Special Keys doesn't work on Fujitsu siemens amilo LI 1718

Bug #250732 reported by Alexandre Otto Strube on 2008-07-22
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Martin Pitt

Bug Description

The special keys of the Fujitsu siemesn amilo LI 1718 doesn't work.

Related branches

Alexandre Otto Strube (surak) wrote :

This is an script found on forums, people are using it to correct the issue.

YoBoY (yoboy-leguesh) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release to see if your hotkeys are working out of the box? Thanks in advance.

John Tait (johntait1-waitrose) wrote :

I have a fujitsu seimens amilo 1718 and I can confirm that Ubuntu 8.10 does not recognise the hotkeys
When I used Ubuntu 7.10 I used a modified version of acerhk thanks to the instructions at http://damagedspline.blogspot.com/
This involved removing Madwifi drivers and using the Ndiswrapper instead with the drivers for windows XP
That should not be neccessary now as the support for the wireless card is now taken care of by the madwifi atheros driver at installation
The problem remains though that the wireless button on the laptop which operates once for wireless on, and then again for wireless off is not recognised and does nothing.
The modification of acerhk forced the module to autowlan=1 and force_series=5020 and in addition modprobe.d was to tell the system to load acerhk at boot ( apparently it would not load the module because the laptop is not recognised as an acer)

The problem is much simplified now though, because as soon as the wireless key can be enabled the setup for wireless will just be a matter using net-applet to configure the network

YoBoY (yoboy-leguesh) wrote :

I'm a little confused with this wireless card addition.

The hotkeys for this computeur are (based on official manual):
Fn+F1 : Suspend
Fn+F3: Sound mute
Fn+F4 : switch screens
Fn+F5/F6 : Sound Up/Down
Fn+F7/F8 : Brightness Up/Down

Hotkeys Easy Launch (wifi on/off, internet, silent mode)

I presume it's the Hotkey Easy Launch for the wifi (and perhaps the others) who don't work like expected. Can you provide us the informations requested at : https://wiki.ubuntu.com/Hotkeys/Troubleshooting ?

Tanks in advance.

Hi
thanks for your Email I will follow the instructions at the
Hotkeys /Troubleshooting link as soon as I can after a clean install of
Ubuntu 8.10 and send you the results. Might be a couple of days but it
will be done
Regards
John

Thanks
  On Tue, 2009-04-14 at 14:47 +0000, YoBoY wrote:
> I'm a little confused with this wireless card addition.
>
> The hotkeys for this computeur are (based on official manual):
> Fn+F1 : Suspend
> Fn+F3: Sound mute
> Fn+F4 : switch screens
> Fn+F5/F6 : Sound Up/Down
> Fn+F7/F8 : Brightness Up/Down
>
> Hotkeys Easy Launch (wifi on/off, internet, silent mode)
>
> I presume it's the Hotkey Easy Launch for the wifi (and perhaps the
> others) who don't work like expected. Can you provide us the
> informations requested at :
> https://wiki.ubuntu.com/Hotkeys/Troubleshooting ?
>
> Tanks in advance.
>

John Tait (johntait1-waitrose) wrote :

hi Yoboy
 I'm not sure where to start with this one so before I post the outputs of xev etc it might be worth saying that the Fujitsi Amilo 1718 Li was sold by big supermarkets namely Tesco etc and so owners trying Ubuntu might not get as far as bug reports etc before giving up but they are out there in large numbers.

The script mentioned by Alexander is a lifesaver for people like me and was written by Assaf Paz originally for a 1600 series amilo and can be found on the amilo forums as well as his damagedspline blog listed above

http://www.amilo-forum.com/topic,929,60,-linux-on-amilo-li-1718.htm

After a clean install of Ubuntu 8.10 and all current updates the Hotkeys that work are all accessed by using the Fn key + another
so
Fn+F1 should be sleep/hibernate this works but a bit too well as nothing will wake the machine up again needs fix
Fn+F3 Mutes sound xev sees this and identifies it also the gnome desktop shows a graphical muted speaker
Fn+F5 Volume up xev sees this identifies it and gnome desktop graphical speaker up shows
Fn+F6 Volume down xev sees this and identifies it gnome desktop shops a graphical speaker down
Fn+F7 brightness up Xev sees something doesn't identify it as brightness no graphical display on desktop but key works
Fn+F8 brightness down xev doen't see at all no graphical display on gnome desktop but key works brightness goes down

now the fancy keys for
wireless
internet
Fan quieten
none of them do anything

Also because Ubuntu 8.10 misidentifies the built in wireless card it knows its atheros but goes for the wrong device id
the script has to fix that.
But here we are concerned with the hotkeys only so looking in /user/share/hotkeys we won't have a suitable entry for the amilo until after the script is run then we have a new entry when we issue the command hotkey -l in a terminal we find fsca16xx.def
which contains the following information

<?xml version="1.0"?>

<definition>

  <config model="Fujitsu-Siemens Amilo A16xx">
    <userdef keycode="129" command="/etc/acpi/fsc-cpuspeed.sh">Cool-n'-Quiet On$
    <userdef keycode="147" command="/etc/acpi/fsc-wireless.sh">Wireless On/Off<$
  </config>

  <contributor>
    <name>Assaf Paz</name>
    <email><email address hidden></email>
  </contributor>

</definition>

hopefully that helps you identify the keys

If you give me some instructions on what you need to fix the keys and identify the model correctly on install I am only too glad to help apparently the fix using acerhk will not work on a 64bit kernel I'm pretty sure Assaf Paz would be a mine of useful information if contacted.

John Tait (johntait1-waitrose) wrote :

just cross referencing this to another bug report

https://bugs.launchpad.net/ubuntu/+source/module-init-tools/+bug/257344/

This was filed by Assaf Paz but it looks as though when it was reassigned from the kernel to the Module-init-tools team they decided not to bother fixing it

John Tait a écrit :
> just cross referencing this to another bug report
>
> https://bugs.launchpad.net/ubuntu/+source/module-init-tools/+bug/257344/
>
> This was filed by Assaf Paz but it looks as though when it was
> reassigned from the kernel to the Module-init-tools team they decided
> not to bother fixing it
>
>
Some screen-shots from John

Steve Langasek (vorlon) wrote :

The script that has been linked to here is specific to the 'acerhk' kernel module, which appears to be obsolete now in favor of the 'acer-wmi' module. Can anyone confirm the current state of this keyboard on Ubuntu 9.10?

Changed in hotkey-setup (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Steve Langasek (vorlon) on 2009-11-08
affects: hotkey-setup (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

If it still does not work on Ubuntu 9.10, please exercise the steps at https://wiki.ubuntu.com/Hotkeys/Troubleshooting to determine at which level your hotkey problems occur, and attach the collected information. Thanks!

roadrash (roadrash) wrote :

The problem with the Atheros AR5007 wireless interface & hotkeys on the Fujitsu Amilo Li1718 has been a problem for quite some time now. Thanks to Assaf Paz over at http://www.amilo-forum.com who wrote the auto install script many Li1718 owners were able to get ubuntu linux working on this laptop. He continued to maintain his script up to the 8.10 Intepid Ibex release. I had to make changes & additions to his script here at http://www.amilo-forum.com/post,9727.html#p8610 to get it working with 9.04 Jaunty. In the case of 9.10 Karmic, for the first time the AR5007 wireless was being detected properly but still could not be turned on because the hotkeys still didn't work. Because of a number of changes in 9.10 Karmic, Assaf's fsca16xx.sh script which I had working with Jaunty didn't work with Karmic. I tried many times to get the acerhk module working in Karmic but was having many problems while browsing for clues I found this article at http://www.edbl.no/karmic/amilo_1718_wireless_in_ubuntu_9.10.txt which when i tested worked perfectly. I simplified the process by writing a small script "amilo-hk-lanon" and posted it here at the amilo forums http://www.amilo-forum.com/post,9727.html#p9708
It would be great if the problem with the hotkeys on this latop could be resolved especially now that the atheros interface now works.

Martin Pitt (pitti) wrote :

> It would be great if the problem with the hotkeys on this latop could be resolved especially now that the atheros interface now
works.

Please see comment #10 for the information that we need.

John Tait (johntait1-waitrose) wrote :

Hi,
 I have finally got a copy of 9.10 installed and will follow this with information as requested

meanwhile here is the info from showkeys when the wireless key is pressed

[411.988162] atkbd.c unknown key pressed translated set2, code 0xd6 on isa0060/serio0
[411.988246] atkbd.c use setkeycodes e056 <keycode> to make it known

[412.397977] atkbd.c use setkeycodes e056 <keycode>to make it known

a few tips on how to collect the necessary info would be welcome if anyone can help I had to write this down and type it into this window (hopefully accurately)

On a version of 8.04 with wireless button working (after using the script ) which I have also installed reports two different keycodes for the same wireless button depending on whether you use xev or showkeys -k to monitor the key press

root@amilo:/home/john# showkey -k
kb mode was RAW
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
keycode 147 press
keycode 147 release

root@amilo:/home/john# xev | sed -n 's/^.*state \([0-9].*\), keycode *\([0-9]\+\) *\(.*\), .*$/keycode \2 = \3, state = \1/p'
keycode 36 = (keysym 0xff0d, Return), state = 0x0
keycode 155 = (keysym 0x1008ff8a, XF86Xfer), state = 0x0
keycode 155 = (keysym 0x1008ff8a, XF86Xfer), state = 0x0
keycode 155 = (keysym 0x1008ff8a, XF86Xfer), state = 0x0
keycode 155 = (keysym 0x1008ff8a, XF86Xfer), state = 0x0

Martin Pitt (pitti) wrote :

John,

thanks for the info. So it seems in Hardy the Wireless key was mapped to KEY_XFER, while it is unmapped now. We should map it to KEY_WIFI (which is the supposed functionality for a wireless switching key). Please also get me an udev dump and your DMI information, as explained in steps 4 and 5 in /usr/share/doc/udev/README.keymap.txt .

Thanks!

John Tait (johntait1-waitrose) wrote :

Hi

John Tait (johntait1-waitrose) wrote :

Hi

John Tait (johntait1-waitrose) wrote :
Download full text (89.5 KiB)

Martin hope this helps

findkeyboards from 9.10
ubuntu@ubuntu:~$ /lib/udev/findkeyboards
AT keyboard: input/event5

root@ubuntu:/# cat /sys/class/dmi/id/product_name
AMILO Li 1718

root@ubuntu:/# cat /sys/class/dmi/id/sys_vendor
FUJITSU SIEMENS

contents of /lib/udev/keymaps

root@ubuntu:/lib/udev# cd keymaps
root@ubuntu:/lib/udev/keymaps# ls
acer inventec-symphony_6.0_7.0
acer-aspire_5920g lenovo-3000
acer-aspire_6920 lenovo-thinkpad_x200_tablet
acer-travelmate_c300 lenovo-thinkpad_x6_tablet
asus maxdata-pro_7000
compaq-e_evo medion-fid2060
dell medionnb-a555
everex-xt5000 micro-star
fujitsu-amilo_pa_2548 module-asus-w3j
fujitsu-amilo_pro_edition_v3505 module-ibm
fujitsu-amilo_pro_v3205 module-lenovo
fujitsu-amilo_si_1520 module-sony
fujitsu-esprimo_mobile_v5 module-sony-old
fujitsu-esprimo_mobile_v6 oqo-model2
hewlett-packard samsung-other
hewlett-packard-2510p_2530p samsung-sq1us
hewlett-packard-compaq_elitebook samsung-sx20s
hewlett-packard-pavilion toshiba-satellite_a100
hewlett-packard-presario-2100 toshiba-satellite_a110
hewlett-packard-tablet zepto-znote
hewlett-packard-tx2

udev-db.txt 9.10
P: /devices/LNXSYSTM:00
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00
E: MODALIAS=acpi:LNXSYSTM:
E: SUBSYSTEM=acpi

P: /devices/LNXSYSTM:00/LNXCPU:00
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/LNXCPU:00
E: DRIVER=processor
E: MODALIAS=acpi:LNXCPU:
E: SUBSYSTEM=acpi

P: /devices/LNXSYSTM:00/LNXCPU:01
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/LNXCPU:01
E: DRIVER=processor
E: MODALIAS=acpi:LNXCPU:
E: SUBSYSTEM=acpi

P: /devices/LNXSYSTM:00/LNXPWRBN:00
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/LNXPWRBN:00
E: DRIVER=button
E: MODALIAS=acpi:LNXPWRBN:
E: SUBSYSTEM=acpi

P: /devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
E: PRODUCT=19/0/1/0
E: NAME="Power Button"
E: PHYS="LNXPWRBN/button/input0"
E: EV==3
E: KEY==100000 0 0 0
E: MODALIAS=input:b0019v0000p0001e0000-e0,1,k74,ramlsfw
E: SUBSYSTEM=input

P: /devices/LNXSYSTM:00/LNXPWRBN:00/input/input0/event0
N: input/event0
S: char/13:64
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input0/event0
E: MAJOR=13
E: MINOR=64
E: DEVNAME=/dev/input/event0
E: SUBSYSTEM=input
E: DMI_VENDOR=FUJITSU SIEMENS
E: DEVLINKS=/dev/char/13:64

P: /devices/LNXSYSTM:00/LNXTHERM:00
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/LNXTHERM:00
E: MODALIAS=acpi:LNXTHERM:
E: SUBSYSTEM=acpi

P: /devices/LNXSYSTM:00/LNXTHERM:00/LNXTHERM:01
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/LNXTHERM:00/LNXTHERM:01
E: DRIVER=thermal
E: MODALIAS=acpi:LNXTHERM:
E: SUBSYSTEM=acpi

P: /devices/LNXSYSTM:00/LNXTHERM:00/LNXTHERM:02
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/LNXTHERM:00/LNXTHERM:02
E: DRIVER=thermal
E: MODALIAS=acpi:LNXTHERM:
E: SUBSYSTEM=acpi

P: /devices/LNXSYSTM:00/device:00
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/device:00
E: SUBSYSTEM=acpi

P: /devices/LN...

Martin Pitt (pitti) wrote :

Fixed in master/7cbbd7e, thanks!

Changed in udev (Ubuntu):
status: Incomplete → Fix Committed
John Tait (johntait1-waitrose) wrote :

Martin
Thanks for your time and help I don't know what master/7cbbd7e means but it sounds promising :)
Sorry about the messy posts #15 #16 #17
If you need anything else I will try to do better
John

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 151-1

---------------
udev (151-1) lucid; urgency=low

  * New upstream release:
    - Support for systems with SYSFS_DEPRECATED=y officially dropped.
    - Bug fixes.
    - Rules updates. LP: #492657, #316215, #259244, #250732.

  * Merge additional fixes from GIT master:
    - Rules updates. LP: #581496, #415023.
    - Fix firmware error reporting.
 -- Scott James Remnant <email address hidden> Wed, 10 Feb 2010 11:50:56 +0000

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers