udev does not include ATA-over-Ethernet rules

Bug #234033 reported by Kain on 2008-05-22
4
Affects Status Importance Assigned to Milestone
aoetools (Ubuntu)
Undecided
Unassigned
udev (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: udev

neither udev nor aoe-tools include a rules entry for the AOE driver, thus aoetools does not work as distributed on Ubuntu Hardy.

a 60-aoe.rules such as follows can be included:

# These rules tell udev what device nodes to create for aoe support.
# They may be installed along the following lines. Check the section
# 8 udev manpage to see whether your udev supports SUBSYSTEM, and
# whether it uses one or two equal signs for SUBSYSTEM and KERNEL.

# aoe char devices
SUBSYSTEM=="aoe", KERNEL=="discover", NAME="etherd/%k", GROUP="disk", MODE="0220"
SUBSYSTEM=="aoe", KERNEL=="err", NAME="etherd/%k", GROUP="disk", MODE="0440"
SUBSYSTEM=="aoe", KERNEL=="interfaces", NAME="etherd/%k", GROUP="disk", MODE="0220"
SUBSYSTEM=="aoe", KERNEL=="revalidate", NAME="etherd/%k", GROUP="disk", MODE="0220"
SUBSYSTEM=="aoe", KERNEL=="flush", NAME="etherd/%k", GROUP="disk", MODE="0220"

# aoe block devices
KERNEL=="etherd*", NAME="%k", GROUP="disk"

Changed in udev:
importance: Undecided → Wishlist
status: New → Confirmed
Nuno Silva (nuno-nunosilva) wrote :

Without these rules you can't use aoe-discover or aoe-revalidate, so it's more than a wishlist item, at least for people using AoE.
(The nodes are still created, but in /dev/ instead of /dev/etherd, so it's also a good think for others because /dev is cleaner)

These rules work fine. Please include them.
Thanks!

These are part of the upstream ruleset for 136, which is in jaunty

Changed in udev:
status: Confirmed → Fix Released
Changed in aoetools:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers