Ubuntu

/dev/dvd and /dev/cdrom symlink removed in Hardy

Reported by Jonas Norlander on 2008-04-28
18
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: udev

I guess this is udev related.

After i upgraded my Gutsy box to Hardy i saw that my dvd device that used to be on /dev/hda was now on /dev/scd0.
And the usually default symlinks /dev/dvd, /dev/dvdrw and /dev/cdrom didn't exist instead i got this symlinks:
lrwxrwxrwx 1 root root 4 2008-04-28 08:59 /dev/cdrom3 -> scd0
lrwxrwxrwx 1 root root 4 2008-04-28 08:59 /dev/cdrw3 -> scd0
lrwxrwxrwx 1 root root 4 2008-04-28 08:59 /dev/dvd3 -> scd0
lrwxrwxrwx 1 root root 4 2008-04-28 08:59 /dev/dvdrw3 -> scd0
brw-rw----+ 1 root cdrom 11, 0 2008-04-28 10:59 /dev/scd0

I have only one dvd drive and it's master on the first IDE port. Used to be /dev/hda.
For me Kaffein and other xine program stopped work as they could not open /dev/dvd.

Jonas Norlander (jonorland) wrote :

Tracked down the cause to this to the /etc/udev/rules.d/70-persistent-cd.rules. With the upgrade to Hardy and a new kernel
my DVD drive moved from pci-0000:00:04.0-ide-0:0 to pci-0000:00:04.0-scsi-0:0:0:0 so new rules was created.

Removing /etc/udev/rules.d/70-persistent-cd.rules and reboot will recreate the file with default udev rules and the
cdrom, cdrw, dvd and dvdrw symlinks will be restored and pointing to the right device.

The number of people that appear to be affected by this are somewhat low, and snce the release is already out, it's "too late" to fix -- the workaround you used is the correct one, and we'll ensure this is documented

Changed in udev:
status: New → Won't Fix
Bill Gjestvang (bgjestvang) wrote :

I ran into this after swapping out my DVD drive, under the latest hardy.

Paweł Tęcza (ptecza) wrote :

affected_people++;

Thanks a lot for the hint! It really works and now I can use my DVD again :)

Aaron Whitehouse (luna-tick) wrote :

Will this fix be applied to intrepid?

I'm no developer and work the console like a taxi-driver doing heart surgery, but this worked and you are friggidy awesome. My hamsters' next offspring will proudly bear the name Jonas.

Same thing happened for me in upgrade to 9.10, so I did the following:

sudo mv /etc/udev/rules.d/70-persistent-cd.rules /etc/udev/rules.d/70-persistent-cd.rules.disable

Rebooted machine

And now I can see the following links under /dev

/dev/cdrom
/dev/cdrw
...
/dev/dvd
/dev/dvdrw

All pointing to the correct sr0 device.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers