[dapper->hardy] udev not upgraded (was: using kernel 2.6.24-12 after upgrading from dapper to hardy isn't possible)

Bug #203756 reported by Brian Murray on 2008-03-18
14
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: update-manager

I was upgrading from dapper to hardy today and the upgrade seemed successful. However, when I boot the 2.6.24-12 kernel the system is unusable - even in single user mode.

Related branches

Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :

Bug 203385 has some information about how using friendly-recovery isn't really possible.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

It looks like the problem is the following:

2008-03-18 10:59:41,931 DEBUG Held-back: gnome-games-data udev lvm2 mdadm dmsetup xserver-xorg-input-synaptics python-launchpad-integration rhythmbox

Changed in update-manager:
importance: Undecided → High
milestone: none → ubuntu-8.04-beta
status: New → Confirmed
Albert Damen (albrt) wrote :

I got the same problem after an LTS upgrade in kvm. After manually upgrading udev, I could login in gnome again.
There still is some problem: hal did not start due to missing symlinks in rcX.d Manually starting hal works ok.

Michael Vogt (mvo) wrote :

@Albert: thanks for this additional information. The fix for udev should be in the archive once it gets unfrozen. I will try to reproduce the hal problem you mentioned in my next test-run.

Changed in update-manager:
assignee: nobody → mvo
status: Confirmed → Fix Committed
Steve Langasek (vorlon) wrote :

I believe this is now fixed in udev, but the bug report was not auto-closed because the bug was assigned to the wrong package. Changelog was:

udev (117-4ubuntu1) hardy; urgency=low

 * change the "Breaks: libdevmapper1.02" to a Conflict to help
    the apt resolver calculating the upgrade (LP: #203756)

 -- Michael Vogt < <email address hidden>> Wed, 19 Mar 2008 16:27:39 +0100

Changed in update-manager:
status: Fix Committed → Fix Released
Albert Damen (albrt) wrote :

Confirming the fix of udev and hal. I just completed a new LTS upgrade in kvm. This time I could login in Gnome without problems and hal was running.

hal (0.5.10+git20080301-1ubuntu3) hardy; urgency=low

  * debian/hal.postinst:
    - make sure that the start scripts are installed on
      dapper->hardy upgrades (LP: #203756)

 -- Michael Vogt <email address hidden> Thu, 20 Mar 2008 10:17:43 +0100

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers