Ubuntu

User has no privilege to access /dev/raw1394

Reported by Lionel Dricot on 2008-02-28
4
Affects Status Importance Assigned to Milestone
kino (Ubuntu)
Undecided
Unassigned
udev (Baltix)
Undecided
Unassigned
udev (Ubuntu)
Wishlist
Unassigned

Bug Description

EDIT : as this bug cannot be solved in udev ( see bug #20567 ), kino should by default use /dev/video1394 or dv1394 without the need for any configuration.

All video software that use raw1394 should be affected.
*****

Binary package hint: pmount

On a nearly fresh Gutsy :

- Plug a firewire DV camera in
- The user cannot access to it with dvgrab (or kino)
- Add user to the disk group and logout/login
- The user has access to the camera

Because of bug #10156 , it seems that we cannot imagine to add the user to the disk group by default. So this bug has to be solved in any other way.

#109761 might be related but I'm not sure.

Changed in pmount:
importance: Undecided → Wishlist
Lionel Dricot (ploum) wrote :

I don't understand the "wishlist" rating. It's a bug : an average user plug his camera and it doesn't work. When something "doesn't work", we are far beyond the wishlist rating. It's not critical but it's still a bug.

Oliver Grawert (ogra) wrote :

i would think thats a udev probelm rather than a pmount one, whats the exact device you need the disk group for ? if its distinctly owned by cameras and video devices we could easily add a rule to make it owned by the video group, if its not exclusively a camera and video device that might get a more complex feature though and rather be intrepid stuff.

Lionel Dricot (ploum) wrote :

Oliver > It's really a camcorder only so it makes a lot more sense to add it to the video group.

I have this bug with two completely different firewire DV camcorder so I'm enclined to think that it affects every Firewire camcorder.

What informations do you need to put this in the video group instead of the disk one ? If this is a group stuff, you are right, I will reassign it to udev.

Oliver Grawert (ogra) wrote :

plug in a camera directly after doing a fresh boot and attach /var/log/udev and the output of dmesg, that should show which device it is you need access to.

Lionel Dricot (ploum) wrote :
Lionel Dricot (ploum) wrote :
antistress (antistress) wrote :

i confirm that BUG with two differents camcorder (CANON & PANASONIC)

antistress (antistress) wrote :

See also http://www.linux.com/feature/119492
"ecause Kino uses dvgrab to capture video, you'll either need to run it as root, tweak permissions for the 1394 device, or add your user to the video group. The last method is the preferred solution, as the first two may create insecurity. If you're running Ubuntu 7.04, you'll also need to edit /etc/udev/rules.d/40-permissions.rules to change the line that begins KERNEL=="raw1394" to end with GROUP="video" instead of GROUP="disk". You may need to log out and log back in for the changes to take effect. "

See past udev bugs.

Raw ieee1394 device access will *NEVER* be permitted for ordinary users.

Changed in udev:
status: New → Won't Fix
Lionel Dricot (ploum) wrote :

Scott > well, I don't know how to solve this, but this bug has to be solved one way or another. Currently, most users will not be able to use their DV camera on Ubuntu.

From an end-user point of view, it's exactly the same as an USB camera : you plug it, you should be able to access it. It might not be raw access but Kino (and any other video editing tool) should access it. Unless an user can access it, this bug is *not* fixed.

By closing this, you will only have more and more duplicate.

(note : I've never said that the fix has to happen in udev or anything. I just want to point out that users cannot access a DV camera under Ubuntu and that's a (big) bug )

Lionel Dricot (ploum) on 2008-04-02
description: updated

Yes, and that bug is open elsewhere where it belongs - on the kernel

I just ran into this one as well.

Kino is included in the Main repo, but is broken by default. I was in a hurry, and did a 'chmod 777 /dev/raw1394' to capture video, but your average user is going to be lost on this one. I noticed an old bug (#6290) was marked as fixed for this problem.

Strangely, even though the 'disk' group has rw, adding the user to that group didn't seem to help. Also, the admin user isn't added to this group be default during install.

There's really zero chance of users being given right to raw1394 in Ubuntu. So there's not much to say on this bug, maybe bug #152392 is more relevant?

Thanks Duncan,

I agree that a user shouldn't have access to raw1394. I was looking for an existing bug to post too, and this was the only one I could find. Maybe this should be merged with #152392, as most users hitting this will be having dv capture issues.

@James: Okay, I've marked this as a duplicate of bug #152392 because I think that what Lionel was originally pointing out was that users can't capture from their dv over firewire, he assumed that should be done using raw1394, which happens to be a wrong assumption.
@Lionel: Would you consider this fair or do you still think users should _by default_ have access to raw1394? Please edit this bug's description suitably.

Lionel Dricot (ploum) wrote :

@Duncan : you are right to mark it as a duplicate. The bug is : "Kino should have plug-n-play access to DV camera (including DV control)". Users do not care if it is /dev/raw1394 or /dev/video1394. Has you pointed out, I made a false assumption when writing this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers