Incomplete multimedia key support for CHICONY Compaq USB Keyboard

Bug #162178 reported by Fred on 2007-11-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Martin Pitt

Bug Description

I am using Ubuntu 7.10 Gutsy Gibbon.

I have some kind of HP keyboard (model number: KU-0133).
It has internet/multimeda-keys, but only 1 of them work.

It has 8 keys, but only the Mail-key works which brings up Evolution Mail.
The Search-key, Home-key, Information-key, People-key, and the other keys does not work. Nothing happens when I press them.

Nanley Chery (nanoman) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in gnome-power-manaager.

Changed in gnome-power-manager:
status: Confirmed → New
Fred (eldmannen+launchpad) wrote :

I am new to Ubuntu, and I have no idea what package it is.

Thank you for your bug report. Could you please follow https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch to indicate us what keys do not work and what they are supposed to do ? Thank you.
.

Changed in gnome-power-manager:
status: New → Incomplete
Fred (eldmannen+launchpad) wrote :

Jérôme Guelfucci,
its a normal keyboard for a normal computer.
It is not a laptop.

Fred (eldmannen+launchpad) wrote :

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

Key 1 - looks like an "i" with a ring in it, i think it means "information" or something. - does nothing, i get no keycode :(
Key 2 - looks like a house - 0xb2 (correctly mapped to web browser)
Key 3 - looks like a magnifier - 0xe5 (correctly mapped to search (Tracker Search Tool))
Key 4 - looks like a letter (mail) - 0xec (correctly mapped to Linux email client)
Key 5 - looks like 3 people (maybe its for instant messaging chat) - does nothing, i get no keycode :(
Key 6 - looks like a diagram graph (maybe its for finance?) - does nothing, i get no keycode :(
Key 7 - looks like 3 people and a round table (maybe its for conferencing) - does nothing, i get no keycode :(
Key 8 - looks like a guy reading the newspaper - does nothing, i get no keycode :(

When I wrote first post, I was using Ubuntu 7.10, but now I am using Ubuntu 8.04 (Alpha4+updates).
In 7.10 only 1 key worked (mail).
In 8.04 more keys work, now works 3 keys (key 2,3,4 - house/browser, magnifier/trackersearch, letter/evolutionmail).
But still some keys don't work. 5 keys don't work. Key 1,5,6,7,8.
And they don't even generate a keycode when I press them (in Keyboard Shortcuts application).

Fred (eldmannen+launchpad) wrote :

Might be any of these, but I have no clue.

0x9c
0xe0 0x32 0xe0 0xb2
0x1d 0x2e
0xae
0x2d
0xad 0x2c
0xac
0x9d

Leaving this as new, without the keycodes we can't do anything.

Changed in hotkey-setup:
status: Incomplete → New
Fred (eldmannen+launchpad) wrote :

$ cat /proc/bus/input/devices
...
I: Bus=0003 Vendor=049f Product=0051 Version=0110
N: Name="CHICONY Compaq USB Keyboard"
P: Phys=usb-0000:00:1a.0-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1:1.0/input/input1
U: Uniq=
H: Handlers=kbd event1
B: EV=120013
B: KEY=10000 7 ff9f207a c14057ff febeffdf ffefffff ffffffff fffffffe
B: MSC=10
B: LED=7

I: Bus=0003 Vendor=049f Product=0051 Version=0110
N: Name="CHICONY Compaq USB Keyboard"
P: Phys=usb-0000:00:1a.0-1/input1
S: Sysfs=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1:1.1/input/input2
U: Uniq=
H: Handlers=kbd event2
B: EV=13
B: KEY=2000000 1000 8000000 0 0 0 0
B: MSC=10
...

Fred (eldmannen+launchpad) wrote :

Ubuntu 8.10 "Intrepid Ibex" (alpha)

Key 1 (information) - nothing
Key 2 (house) - works (home directory)
Key 3 (magnify glass) - works (tracker search tool)
Key 4 (letter) - works (evolution)
Key 5 (people) nothing
Key 6 (diagram graph) - nothing
Key 7 (conference table) - nothing
Key 8 (guy reading book) - nothing

Fred (eldmannen+launchpad) wrote :

https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch
Method 3 don't work, no ACPI output.
Method 4 works, but not so good.

Key 1 - No output
Key 2 - 180 XF86HomePage
Key 3 - No output (this key works though, and brings up Tracker Search Tool)
Key 4 - No output (this key works though, and brings up Evolution)
Key 5 - No output
Key 6 - No output
Key 7 - No output
Key 8 - No output

Fred (eldmannen+launchpad) wrote :

Method 2:

Key 1 - No capture
Key 2 - Works (XF86HomePage)
Key 3 - Works (XF86Search)
Key 4 - Works (XF86Mail)
Key 5 - No capture
Key 6 - No capture
Key 7 - No capture
Key 8 - No capture

Maybe my keyboard just sucks.

klap-in (klap-in) wrote :

Here my story is quite the same. I have a Chicony Keyboard (KB-9885) and have had many versions of ubuntu. Most times some keys are working, but never all. I have tried keyTouch during early releases of Ubuntu, but you can only use the options they have defined. And not the other options available in the hotkey-configuration program of ubuntu.

Now I use Ubuntu 9.04 . Hotkey is at this moment succesfull in detecting each button and in predicting which fuction each key has. But after running it Ubuntu is succesfull in detecting my hotkeys, while first not!

First I run 'Gnome-keybinding-properties' this didn't sees all the buttons and exchange some of the other keys. Next I install KeyTouch-editor and KeyTouch. After running Keytouch-editor (this founds my keys without problems) and Keytouch (This don't result in more working keys...) I tried again 'Gnome-keybinding-properties' and just now it sees all my mediakeys and everything is perfect... So I am happy!

I have the following buttons:

Symbol - scancode of KeyTouch-editor
Volume Down - 153
Mute - 146
Volume Up - 163
Previous song - 162
Stop - 164
Play/Pause - 161
Next Song - 160
Wake up - 227
Sleep - 223
Power - 222
WWW - 178
E-mail - 151
Prog 1 - 176
Prog 2 - 166
Prog 3 - 174
Back - 165
Forward - 158

Steve Langasek (vorlon) wrote :

It sounds like in 9.04 and above, things are most of the way there.

For each key that does not work by default in Ubuntu 9.10, please follow the instructions in the "Fix broken keys" section of /usr/share/doc/udev/README.keymap.txt and post the results here.

affects: hotkey-setup (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
status: New → Incomplete
summary: - Only 1 multimedia keys on keyboard work
+ Incomplete multimedia key support for CHICONY Compaq USB Keyboard
Fred (eldmannen+launchpad) wrote :

That particular keyboard I had did break.
Now I am using another keyboard.
I cant test it.

Changed in udev (Ubuntu):
importance: Low → Medium
assignee: nobody → Martin Pitt (pitti)
klap-in (klap-in) wrote :

I use today ubuntu 9.10 and have again keys which were not working. I can try possibly the same tric as i explained in message 2009-06-02, but haven't do so yet todays.

When you like to get more info from my situation, i can supply it, when you ask.

Steve Langasek (vorlon) wrote :

klap-in,

Yes: for each key that does not work by default in Ubuntu 9.10, please follow the instructions in the "Fix broken keys" section of /usr/share/doc/udev/README.keymap.txt and post the results here.

Martin Pitt (pitti) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in udev (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers