Missing /dev/cdrom symlink

Bug #12491 reported by Andrew Conkling on 2005-02-03
24
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Jeff Bailey

Bug Description

I've had no luck getting audio CDs to work. I've tried upgrading to hoary,
tried switching kernel images... nothing. Data CDs work just fine--they mount
and read--but I've gotten no media application, including the included CD player
in gnome-media, to play my audio CDs. I'm not sure where to turn for any
pertinent error messages, but here are the kernel images I've tried to use thus far:
linux-386
linux-686 (currently, using 2.6.10-3)

Thanks in advance!

Matt Zimmerman (mdz) wrote :

Is your CD-ROM drive wired to your sound card? Or is it necessary to play using
CDDA?

Andrew Conkling (andrewski) wrote :

I think my drive is wired to my card, but I'm not sure. All I know is that it
works in my parallel install of Gentoo just fine (I confirmed today) but not in
Ubuntu. Any info you want me to post?

Matt Zimmerman (mdz) wrote :

What happens when you try? do you get an error? do you hear any sound? did
you check the volume levels in the mixer?

Andrew Conkling (andrewski) wrote :

I figured out the problem: there was no /dev/cdrom. (Only grip gave me any
information upon error, and I hadn't thought to try that before.) I created the
symlink myself and now it works fine.

FWIW, I'm using udev-0.050-3ubuntu3. Let me know if any more information would
be useful in helping this not be a problem for others.

Matt Zimmerman (mdz) wrote :

If it wasn't created for you, that's a bug.

What does /proc/sys/dev/cdrom/info say?

Does "sudo udevstart" create the symlink if it doesn't exist?

Andrew Conkling (andrewski) wrote :

root@LinuxLand:/home/andrew # cat /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name: hdd hdc
drive speed: 40 20
drive # of slots: 1 1
Can close tray: 1 1
Can open tray: 1 1
Can lock tray: 1 1
Can change speed: 1 1
Can select disk: 0 0
Can read multisession: 1 1
Can read MCN: 1 1
Reports media changed: 1 1
Can play audio: 1 1
Can write CD-R: 1 0
Can write CD-RW: 1 0
Can read DVD: 0 1
Can write DVD-R: 0 0
Can write DVD-RAM: 0 0
Can read MRW: 1 0
Can write MRW: 1 0
Can write RAM: 1 0

No, udevstart does not create the symlink for me; I tried deleting it and
invoking the command, but to no avail.

Andrew Conkling (andrewski) wrote :

Also and additionally, I must recreate these symlinks on every boot. I'm not
surprised, but I wanted to make sure that was included so it could be rectified
when the pest control arrives. :-)

Cheers.

Ji Yu (noizezone) wrote :

As of version udev-0.050-3ubuntu3, the installation put only one symlink entry
under the /etc/udev/rules.d/ directory, which points to /etc/udev/udev.rules.
This configuration won't create /dev/cdrom link automatically. The packager
should consider adding extra symlink, either to /etc/udev/simple-cd-alias.rules
 or to /etc/udev/cd-alias.rules (both of which are installed already, just not
linked). This will solve the problem

Jeff Bailey (jbailey) wrote :

Hi! I've done an install test of the udev package, and it seems fine. I also
double checked with Martin Pitt who just did an Array 6 install, and neither of
us see this bug.

I'm going to close it for now and watch for another report of the same.
Hopefully it was just a one time bug with the package version uploaded back then.

Tks,
Jeff Bailey

Andrew Conkling (andrewski) wrote :

Hi Jeff,
I have been staying with Hoary's upgrades but this problem persists. I'm
assuming at this point that a fresh install of the recent packages would not
have this problem but, since I installed from Warty about two months ago, I will
still see this problem. How do I fix it?

Jeff Bailey (jbailey) wrote :

I've asked for a note to the release notes about this too. Do the command:

sudo ln -s ../cd-aliases.rules /etc/udev/rules.d

and reboot.

Andrew Conkling (andrewski) wrote :

OK, that helps, but it sets my primary device (/dev/cdrom) as my CD-RW, but I
want to use my DVD-ROM. I tried searching the cd* files but didn't find
anything I could change. Can anyone point me in the right direction?

Jeff Bailey (jbailey) wrote :

Udev should be configured to show your drives as /dev/cdrw and /dev/dvd for
friendly names. For /dev/cdrom it makes a best guess effort. It doesn't look
like the config file allows an easy override. Does this meet your needs?

Tks,
Jeff Bailey

Jeff Bailey (jbailey) wrote :

*** Bug 14130 has been marked as a duplicate of this bug. ***

sam tygier (samtygier) wrote :

i just upgraded a laptop from warty to hoary and found that the /dev/dvd was not
being created.

this bug seems not to be fixed.

i manually made a symbolic link, but from reading a bit more now it seems that
that would need to be done at every boot.

the work around is mentioned on the hoary upgrade page in the wiki.

could we have a udev update that fixes this?

Mario Vukelic (kreuzsakra) wrote :

Just make a link for the cd-aliases.rules in the udev rules directory. I.e.,

sudo ln -s /etc/udev/cd-aliases.rules /etc/udev/rules.d

You only have to do this once, not on every boot. Jeff Bailey said that for some
reason this can't be done automatically when the upgrade from Warty is made

sam tygier (samtygier) wrote :

so really it is "resolved - wontfix"

i dont really see why apt cant make a symbolic link (or run a script that does),
but if it is not possible then fair enough.

Matt Zimmerman (mdz) wrote :

*** Bug 16611 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.