upgrade Feisty to Gutsy gnome startup failed due wrong /dev/null permission

Bug #122062 reported by marcobra (Marco Braida) on 2007-06-25
4
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned

Bug Description

Upgrading from Feisty to Gutsy on 2 pc Gutsy gnome don't start i get always /dev/null permission problem at startup.

In Gutsty i do this steps:

1) I start the pc
2) a graphical terminal windows give me this italian message at startup
Bash: /dev/null : permesso negato (denied permission)
3) Working from that showed terminal window i do a sudo chmod 777 /dev/null
4) I press ctrl+alt+bkspace
5) I can make a regular login
6) All work fine, but at next restart i have the same problem

HTH

Thanks for your bug report. From the graphical terminal window, please check the output of this command:

grep null /etc/udev/rules.d/40-permissions.rules

The output should be something like this:
KERNEL=="null", MODE="0666"

Thank you for the check here my output of your requested command:

danilo@ubuntu:~$ grep null /etc/udev/rules.d/40-permissions.rules
KERNEL=="null", MODE="0666"

It seems ok.
Still in problem with this not blocking issue :-(

At startup /dev/null permission are:

crw------- 1 root root 1, 3 2007-06-17 18:39 /dev/null

HTH

I reinstalled Ubuntu Feisty from setup cd. I update it i rebooted and all was fine.
I try to upgrade Gutsy from command line with
sudo update-manager -c -d
and i get this error
warning: could not initiate dbus
could not send the dbus Inhibit signal: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

No upgrade was made.

I reboot the pc and i see again the /dev/null permission error at startup.

HTH

description: updated
sandoz (sandoz) wrote :

I had the same problem, but I think it was due to a failing of the upgrade manager during installation. A by-hand "apt-get update" and "dpkg-configure -a" did not all the stuff the update manager would have made I guess. Especially evms was not reinstalled, so that the udevd was making trouble, maybe the restart of changed the permissions of /dev/null - but I am not sure.

A reboot helped and I guess a "sudo chmod 0666 /dev/null" would help too.

Regards,
sandoz

I still have this issue but i have put into /etc/rc.local

chmod 0666 /dev/null

And this workaround make Ubuntu gdm starting good

HTH

Wim (wimvandender) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 63031 (which has a fix released), so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Changed in update-manager:
status: New → Fix Released

On Thu, 2008-09-25 at 14:48 +0000, Launchpad Bug Tracker wrote:

> Upgrading from Feisty to Gutsy on 2 pc Gutsy gnome don't start i get
> always /dev/null permission problem at startup.
>
This is almost always caused by sysadmin error causing udev to be run
multiple times in the boot sequence.

Check /etc/rc[2-5].d for S*udev and remove.

Scott
--
Scott James Remnant
<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers