cd drive opens by itself

Bug #1068575 reported by AlainKnaff on 2012-10-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Unassigned

Bug Description

After upgrading from 10.04 to 12.04 I noticed that every 10 minutes, my second CD-ROM drive (/dev/sr1) opens its tray.

At this very instant udev shows some activity, so I believe that udev is triggering this. Interestingly enough, this doesn't happen to /dev/sr0.

Other people seem to have experienced the same thing in 11.04:
http://askubuntu.com/questions/67569/what-is-opening-closing-cd-tray

Unfortunately, that problem has been "closed as too localized". WTF?
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: alain 21570 F.... pulseaudio
 /dev/snd/controlC0: alain 21570 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe020000 irq 16'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,10438232,00100002'
   Controls : 37
   Simple ctrls : 21
Card1.Amixer.info:
 Card hw:1 'Audio'/'C-Media INC. C-Media USB Audio at usb-0000:00:13.1-1.2, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB0d8c:0103'
   Controls : 3
   Simple ctrls : 2
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=c38c446b-65ae-46d8-8a18-be3d0ec158ba
MachineType: System manufacturer System Product Name
Package: linux (not installed)
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-31-generic root=UUID=d1cc6452-8f6a-4b27-83db-0108b012e8dd ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-31-generic N/A
 linux-backports-modules-3.2.0-31-generic N/A
 linux-firmware 1.79.1
RfKill: Error: [Errno 2] No such file or directory
Tags: precise
Uname: Linux 3.2.0-31-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-10-06 (12 days ago)
UserGroups: adm admin audio cdrom cvs dialout dip disk floppy kqemu kvm libvirtd lpadmin netdev plugdev powerdev scanner video
WpaSupplicantLog:

dmi.bios.date: 07/19/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2A-VM ACPI BIOS Revision 1002
dmi.board.name: M2A-VM
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2A-VMACPIBIOSRevision1002:bd07/19/2007:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2A-VM:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

AlainKnaff (kubuntu-misc) wrote :
AlainKnaff (kubuntu-misc) wrote :
AlainKnaff (kubuntu-misc) wrote :
AlainKnaff (kubuntu-misc) wrote :
AlainKnaff (kubuntu-misc) wrote :
AlainKnaff (kubuntu-misc) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1068575

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected precise
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

affects: linux (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
status: Incomplete → New
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.7 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc1-quantal/

Changed in udev (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
AlainKnaff (kubuntu-misc) wrote :

Just tested with 3.7.0-999-generic, and the problem still happens

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in udev (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.