Ubuntu

[Dell Latitude D430] recent hid2hci upgrade breaks docking station USB input devices

Reported by Martin Pitt on 2009-06-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udev
Fix Released
Undecided
Martin Pitt
udev-extras (Ubuntu)
High
Martin Pitt
Karmic
High
Martin Pitt

Bug Description

Binary package hint: udev-extras

I have a Dell Latitude D432 on an EURO-1 docking station. Since yesterday's upgrades, external USB mouse/keyboard don't work any more, they stop working during boot (udevadm trigger, I think) with some error messages about "cannot access device", and then keyboard and mouse get powered off. I don't get the issue without the docking station, all USB devices work fine when being connected directly on the laptop.

I tracked this down to the hid2hci rule change in http://bazaar.launchpad.net/~ubuntu-core-dev/udev-extras/ubuntu/revision/138

This is meant to do something with bluetooth devices, but apparently catches my USB input devices on the docking station.

ProblemType: Bug
Architecture: amd64
CustomUdevRuleFiles: 95-calibre.rules
Date: Thu Jun 25 16:42:57 2009
DistroRelease: Ubuntu 9.10
MachineType: Dell Inc. Latitude D430
Package: udev-extras 20090615+1-3 [modified: lib/udev/rules.d/62-hid2hci.rules]
ProcCmdLine: root=UUID=793b0aea-cd13-4379-bc6e-e72fd2620cdd ro quiet
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-10.12-generic
SourcePackage: udev-extras
Uname: Linux 2.6.30-10-generic x86_64
dmi.bios.date: 05/21/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: 0HU754
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd05/21/2007:svnDellInc.:pnLatitudeD430:pvr:rvnDellInc.:rn0HU754:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D430
dmi.sys.vendor: Dell Inc.

Martin Pitt (pitti) wrote :
Changed in udev-extras (Ubuntu):
assignee: nobody → Mario Limonciello (superm1)
importance: Undecided → High
Martin Pitt (pitti) wrote :

The second hunk is irrelevant, but this change seems to have triggered it:

-KERNEL=="mouse*", SUBSYSTEMS=="usb", ATTRS{idVendor}=="413c", ATTRS{bmAttributes}=="e0", \
+ATTR{bInterfaceProtocol}=="02", ATTRS{idVendor}=="413c", ATTRS{bmAttributes}=="e0", \
     RUN+="hid2hci --method dell -v $attr{idVendor} -p $attr{idProduct} --mode hci"

I guess what happens it that hid2hci is now called on this device.

First, my USB input devices:

  keyboard: /devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8.1/1-8.1.2/1-8.1.2:1.1/input/input8/event8
  mouse: /devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8.1/1-8.1.3/1-8.1.3:1.0/input/input9/event9

So let's check what this rule is called on:

$ udevadm trigger --dry-run --subsystem-match=usb --attr-match=bInterfaceProtocol=02 --verbose
/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8.1/1-8.1.3/1-8.1.3:1.0
/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8:1.0

/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8:1.0 is apparently the docking station's USB hub, in attached UdevDb.txt you see that the USB mouse/keyboard are attached to this.

/devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8.1/1-8.1.3/1-8.1.3:1.0 is the mouse (which is connected to the keyboard's builtin USB hub).

ATTRS{idVendor}=="413c", ATTRS{bmAttributes}=="e0" matches on a far-out parent device:

  looking at parent device '/devices/pci0000:00/0000:00:1d.7/usb1/1-8':
    KERNELS=="1-8"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{configuration}==""
    ATTRS{bNumInterfaces}==" 1"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bmAttributes}=="e0"
    ATTRS{bMaxPower}=="100mA"
    ATTRS{urbnum}=="71"
    ATTRS{idVendor}=="413c"
    ATTRS{idProduct}=="0058"
    ATTRS{bcdDevice}=="0000"
    ATTRS{bDeviceClass}=="09"
    ATTRS{bDeviceSubClass}=="00"
    ATTRS{bDeviceProtocol}=="02"
    ATTRS{bNumConfigurations}=="1"
    ATTRS{bMaxPacketSize0}=="64"
    ATTRS{speed}=="480"
    ATTRS{busnum}=="1"
    ATTRS{devnum}=="3"
    ATTRS{version}==" 2.00"
    ATTRS{maxchild}=="4"
    ATTRS{quirks}=="0x0"
    ATTRS{authorized}=="1"

so just because I have a Dell USB hub somewhere, all devices attached to it with bInterfaceProtocol==02 get treated by this hid2hci program. Apparently this rule is way too wide.

You need to check ATTR{bInterfaceClass} and ATTR{bInterfaceSubClass}, to make sure that bInterfaceProtocol=="02" actually has some meaning. E. g., as http://www.usb.org/developers/defined_class shows, interface class 09, subclass 00, interface protocol 02 is a hi-speed USB. I don't think these are intended to match here. You probably want class E0, subclass 01 or 02 (I don't know what these rules are actually supposed to do), but these are bluetooth devices.

Martin Pitt (pitti) wrote :

Mario, can you please check what these rules are meant to do, and test whether the proposed interface class/subclass matches work for you?

Changed in udev-extras (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) wrote :

I verified that this rule unbreaks my computer. Can you please test if this works as intended? if not, try changing DeviceSubClass to 01.

ATTR{bDeviceClass}=="e0", ATTR{bDeviceSubClass}=="00", ATTR{bInterfaceProtocol}=="02", ATTRS{idVendor}=="413c", ATTRS{bmAttributes}=="e0", \

Martin Pitt (pitti) wrote :

erm, I meant bDeviceSubClass 01 or 02. Just check udevadm info.

tags: added: regression-potential
Changed in udev-extras (Ubuntu Karmic):
milestone: none → karmic-alpha-3
Martin Pitt (pitti) wrote :

Once this is sorted out, I'll take care of committing the fix to upstream udev.

Changed in udev:
assignee: nobody → Martin Pitt (pitti)
status: New → Confirmed
  • walk.out Edit (3.8 KiB, application/octet-stream; name="walk.out")

Hi Martin:

Your proposed rule unfortunately breaks for me still. Did you mix up
DeviceClass and InterfaceClass?

Can you try this proposed rule instead:

ATTR{bInterfaceClass}=="03", ATTR{bInterfaceSubClass}=="01",
ATTR{bInterfaceProtocol}=="02", ATTRS{idVendor}=="413c", \
    ATTRS{bmAttributes}=="e0", \
    RUN+="hid2hci --method dell -v $attr{idVendor} -p $attr{idProduct}
--mode hci"

That still works for me. If not, attached is the attribute-walk for the
device in question in case a better idea to match on sticks out.

On Thu, Jun 25, 2009 at 10:24, Martin Pitt <email address hidden> wrote:

> Once this is sorted out, I'll take care of committing the fix to
> upstream udev.
>
> ** Changed in: udev
> Status: New => Confirmed
>
> ** Changed in: udev
> Assignee: (unassigned) => Martin Pitt (pitti)
>
> --
> [Dell Latitude D430] recent hid2hci upgrade breaks docking station USB
> input devices
> https://bugs.launchpad.net/bugs/392144
> You received this bug notification because you are a bug assignee.
>

--
Mario Limonciello
<email address hidden>

Martin Pitt (pitti) wrote :

Ah, thanks Mario. I think for safety I'll additionally use this field in the USB spec:

  00h Device Use class information in the Interface Descriptors

Changed in udev-extras (Ubuntu Karmic):
assignee: Mario Limonciello (superm1) → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :
Changed in udev:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev-extras - 20090615+1-4

---------------
udev-extras (20090615+1-4) karmic; urgency=low

  * hid2hci/62-hid2hci.rules: The previous rules just checked
    bInterfaceProtocol but not the actual device and interface class. This
    caused the hci rules to be applied for Dell USB hubs and attached input
    devices like keyboards and mouses as well, breaking them completely.
    Tighten the match to also check device and interface class/subclass.
    (Patch also committed to udev trunk). (LP: #392144)

 -- Martin Pitt <email address hidden> Fri, 26 Jun 2009 08:24:48 +0200

Changed in udev-extras (Ubuntu Karmic):
status: Triaged → Fix Released
Ryan (ubuntu-draziw) wrote :

Hi,

I have a 'funky' issue with USB on my Dell Latitude D620 too. I'm on a docking station, a USB cable going from that to a Dell 1905 LCD, and that going to a USB Microsoft Ergo keyboard and mouse. At boot the mouse will not work, and the keyboard has been 'iffy' - Then most of the time if I unplug and replug them into the monitor USB hub, they will both work fine. Just now I tried unplugging my mouse from the monitor, plugged in on the doc, and it worked, then plugged in direct to the laptop ports, and it worked... Only to find my usb keyboard stopped working... Unplugged keyboard and mouse - put them on the laptop, now neither works. :(

dmsg snip from boot time, and then for this event. Not sure what other bits to grab since I haven't really had usb issues before, so I'll just attach some 'normal' bits.. Darn - or I would attach if I could start a terminal. Since the usb lock, terminal will no longer launch, etc. weird. I'll see if I can get /var/log bits after a restart.

[15817.523026] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8.1/1-8.1.1/1-8.1.1:1.0/input/input15
[15817.523169] microsoft 0003:045E:00DB.0001: input,hidraw0: USB HID v1.11 Keyboard [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.7-8.1.1/input0
[15817.535472] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8.1/1-8.1.1/1-8.1.1:1.1/input/input16
[15817.535647] microsoft 0003:045E:00DB.0002: input,hidraw1: USB HID v1.11 Device [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.7-8.1.1/input1
[15817.636041] usb 1-8.1.2: configuration #1 chosen from 1 choice
[15817.641654] input: Microsoft Corporation Microsoft ® Laser Mouse 6000 as /devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8.1/1-8.1.2/1-8.1.2:1.0/input/input17
[15817.641837] generic-usb 0003:045E:00F0.0003: input,hidraw2: USB HID v1.11 Mouse [Microsoft Corporation Microsoft ® Laser Mouse 6000] on usb-0000:00:1d.7-8.1.2/input0
[15817.644881] hub 2-2:1.0: port 3 disabled by hub (EMI?), re-enabling...
[15817.644887] usb 2-2.3: USB disconnect, address 12
[15817.644890] usb 2-2.3.1: USB disconnect, address 13
[15817.645119] usb 2-2.3.2: USB disconnect, address 14
[15817.865833] usb 2-2.3: new full speed USB device using uhci_hcd and address 15
[15817.997824] usb 2-2.3: configuration #1 chosen from 1 choice
[15818.003008] hub 2-2.3:1.0: USB hub found
[15818.005072] hub 2-2.3:1.0: 3 ports detected

Hello Ryan,

please also try to get the output of

  udevadm test /devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8.1/1-8.1.1/1-8.1.1:1.0/input/input15

and

  udevadm info --attribute-walk --path=/devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8.1/1-8.1.1/1-8.1.1:1.0/input/input15

so that I can check whether it's really the new hid2hci thing. Thanks!

Ryan (ubuntu-draziw) wrote :
Download full text (64.4 KiB)

On reboot, even connected directly, my USB keyboard and mouse don't work. unplug mouse and re-plug, and both the keyboard and mouse work.
/var/log/messages - blank lines are where I unplugged and replugged.
 Jul 28 11:56:57 lt kernel: [ 51.447203] usb 2-2.3.1: configuration #1 chosen from 1 choice
Jul 28 11:56:57 lt kernel: [ 51.529108] usb 2-2.3.2: new full speed USB device using uhci_hcd and address 8
Jul 28 11:56:57 lt kernel: [ 51.652213] usb 2-2.3.2: configuration #1 chosen from 1 choice
Jul 28 11:56:57 lt kernel: [ 71.788980] padlock: VIA PadLock not detected.
Jul 28 11:56:57 lt kernel: [ 237.240156] usb 4-1: USB disconnect, address 2
Jul 28 11:56:57 lt kernel: [ 237.980102] usb 4-1: new low speed USB device using uhci_hcd and address 3
Jul 28 11:56:57 lt kernel: [ 238.162990] usb 4-1: configuration #1 chosen from 1 choice
Jul 28 11:56:57 lt kernel: [ 238.180298] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/input/input14
Jul 28 11:56:57 lt kernel: [ 238.180390] microsoft 0003:045E:00DB.0004: input,hidraw1: USB HID v1.11 Keyboard [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.2-1/input0
Jul 28 11:56:57 lt kernel: [ 238.204131] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.1/input/input15

Jul 28 12:14:37 lt kernel: [ 238.204231] microsoft 0003:045E:00DB.0005: input,hidraw2: USB HID v1.11 Device [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.2-1/input1
Jul 28 12:14:37 lt kernel: [ 1287.624121] usb 3-2: USB disconnect, address 2
Jul 28 12:14:37 lt kernel: [ 1297.912103] usb 3-2: new low speed USB device using uhci_hcd and address 3
Jul 28 12:14:37 lt kernel: [ 1298.136287] usb 3-2: configuration #1 chosen from 1 choice
Jul 28 12:14:37 lt kernel: [ 1298.169466] input: Microsoft Corporation Microsoft ® Laser Mouse 6000 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input16

On patched (as of an hour ago) alpha 3.

uname -a
Linux lt 2.6.31-4-generic #23-Ubuntu SMP Mon Jul 27 18:39:51 UTC 2009 i686 GNU/Linux

root@lt:/etc/X11# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu karmic (development branch)"

dmesg before unplug/replug
[ 50.549078] hub 2-2.3:1.0: hub_port_status failed (err = -71)
[ 50.569077] hub 2-2.3:1.0: cannot disable port 1 (err = -71)
[ 50.570072] hub 2-2.3:1.0: hub_port_status failed (err = -71)
[ 50.654077] hub 2-2:1.0: port 3 disabled by hub (EMI?), re-enabling...
[ 50.654084] usb 2-2.3: USB disconnect, address 3
[ 50.654087] usb 2-2.3.1: USB disconnect, address 4
[ 50.654323] usb 2-2.3.2: USB disconnect, address 5
[ 50.881088] usb 2-2.3: new full speed USB device using uhci_hcd and address 6
[ 51.010401] usb 2-2.3: configuration #1 chosen from 1 choice
[ 51.013830] hub 2-2.3:1.0: USB hub found
[ 51.018928] hub 2-2.3:1.0: 3 ports detected
[ 51.288656] ata1.00: configured for UDMA/133
[ 51.288661] ata1: EH complete
[ 51.301098] usb 2-2.3.1: new full speed USB device using uhci_hcd and address 7
[ 51.447203] usb 2-2.3.1: configuration #1 chosen from 1 cho...

Martin Pitt (pitti) wrote :

Ryan, thanks for the logs. However, I'm afraid I really need the udevadm output I asked for in comment 12.

Ryan (ubuntu-draziw) wrote :
Download full text (16.4 KiB)

Hi Martin, for some reason I didn't subscribe to this one, so I didn't see your note until now - Sorry for the delay. Do you want the output when working, or not? Here it is when working - I'll need a fresh boot with them already plugged in for the not working version...

(Picked targets based on dmesg output on current location)
$ dmesg |grep -i 'ergonomic keyboard'
[ 2.668426] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input6
[ 2.668562] microsoft 0003:045E:00DB.0001: input,hidraw0: USB HID v1.11 Keyboard [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.1-2/input0
[ 2.691256] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.1/input/input7
[ 2.691397] microsoft 0003:045E:00DB.0002: input,hidraw1: USB HID v1.11 Device [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.1-2/input1
[ 56.549232] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input15
[ 56.549323] microsoft 0003:045E:00DB.0005: input,hidraw1: USB HID v1.11 Keyboard [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.1-2/input0
[ 56.573034] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.1/input/input16
[ 56.573125] microsoft 0003:045E:00DB.0006: input,hidraw2: USB HID v1.11 Device [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.1-2/input1

udevadm test /sys/devices/pci0000\:00/0000\:00\:1d.1/usb3/3-2/3-2\:1.1/input/input16
run_command: calling: test
udevadm_test: version 145
This program is for debugging only, it does not run any program,
specified by a RUN key. It may show incorrect results, because
some values may be different, or not available at a simulation run.

parse_file: reading '/etc/udev/rules.d/10-blackberry.rules' as rules file
parse_file: reading '/etc/udev/rules.d/10-vboxdrv.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-alsa.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-gnupg.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-gnupg2.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-hplip.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-ia64.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-infiniband.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-isdn.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-libgphoto2-2.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-libpisock9.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-libsane.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-pilot-links.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-ppc.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-xserver-xorg-input-wacom.rules' as rules file
parse_file: reading '/lib/udev/rules.d/40-zaptel.rules' as rules file
parse_file: reading '/lib/udev/rules.d/45-fuse.rules' as rules file
parse_file: reading '/etc/udev/rules.d/45-libmtp7.rules' as rules file
parse_file: reading '/lib/udev/rules.d/45-libmt...

Ryan (ubuntu-draziw) wrote :
Download full text (22.6 KiB)

OK - just to keep things interesting, on reboot, with the USB devices (keyboard and mouse) the usb keyboard did work, but the mouse did not.

$ dmesg |egrep -i usb
[ 0.354776] usbcore: registered new interface driver usbfs
[ 0.354776] usbcore: registered new interface driver hub
[ 0.354776] usbcore: registered new device driver usb
[ 1.155905] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 1.156216] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
[ 1.173022] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00
[ 1.173197] usb usb1: configuration #1 chosen from 1 choice
[ 1.173321] hub 1-0:1.0: USB hub found
[ 1.173545] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 1.173655] uhci_hcd: USB Universal Host Controller Interface driver
[ 1.173935] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
[ 1.174204] usb usb2: configuration #1 chosen from 1 choice
[ 1.174323] hub 2-0:1.0: USB hub found
[ 1.174681] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
[ 1.174961] usb usb3: configuration #1 chosen from 1 choice
[ 1.175081] hub 3-0:1.0: USB hub found
[ 1.175438] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
[ 1.175715] usb usb4: configuration #1 chosen from 1 choice
[ 1.175836] hub 4-0:1.0: USB hub found
[ 1.176201] uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 5
[ 1.176476] usb usb5: configuration #1 chosen from 1 choice
[ 1.176600] hub 5-0:1.0: USB hub found
[ 1.717030] usb 1-8: new high speed USB device using ehci_hcd and address 5
[ 1.851115] usb 1-8: configuration #1 chosen from 1 choice
[ 1.851301] hub 1-8:1.0: USB hub found
[ 2.089038] usb 2-2: new full speed USB device using uhci_hcd and address 2
[ 2.240261] usb 2-2: configuration #1 chosen from 1 choice
[ 2.242201] hub 2-2:1.0: USB hub found
[ 2.488038] usb 3-2: new low speed USB device using uhci_hcd and address 2
[ 2.671028] usb 3-2: configuration #1 chosen from 1 choice
[ 2.680290] usbcore: registered new interface driver hiddev
[ 2.680689] usbcore: registered new interface driver usbhid
[ 2.680782] usbhid: v2.6:USB HID core driver
[ 2.696353] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input6
[ 2.696491] microsoft 0003:045E:00DB.0001: input,hidraw0: USB HID v1.11 Keyboard [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.1-2/input0
[ 2.720162] input: Microsoft Natural® Ergonomic Keyboard 4000 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.1/input/input7
[ 2.720291] microsoft 0003:045E:00DB.0002: input,hidraw1: USB HID v1.11 Device [Microsoft Natural® Ergonomic Keyboard 4000] on usb-0000:00:1d.1-2/input1
[ 2.916036] usb 4-1: new low speed USB device using uhci_hcd and address 2
[ 3.139789] usb 4-1: configuration #1 chosen from 1 choice
[ 3.171020] input: Microsoft Corporation Microsoft ® Laser Mouse 6000 as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/input/input8
[ 3.171096] generic-usb 0003:045E:00F0.0003: input,hidraw2: USB HID v1.11 Mouse [Microsoft Co...

Ryan (ubuntu-draziw) wrote :
Download full text (3.2 KiB)

Right after above comment, unplug and replug mouse - and it then works perfect. (fyi - both of comments were sitting on a docking station, but using the right side direct to notebook USB ports.

[ 832.212100] usb 4-1: USB disconnect, address 2
[ 834.808123] usb 4-1: new low speed USB device using uhci_hcd and address 3
[ 835.035428] usb 4-1: configuration #1 chosen from 1 choice
[ 835.068927] input: Microsoft Corporation Microsoft ® Laser Mouse 6000 as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/input/input14
[ 835.069128] generic-usb 0003:045E:00F0.0004: input,hidraw2: USB HID v1.11 Mouse [Microsoft Corporation Microsoft ® Laser Mouse 6000] on usb-0000:00:1d.2-1/input0

# lsusb
Bus 003 Device 002: ID 045e:00db Microsoft Corp. Natural Ergonomic Keyboard 4000 V1.0
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 045e:00f0 Microsoft Corp.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 008: ID 0b97:7762 O2 Micro, Inc. Oz776 SmartCard Reader
Bus 002 Device 007: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
Bus 002 Device 006: ID 0b97:7761 O2 Micro, Inc. Oz776 1.1 Hub
Bus 002 Device 002: ID 413c:a005 Dell Computer Corp. Internal 2.0 Hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 0424:2504 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 413c:0058 Dell Computer Corp. Port Replicator

# lsusb -v -s 4:3

Bus 004 Device 003: ID 045e:00f0 Microsoft Corp.
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 8
  idVendor 0x045e Microsoft Corp.
  idProduct 0x00f0
  bcdDevice 1.01
  iManufacturer 1 Microsoft Corporation
  iProduct 2 Microsoft � Laser Mouse 6000
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 34
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 100mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 3 Human Interface Device
      bInterfaceSubClass 1 Boot Interface Subclass
      bInterfaceProtocol 2 Mouse
      iInterface 0
      ** UNRECOGNIZED: 09 21 11 01 21 01 22 3b 00
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPack...

Read more...

Martin Pitt (pitti) wrote :

So, I didn't see anything in the logs regarding hid2hci, so I don't think this is the same problem. Can you please report a new problem against the kernel, with "ubuntu-bug linux"? Thanks!

Ryan (ubuntu-draziw) wrote :

Thanks Martin - entered 410730.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers