Focal ucf need redirect fixes backported to ensure working with config-package-dev

Bug #1891110 reported by Stephen Fletcher on 2020-08-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ucf (Debian)
Fix Released
Unknown
ucf (Ubuntu)
Medium
Unassigned
Focal
Medium
Unassigned

Bug Description

When using config-package-dev and diverting config files for packages that use ucf to manage installation of their config files, this patch is necessary to ensure config files are correctly diverted.

Please apply to upstream Focal UCF package

The attachment "patches from ucf 3.0040 to fix diversions issue with config-package-dev" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ucf (Ubuntu):
status: New → Confirmed
Mathew Hodson (mhodson) wrote :

ucf (3.0043) unstable; urgency=high

  * The argument to dpkg-divert needs to be the actual file name, not the
    fully escaped regexp safe one.
  * Bug fix: "dpkg-divert error when upgrading grub with diverted config",
    thanks to <email address hidden></a>; (Closes: #962818).

 -- Manoj Srivastava <email address hidden> Mon, 15 Jun 2020 22:37:53 -0700

Changed in ucf (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Released
Changed in ucf (Ubuntu Focal):
importance: Undecided → Medium
Changed in ucf (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.