ucarp not working with ubuntu server 18.04

Bug #1777901 reported by Daniel Roche on 2018-06-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ucarp (Ubuntu)
Undecided
Unassigned

Bug Description

on a freshly installed ubuntu server 18.04

- install ucarp package ( 1.5.2-2.1 amd64 ) no problem for installing

- problem n°1, this package does not have any systemd launching utilities, annoying, but i can launch
   it manually as follow :

- /usr/sbin/ucarp --interface=enp0s31f6 --passfile=/etc/ucarp/vip-001.pass --srcip=172.16.0.140 --vhid=001 --addr=172.25.1.200 --shutdown --preempt --advskew=0 --upscript=/opt/miscbin/vip-up --downscript=/opt/miscbin/vip-down

--> i get :
[INFO] Local advertised ethernet address is [00:01:2e:79:0f:64]
[WARNING] Switching to state: BACKUP
[WARNING] Spawning [/opt/miscbin/vip-down enp0s31f6 172.25.1.200]
[ERROR] Can't do IP_ADD_MEMBERSHIP errno=No such device (19)

the error IP_ADD_MEMBERSHIP seems to be related to multicast not allowed on the network device
but on the same hardWare, it run perfectly on ubuntu server 16.04.4 !

the /etc/ucarp/vip-001.pass file exists and provide a regular password
the /opt/miscbin/vip-up and vip-down script are defined as follow :
----- up -----
#!/bin/sh
exec 2>/dev/null

/sbin/ip address add "$2"/32 dev "$1"
------- down -------
#!/bin/sh
exec 2>/dev/null

/sbin/ip address del "$2"/32 dev "$1"
---------------

i have tried several things :

- ubuntu server on a real server, and on virtual machine ( KVM )
- not using netplan ( installing back ifupdown and removing all netplan yaml files )

i still have the same error.

this is working without error with ubuntu-server 16.04 with the exact same conditions / procedure

Best regards

tags: added: bionic
Daniel Roche (dan-y-roche) wrote :

You can discard this bug report !

it was an IP misconfiguration, nothing to do with ubuntu 1804 bionic !

i am very sorry, i looked at my config dozen of time without seeing the mistake !

ucarp is working !

however , the ucarp package still miss the systemd launcher.

best regards.

Changed in ucarp (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers