[SRU] Media Playback menu is overpopulated

Bug #1905061 reported by mook765 on 2020-11-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntustudio-menu (Ubuntu)
Status tracked in Hirsute
Groovy
High
Erich Eickmeyer 
Hirsute
High
Erich Eickmeyer 

Bug Description

[Impact]

 * An issue has been discovered in the default menu for Ubuntu Studio where many (if not most) items were showing up in the Multimedia Playback menu, making menu clutter that was unintentional and causing application discovery issues.

[Test Case]

 * Install Ubuntu Studio (or any flavor and use the Ubuntu Studio Installer to install ubuntustudio-menu and ubuntustudio-audio), -OR- simply check the live session for Ubuntu Studio's ISO.

 * Click Ubuntu Studio logo (Plasma Kickoff menu) and go to Multimedia Playback.

 * Menu will be extremely cluttered and have too many entries.

[Where problems could occur]

 * This has been thoroughly tested, but it might not work for people who have customized the items in their menu.

Original Description:

UbuntuStudio 20.10
Application menu displays almost all applications in the "Media Playback"-category.
It seems the problem is in /etc/xdg/menus/applications-merged/studio.menu
I changed the related section in the file from

    <Menu>
        <Name>Media Playback</Name>
        <Directory>ubuntustudio-mediaplayback.directory</Directory>
        <Include>
         <And>
            <Category>AudioVideo</Category>
            <Category>Player</Category>
            <Filename>org.kde.elisa.desktop</Filename>
         </And>
         <Not>
            <Filename>jack_mixer.desktop</Filename>
         </Not>
        </Include>
    </Menu>

to

    <Menu>
        <Name>Media Playback</Name>
        <Directory>ubuntustudio-mediaplayback.directory</Directory>
        <Include>
         <And>
            <Category>AudioVideo</Category>
            <Category>Player</Category>
          <Not>
            <Filename>jack_mixer.desktop</Filename>
          </Not>
         </And>
         <Filename>org.kde.elisa.desktop</Filename>
        </Include>
    </Menu>

Now it looks like it should be, pretty clean, I think that's what was intended.

Thank you for doing this. I'll make the change, upload a fix, and turn this bug into an SRU (Stable Release Update).

affects: carla → ubuntustudio-menu (Ubuntu)
Changed in ubuntustudio-menu (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Erich Eickmeyer (eeickmeyer)

Looks like your fix worked, mook765. I tested it here and I'm going to get this uploaded as soon as possible.

Changed in ubuntustudio-menu (Ubuntu Groovy):
status: New → In Progress
Changed in ubuntustudio-menu (Ubuntu Hirsute):
status: Triaged → In Progress
Changed in ubuntustudio-menu (Ubuntu Groovy):
importance: Undecided → High
assignee: nobody → Erich Eickmeyer (eeickmeyer)
Changed in ubuntustudio-menu (Ubuntu Hirsute):
status: In Progress → Fix Committed
description: updated
summary: - too many apps in media playback category
+ [SRU] Media Playback menu is overpopulated
Changed in ubuntustudio-menu (Ubuntu Groovy):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-menu - 0.50

---------------
ubuntustudio-menu (0.50) hirsute; urgency=medium

  * Fix for Media Playback menu showing too many items (LP: #1905061)

 -- Erich Eickmeyer <email address hidden> Fri, 20 Nov 2020 14:19:18 -0800

Changed in ubuntustudio-menu (Ubuntu Hirsute):
status: Fix Committed → Fix Released

Hello mook765, or anyone else affected,

Accepted ubuntustudio-menu into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntustudio-menu/0.50~20.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-groovy
mook765 (mook765) wrote :

apt-cache policy ubuntustudio-menu
ubuntustudio-menu:
  Installed: 0.50~20.10.1

Works as expected...

Can also confirm it works.

tags: added: verification-done verification-done-groovy
removed: verification-needed verification-needed-groovy
mook765 (mook765) wrote :

The package does not install the file /etc/xdg/menus/applications-merged/studio.menu
My test was not complete, sorry. I had changed my file on 20/11, after installing from proposed the modification date of the file was unchanged. So removing the file and reinstalinng the package from proposed again does not install the mentioned file. Please check this.

mook765, that's because you manually modified the file. Anytime you do this to any file in /etc, dpkg knows not to modify those files since it might be a custom configuration. You might have to use this:

sudo apt-get -o Dpkg::Options::="--force-overwrite" install ubuntustudio-menu

-or, if you downloaded the .deb file-

sudo dpkg -i --force-overwrite ubuntustudio-menu.deb

mook765 (mook765) wrote :

Thanks Erich, that's what I didn't know, evereyday something to learn. I had to downgrade the package first with

sudo apt-get install ubuntustudio-menu=0.49

This indeed asked me to overwrite the modified file and I got the overpopulated menu back.
Upgrading the package with

sudo apt-get install ubuntustudio-menu=0.50~20.10.1

solved the issue with the overpopulated menu. Just perfect.

By the way, I didn't like the subfolders in the "Games"-folder since there are not many games installed and I'm not planning to do so. I wrote a games.menu file which can be placed in
/etx/xdg/menus/applications-merged or in ~/.config/menus/applications-merged . Here it is:

<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN" "http://www.freedesktop.org/standards/menu-spec/menu-1.0.dtd">
<Menu>
    <Name>Applications</Name>
    <Menu>
  <Name>Games</Name>
  <Directory>kf5-games.directory</Directory>
  <Menu>
   <Name>Arcade</Name>
   <Directory>ubuntustudio-noshow.directory</Directory>
  </Menu>
  <Menu>
   <Name>Board</Name>
   <Directory>ubuntustudio-noshow.directory</Directory>
  </Menu>
  <Menu>
   <Name>Card</Name>
   <Directory>ubuntustudio-noshow.directory</Directory>
  </Menu>
  <Menu>
   <Name>Kidsgames</Name>
   <Directory>ubuntustudio-noshow.directory</Directory>
  </Menu>
  <Menu>
   <Name>TacticStrategy</Name>
   <Directory>ubuntustudio-noshow.directory</Directory>
  </Menu>
  <Menu>
   <Name>Logic</Name>
   <Directory>ubuntustudio-noshow.directory</Directory>
  </Menu>
        <Include>
            <Category>Game</Category>
        </Include>
    </Menu>
</Menu>

Feel free to use it or not.

The subfolders in Games is actually an XDG thing, even further upstream than KDE Plasma. I intend to keep it as-is since a goal for Ubuntu Studio is to provide an all-in-one package for gaming streamers, which Steam is making a reality via Proton and upstream work in wine. I feel as though they might appreciate the extra organization. :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-menu - 0.50~20.10.1

---------------
ubuntustudio-menu (0.50~20.10.1) groovy; urgency=medium

  * Fix for Media Playback menu showing too many items (LP: #1905061)

 -- Erich Eickmeyer <email address hidden> Fri, 20 Nov 2020 14:19:18 -0800

Changed in ubuntustudio-menu (Ubuntu Groovy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntustudio-menu has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers