the lightdm-theme package is practically empty

Bug #1630347 reported by Ross Gammon on 2016-10-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntustudio-default-settings (Ubuntu)
Undecided
Unassigned
ubuntustudio-lightdm-theme (Ubuntu)
Undecided
Unassigned
ubuntustudio-meta (Ubuntu)
Undecided
Unassigned

Bug Description

The ubuntustudio-lightdm-theme package is now nearly empty, with only a configuration file remaining. We should move this config file to ubuntustudio-default-settings (which is the natural home for such configuration), and remove the lightdm-theme package.

Krytarik prepared a transition to achieve this, but it was a little close to the release date for Yakkety. I reverted this, so that only the change to the latest Numix Blue theme was uploaded instead. This bug is to remind us to do the transition & removal after Yakkety is released.

Remember to take care to update the seeds and metapackages as well as part of the transition.

Ross Gammon (rosco2) on 2017-02-04
Changed in ubuntustudio-default-settings (Ubuntu):
assignee: nobody → Ross Gammon (rosco2)
Changed in ubuntustudio-meta (Ubuntu):
assignee: nobody → Ross Gammon (rosco2)
Changed in ubuntustudio-default-settings (Ubuntu):
status: New → Confirmed
Changed in ubuntustudio-lightdm-theme (Ubuntu):
status: New → Confirmed
Changed in ubuntustudio-meta (Ubuntu):
status: New → Confirmed
Ross Gammon (rosco2) wrote :

I attach a debdiff ready for sponsorship. It also includes a fix for #1550210. We would like to get this fix into Zesty before the final Beta.

Changed in ubuntustudio-default-settings (Ubuntu):
assignee: Ross Gammon (rosco2) → nobody
Ross Gammon (rosco2) wrote :

I am attaching a debdiff for the ubuntustudio-meta package as part of this transition. It needs sponsorship, and it would be good to get this uploaded before the Zesty Final Beta.

The only task left on this bug is to remove the ubuntustudio-lightdm-theme package from the archive. But this can be done later.

Changed in ubuntustudio-meta (Ubuntu):
assignee: Ross Gammon (rosco2) → nobody
Jeremy Bicha (jbicha) wrote :

Ross, I think it would be a good idea to include a transitional package for ubuntustudio-lightdm-theme to make the upgrade smoother.

Ross Gammon (rosco2) wrote :

Hi Jeremy,

I didn't go with the transitional package option because the only reverse dependencies are the ubuntustudio-meta's. If we upload both us-default-settings and us-meta at about the same time (there is a diff that drops us-lightdm-theme from the us-meta package attached to the bug), then we will avoid a build failure on the daily Live-CDs, and get it all over in one go. I have tested that this works with an "apt-get dist-upgrade" in my Zesty VM and my ppa.

But I am happy to add a dummy package if that helps find a sponsor!

Cheers,

Ross

Jeremy Bicha (jbicha) wrote :

Sometimes transitional packages aren't needed but I'm not sure which situations qualify. I would be happier if this had a transitional package -- which we can drop next year after 18.04 LTS.

Ross Gammon (rosco2) wrote :

As the config file previously in the us-lightdm-theme source package is moved to us-default-settings, and us-default-settings is seeded for Ubuntu Studio, Ubuntu Studio users will not notice anything after us-lightdm-theme is removed during the apt-get dist-upgrade.

However, if us-lightdm-theme was manually installed by a user, or another package depended on it (which is not the case here - as it is only the us-meta packages that depend on it), then we would need a dummy us-lightdm-theme package (included in the us-default-settings source package) to force the user over to the new us-default-settings source package.

It is very unlikely that anyone would manually install the ubuntustudio-lightdm-theme package on it's own. And in this case, they could just keep using the us-lightdm-theme package as long as they liked (as apt-get dist-upgrade will not ask for it's removal). Therefore, I think the transitional package is a little over the top.

But expect a new diff including a dummy package uploaded here later today.

Ross Gammon (rosco2) wrote :
Jeremy Bicha (jbicha) on 2017-03-03
Changed in ubuntustudio-default-settings (Ubuntu):
status: Confirmed → Fix Committed
Jeremy Bicha (jbicha) wrote :

Thanks! Uploaded.

I am unsubscribing ~ubuntu-sponsors. Feel free to re-subscribe if you need sponsoring for something else.

Changed in ubuntustudio-meta (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-default-settings - 0.64

---------------
ubuntustudio-default-settings (0.64) zesty; urgency=medium

  * Temporarily override the desktop file for imagemagick
    with Terminal set to true (LP: #1550210)
  * Move configuration from ubuntustudio-lightdm-theme (LP: #1630347)
    Prvide a dummy transitional ubuntustudio-lightdm-theme package
    which can be removed after next LTS release (18.04).

 -- Ross Gammon <email address hidden> Sun, 26 Feb 2017 12:32:33 +0100

Changed in ubuntustudio-default-settings (Ubuntu):
status: Fix Committed → Fix Released

On 03/03/2017 02:34 AM, Jeremy Bicha wrote:
> Thanks! Uploaded.
>
> I am unsubscribing ~ubuntu-sponsors. Feel free to re-subscribe if you
> need sponsoring for something else.
>
> ** Changed in: ubuntustudio-meta (Ubuntu)
> Status: Confirmed => Fix Committed
>
Thanks for all your help with this Jeremy!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-meta - 0.165

---------------
ubuntustudio-meta (0.165) zesty; urgency=medium

  * Have ubuntustudio-graphics depend on ubuntustudio-fonts
    instead of NBS ubuntustudio-font-meta

 -- Jeremy Bicha <email address hidden> Fri, 03 Mar 2017 00:10:28 -0500

Changed in ubuntustudio-meta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers