ubuntustudio-default-settings recommends linux-lowlatency thus breaking ubuntustudio focal image building

Bug #1884915 reported by Dimitri John Ledkov
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
live-build (Ubuntu)
Invalid
Critical
Unassigned
Focal
Invalid
Critical
Unassigned
Groovy
Invalid
Critical
Unassigned
livecd-rootfs (Ubuntu)
Fix Released
Critical
Unassigned
Focal
Fix Released
Critical
Unassigned
Groovy
Won't Fix
Critical
Unassigned
ubuntustudio-default-settings (Ubuntu)
Fix Released
Undecided
Unassigned
Focal
Fix Released
Undecided
Unassigned
Groovy
Fix Released
Undecided
Unassigned
ubuntustudio-meta (Ubuntu)
Invalid
Undecided
Unassigned
Focal
Invalid
Undecided
Unassigned
Groovy
Invalid
Undecided
Unassigned

Bug Description

[ Description ]

ubuntustudio-default-settings recommends linux-lowlatency thus breaking ubuntustudio focal image building

$ reverse-depends linux-lowlatency
Reverse-Recommends
* ubuntustudio-lowlatency-settings

Reverse-Depends
* linux-lowlatency-hwe-18.04 [amd64]
* linux-lowlatency-hwe-18.04-edge [amd64]

Packages without architectures listed are reverse-dependencies in: amd64, arm64, armhf, i386, ppc64el, s390x

Seeded packages in the Ubuntu archive must not depend on the linux kernel. Installation, and defaultness of a kernel flavour must be handled externally using livecd-rootfs kernel flavour picking, or some other dynamic configuration.

The above resulted in transitevely linux-lowlatency packages getting pulled into the ubuntustudio task, without a blacklist. Which means that ABI encoded packages gain Task: ubuntustudio-desktop, and instead of only installing/tracking the latest kernel, the ancient 5.4.0-16-lowlatency abi is also installed, and then production of daily focal isos fails, as there are two lowlatency kernels on the media.

[ Fix ]

The above description indicates what broke. The recommends means that the Task field contains a specific kernel ABI. We'll fix this by enumerating the packages that we need to ensure aren't included, and make sure they are effectively considered as not part of the task.

[ QA ]

Build an ubuntustudio/focal ISO with the -proposed livecd-rootfs and make sure that it builds successfully and boots.

[ Regression potential ]

This is about excluding kernel-related packages from the task consideration. If it is wrong then they could be excluded from the image completely. That should be obvious if the thing doesn't boot, and we'll have to iterate again.

[ Original description ]

$ reverse-depends linux-lowlatency
Reverse-Recommends
* ubuntustudio-lowlatency-settings

Reverse-Depends
* linux-lowlatency-hwe-18.04 [amd64]
* linux-lowlatency-hwe-18.04-edge [amd64]

Packages without architectures listed are reverse-dependencies in: amd64, arm64, armhf, i386, ppc64el, s390x

$ apt-cache show -a linux*lowlatency | grep -e Package -e Task
...
Package: linux-headers-5.4.0-26-lowlatency
Task: ubuntustudio-desktop
...

If the dependency is desired, that is ok, as long as the abi encoded packages are blacklisted in the seed similar to the !linux-image-* stanza.

see https://launchpad.net/~ubuntu-cdimage/+livefs/ubuntu/focal/ubuntustudio/

description: updated
Changed in ubuntustudio-default-settings (Ubuntu):
status: New → Fix Committed
Changed in ubuntustudio-meta (Ubuntu):
status: New → Invalid
Changed in ubuntustudio-default-settings (Ubuntu):
status: Fix Committed → Fix Released
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → Critical
Changed in live-build (Ubuntu):
importance: Undecided → Critical
Changed in livecd-rootfs (Ubuntu Focal):
importance: Undecided → Critical
Changed in live-build (Ubuntu Focal):
importance: Undecided → Critical
Changed in ubuntustudio-meta (Ubuntu Focal):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in live-build (Ubuntu Focal):
status: New → Confirmed
Changed in live-build (Ubuntu):
status: New → Confirmed
Changed in livecd-rootfs (Ubuntu Focal):
status: New → Confirmed
Changed in livecd-rootfs (Ubuntu):
status: New → Confirmed
Changed in ubuntustudio-default-settings (Ubuntu Focal):
status: New → Confirmed
Iain Lane (laney)
Changed in live-build (Ubuntu Focal):
status: Confirmed → Invalid
Changed in live-build (Ubuntu Groovy):
status: Confirmed → Invalid
Changed in livecd-rootfs (Ubuntu Groovy):
status: Confirmed → Won't Fix
Iain Lane (laney)
description: updated
Revision history for this message
Iain Lane (laney) wrote :

livecd-rootfs uploaded to the queue. I've not uploaded ubuntustudio-default-settings to drop the recommends since it's not required for the fix. An ubuntustudio developer can do it though if they want.

Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :

I fixed it in groovy, Iain. If you'd like, I can fix it in focal as part of this SRU.

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Dimitri, or anyone else affected,

Accepted livecd-rootfs into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.664.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Focal):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :

Confirmed that the fix to livecd-rootfs works, latest Focal daily runs without issue.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Dimitri, or anyone else affected,

Accepted ubuntustudio-default-settings into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntustudio-default-settings/20.04.2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntustudio-default-settings (Ubuntu Focal):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-focal
removed: verification-done verification-done-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.664.3

---------------
livecd-rootfs (2.664.3) focal; urgency=medium

  [ Łukasz 'sil2100' Zemczak ]
  * Enable overrides of UC20 grade dangerous channels - as this is possible.
    (LP: #1879350)

  [ Iain Lane ]
  * Hack seeding of linux kernel in ubuntustudio/focal
    ubuntustudio-default-settings in focal release has a Recommends to this
    kernel, which makes it impossible to update the kernel later on, since we
    would install the -updates and release kernel, which isn't allowed and
    causes FTBFS. Hack out the focal-release kernel and let the rest of the
    build process pull in the right one. (LP: #1884915)

 -- Iain Lane <email address hidden> Tue, 21 Jul 2020 16:25:18 +0100

Changed in livecd-rootfs (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in livecd-rootfs (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :

Long-since confirmed that this was the culprit and that the update to ubuntustudio-default-settings fixes a problem that never would have existed had it not have depended on linux-lowlatency in the first place, thus causing issues with livecd-rootfs.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-default-settings - 20.04.2.1

---------------
ubuntustudio-default-settings (20.04.2.1) focal; urgency=medium

  * debian/control: Remove linux-lowlatency from recommends (LP: #1884915)

 -- Erich Eickmeyer <email address hidden> Tue, 21 Jul 2020 10:54:21 -0700

Changed in ubuntustudio-default-settings (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of the Stable Release Update for ubuntustudio-default-settings has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers