ubuntustudio-controls crashed with AttributeError in serialze_settings()

Bug #269389 reported by Marco on 2008-09-12
64
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Studio Controls (development moved)
Fix Released
High
Andrew Hunter
ubuntustudio-controls (Ubuntu)
Undecided
Andrew Hunter

Bug Description

Binary package hint: ubuntustudio-controls

1)
$ lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10

2)
$ apt-cache policy ubuntustudio-controls
ubuntustudio-controls:
  Installed: 0.3
  Candidate: 0.3
  Version table:
 *** 0.3 0
        500 http://archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status

3) I wanted to close the window ("close" button).
4) The window just close and I see that it crashed via "report a problem...".
It doesn't crash everytime.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/ubuntustudio-controls
InterpreterPath: /usr/bin/python2.5
Package: ubuntustudio-controls 0.3
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/bin/ubuntustudio-controls
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/ubuntustudio-controls']
SourcePackage: ubuntustudio-controls
Title: ubuntustudio-controls crashed with AttributeError in serialze_settings()
Uname: Linux 2.6.27-3-generic i686
UserGroups:

Marco (cosmonotonouille) wrote :

This crash has the same stack trace characteristics as bug #194835. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

Andrew Hunter (rexbron) wrote :

I had thought I'd fixed this bug. Could you please list exactly the steps taken to reproduce this crash, from opening to closing as well as any setting you had (or had not) set.

Marco (cosmonotonouille) wrote :

I'll try.

I reinstall the package (I doesn't need it so I remove it). When it crashed last time I doesn't change any setting before closing and had launched ubuntustudio-controls from gnome-control-center.
Now, I started directly gnome-control-center via the terminal (sudo gnome-control-center). It prints me immediately this :
$ sudo ubuntustudio-controls
__main__
/usr/bin/ubuntustudio-controls:32: GtkWarning: Ignoring the separator setting
  self.wTree = gtk.glade.XML(self.gladefile)

(ubuntustudio-controls:18309): libglade-WARNING **: could not find a parent that handles internal children for `vbox'
Traceback (most recent call last):
  File "/usr/bin/ubuntustudio-controls", line 184, in <module>
    uscontrols.serialize_settings()
AttributeError: Uscontrols instance has no attribute 'serialize_settings'

I'm updating now my computer, I'll try again after reboot.

PS : sorry for my bad English.

Marco (cosmonotonouille) wrote :

[System updated]
But if I start the application from gnome-control-center (like the first time) it doesn't crash anymore. (No value change before closing.)
From the terminal it crashes.

Andrew Hunter (rexbron) wrote :

I think this needs some debuging is real time. Would you be able to join #ubuntustudio-devel and ping rexbron so we can set up a time?

Changed in ubuntustudio-controls:
assignee: nobody → rexbron
status: New → Confirmed
Marco (cosmonotonouille) wrote :

Yes I can do what you want. But I don't know what '#ubuntustudio-devel' is :·s .
Please tell me more about what I'm suppose to do.

Andrew Hunter (rexbron) wrote :

A list of official Ubuntu IRC channels, as well as IRC clients for Ubuntu, can be found at https://help.ubuntu.com/community/InternetRelayChat . Once you have joined the freenode channel please join #ubuntustudio and ping (type my name) 'rexbron'.

Changed in ubuntustudio-controls:
assignee: nobody → rexbron
importance: Undecided → High
status: New → Confirmed
Andrew Hunter (rexbron) wrote :

Sorry, marco. Quassel has locked me out for the moment. I have fixed the second traceback you have reported. That was due to a typo in the code.

I will be testing this on my machine and will give you instructions on how to do it on your own.

Marco (cosmonotonouille) wrote :

No problem. ;)

Andrew Hunter (rexbron) wrote :

Ok, I uploaded a package to the Ubuntu Studio PPA[1] that fixed the second traceback you posted. Please test it and try and replicate the bug.

[1] http://launchpad.net/~ubuntustudio-dev/+archive/

Marco (cosmonotonouille) wrote :

With this upgrade it works fine. (excepts one warning)

$ sudo ubuntustudio-controls
__main__
/usr/bin/ubuntustudio-controls:32: GtkWarning: Ignoring the separator setting
  self.wTree = gtk.glade.XML(self.gladefile)

(ubuntustudio-controls:21646): libglade-WARNING **: could not find a parent that handles internal children for `vbox'

Thanks

Andrew Hunter (rexbron) wrote :

Those warning are harmless. I will be pushing the fixed package to the main archives today.

Changed in ubuntustudio-controls:
status: Confirmed → Fix Committed
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-controls - 0.3.1

---------------
ubuntustudio-controls (0.3.1) intrepid; urgency=low

  * Fixed a typo causing a crash in seralize_settings (LP: #269389)
  * Fixed lintian warnings:
   + Upped debhelper version requirement to (>= 5.0.51~)
   + Rephrased descriptions in debian/control

 -- Andrew Hunter <email address hidden> Tue, 16 Sep 2008 15:30:12 -0500

Changed in ubuntustudio-controls:
status: In Progress → Fix Released
Andrew Hunter (rexbron) on 2008-09-20
Changed in ubuntustudio-controls:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers