ubuntustudio-controls: CPU Governor setting does not persist after reboot

Bug #1809024 reported by Erich Eickmeyer on 2018-12-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Studio
Critical
Unassigned
ubuntustudio-controls
High
Unassigned
ubuntustudio-controls (Ubuntu)
Low
Unassigned

Bug Description

When setting CPU Governor option to anything other than Performance, the setting does not persist after reboot.

To reproduce: Open ubuntustudio-controls, set CPU Governor to Ondemand. Reboot. Open ubuntustudio-controls.

Expected result: CPU Governor is set to Ondemand

Actual result: CPU Governor is set to Performance.

Using Ubuntu Studio 18.10.

Code at lp:ubuntustudio-controls
PPA at ppa:ubuntustudio-dev/autobuilds (https://launchpad.net/~ubuntustudio-dev/+archive/ubuntu/autobuild)

Len Ovens (len-ovenwerks) wrote :

Which version of controls is this? Have you tried this with V 1.7 from the Autobuilds PPA? This issue should be fixed in that version already.

Changed in ubuntustudio-controls (Ubuntu):
status: New → Fix Committed
Jeremy Bicha (jbicha) wrote :

There is nothing here ready to be sponsored.

Changed in ubuntustudio-controls (Ubuntu):
importance: Undecided → Low
Erich Eickmeyer (eeickmeyer) wrote :

Originally made this bug report on the already-published Ubuntu package, meant for the development package. The development package needs to be added to Universe for the upcoming Disco release.

Changed in ubuntustudio-controls:
importance: Undecided → High
status: New → Fix Committed
Ross Gammon (rosco2) wrote :

The package has been tested in our autobuild ppa. I have prepared a debdiff for sponsorship (attached). Alternatively, it can be taken directly from git in the upstream (Ubuntu Studio Devel) repository.

Erich Eickmeyer (eeickmeyer) wrote :

I would rather it be taken directly from the upstream git in lp:ubuntustudio-controls.

summary: - CPU Governor setting does not persist after reboot
+ [needs packaging] CPU Governor setting does not persist after reboot
tags: added: needs-packaging
description: updated
Ross Gammon (rosco2) on 2019-03-03
summary: - [needs packaging] CPU Governor setting does not persist after reboot
+ [needs sponsoring] CPU Governor setting does not persist after reboot
tags: removed: needs-packaging

@Erich

The debdiff was created directly from the repository. Many sponsors prefer to see a debdiff so that they can more easily see what has changed from the last upload.

Offering both possibilities is a good idea, but if something has changed since the debdiff was created, we probably should provide a new debdiff. But in this case I see you have only bumped the standards version since the debdiff was created. This change is not so important, and probably should be added to the changelog in anycase.

The sponsors team are subscribed to the bug and someone will hopefully see it soon and sponsor it.

Erich Eickmeyer (eeickmeyer) wrote :
tags: added: upgrade-software-version
Changed in ubuntustudio:
importance: Undecided → Critical
Changed in ubuntustudio-controls (Ubuntu):
status: Fix Committed → New
Erich Eickmeyer (eeickmeyer) wrote :
Ross Gammon (rosco2) on 2019-03-04
summary: - [needs sponsoring] CPU Governor setting does not persist after reboot
+ ubuntustudio-controls: CPU Governor setting does not persist after
+ reboot
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-controls - 1.7

---------------
ubuntustudio-controls (1.7) disco; urgency=medium

  [ Len Ovens ]
  * Fix double daemon startup (LP: #1798927)
  * Fix governor setting over boot (LP: #1809024)
  * Remove file left over from before
  * Properly ecape variables in logger lines
  * Do not set group if UID is less than 999
  * Change Latency to Buffer size (LP: #1815240)

 -- Ross Gammon <email address hidden> Mon, 18 Feb 2019 21:51:15 +0100

Changed in ubuntustudio-controls (Ubuntu):
status: New → Fix Released
Changed in ubuntustudio:
status: New → Fix Committed
status: Fix Committed → Fix Released
Changed in ubuntustudio-controls:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers