ubuntuone-installer crashed with GError in function(): Failed to execute child process "ubuntuone-control-panel-gtk" (No such file or directory)

Bug #853060 reported by Deep on 2011-09-18
672
This bug affects 142 people
Affects Status Importance Assigned to Milestone
ubuntuone-installer
Status tracked in Trunk
Stable-2-0
Undecided
Unassigned
Stable-3-0
Undecided
Unassigned
Trunk
Critical
dobey
ubuntuone-installer (Ubuntu)
Medium
dobey
Oneiric
High
dobey
Precise
High
dobey
Quantal
Medium
dobey

Bug Description

TEST CASE:

1. Click on Ubuntu One icon in Launcher
2. Click the "Install" button
3. Enter password to allow installation

Expected Result: Installer installs necessary packages and presents Ubuntu One setup wizard

Result: Crash (see details below)

---

Crashed

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: ubuntuone-installer 1.7.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Sun Sep 18 13:19:26 2011
ExecutablePath: /usr/bin/ubuntuone-installer
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/ubuntuone-installer
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_IN.UTF-8
PythonArgs: ['/usr/bin/ubuntuone-installer']
SourcePackage: ubuntuone-installer
Title: ubuntuone-installer crashed with GError in function(): Failed to execute child process "ubuntuone-control-panel-gtk" (No such file or directory)
UpgradeStatus: Upgraded to oneiric on 2011-09-18 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Deep (dipayan1990) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-installer (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Pedro Villavicencio (pedro) wrote :

Setting it to High because of the quantity of users affected.

visibility: private → public
Changed in ubuntuone-installer (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Patrick Dickey (pdickeybeta) wrote :

I can confirm that this affects me on the 12.04 Alpha1. Also, there may be a duplicate bug at https://bugs.launchpad.net/ubuntu/+source/ubuntuone-installer/+bug/876903 but I'm not entirely sure.

   Thank you very much, I will follow up. I am glad some body heard my yell

   Ade.Aji ----- Message from <email address hidden> ---------
    Date: Fri, 30 Dec 2011 12:34:38 -0000
    From: Patrick Dickey <email address hidden>
Reply-To: Bug 853060 <email address hidden>
Subject: [Bug 853060] Re: ubuntuone-installer crashed with GError in
function(): Failed to execute child process
"ubuntuone-control-panel-gtk" (No such file or directory)
      To: <email address hidden>

> I can confirm that this affects me on the 12.04 Alpha1.  Also, there may
> be a duplicate bug at https://bugs.launchpad.net/ubuntu/+source
> /ubuntuone-installer/+bug/876903 but I'm not entirely sure.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (904891).
> https://bugs.launchpad.net/bugs/853060
>
> Title:
>    ubuntuone-installer crashed with GError in function(): Failed to
>    execute child process "ubuntuone-control-panel-gtk" (No such file or
>    directory)
>
> Status in “ubuntuone-installer” package in Ubuntu:
>    Triaged
>
> Bug description:
>    crahsed
>
>    ProblemType: Crash
>    DistroRelease: Ubuntu 11.10
>    Package: ubuntuone-installer 1.7.4-0ubuntu1
>    ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
>    Uname: Linux 3.0.0-11-generic i686
>    ApportVersion: 1.23-0ubuntu1
>    Architecture: i386
>    Date: Sun Sep 18 13:19:26 2011
>    ExecutablePath: /usr/bin/ubuntuone-installer
>    InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release
> i386  (20101007)
>    InterpreterPath: /usr/bin/python2.7
>    PackageArchitecture: all
>    ProcCmdline: /usr/bin/python /usr/bin/ubuntuone-installer
>    ProcEnviron:
>     SHELL=/bin/bash
>     PATH=(custom, no user)
>     LANG=en_IN.UTF-8
>    PythonArgs: ['/usr/bin/ubuntuone-installer']
>    SourcePackage: ubuntuone-installer
>    Title: ubuntuone-installer crashed with GError in function():
> Failed to execute child process "ubuntuone-control-panel-gtk" (No
> such file or directory)
>    UpgradeStatus: Upgraded to oneiric on 2011-09-18 (0 days ago)
>    UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ubuntuone-installer/+bug/853060/+subscriptions
>

----- End message from <email address hidden> -----

tags: removed: bugpattern-needed
tags: added: bugpattern-written

I was fairly surprised to start the Ubuntu One control panel after today's updates and have it tell me that I needed to install Ubuntu One, despite the fact that I was already using it on my Precise install. After following along with the installation of whatever it needed, this crash came up.

I got that on my laptop, and now I'm getting it on my desktop, too. Exact same outcome. Worth noting that relaunching the Ubuntu One control panel still produces the same window asking me to install Ubuntu One; this prevents me from being able to review any of my account details or manage settings outside of the web interface.

zzecool (zzecool) wrote :

Ubuntu one allready "installed" but keeps asking me to install it and crashed in the process .

zzecool (zzecool) wrote :

Problem is solved if you manual install :

sudo apt-get install ubuntuone-control-panel-qt

So it looks like a broken dependency rule.

mfauzirahman (mfauzirahman) wrote :

my issue solved after sudo apt-get install ubuntuone-control-panel-qt

dobey (dobey) wrote :

Anyone who is seeing a similar issue to this on precise: it is almost certainly bug #939797 instead. Please tick the "affects me too" link on there if it does. And as has been stated already, instlaling ubuntuone-control-panel-qt is a workaround.

When I opened Ubuntu One from the menu, the new interface appeared asking me to install Ubuntu One. During this process I received the crach report and now the old version of Ubuntu One is opening.

when i try to start UbuntuOne there is a messege, that i first have to install UbuntuOne. But it crashed...

Leo Arias (elopio) wrote :

As zzecool mentioned, this issue is solved after installing ubuntuone-control-panel-qt. That problem is being fixed on the bug mentioned by Rodney.

I'll mark this bug as incomplete. If this workaround doesn't solve the problem for you, please revert to new and add a comment with the description of what you are experiencing.

Thanks for reporting this. We are sorry about the problems this might have caused to you.
pura vida.

Changed in ubuntuone-installer (Ubuntu):
status: Triaged → Incomplete
kaka (kaka-125) on 2012-03-17
Changed in ubuntuone-installer (Ubuntu):
status: Incomplete → New
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-installer (Ubuntu):
status: New → Confirmed
Leo Arias (elopio) wrote :

kaka, could you please tell us why did you marked this bug as New?

Changed in ubuntuone-installer (Ubuntu):
status: Confirmed → Incomplete
dobey (dobey) on 2012-03-22
Changed in ubuntuone-installer:
status: New → Incomplete
crtm (carlosrtm) wrote :

Today, after update (sudo apt-get update), then crash

while installing ubuntu-one

Nils Geylen (nilsgeylen) wrote :

Perhaps a related subsequent bug CredentialsError DBusException(dbus.String(u'Message did not receive a reply (timeout by message bus)'),)

https://bugs.launchpad.net/ubuntu/+source/ubuntuone-client/+bug/985306

edubuntu usb live - english version - while running apport to submit another bug

halim (mohalim) wrote :

I got this error when I setup ubuntuone

Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/ubuntuone-installer/ubuntuone/installer/gui.py", line 357, in finished
GLib.spawn_command_line_async('ubuntuone-control-panel-gtk')
File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in function
return info.invoke(*args, **kwargs)
gi._glib.GError: Failed to execute child process "ubuntuone-control-panel-gtk" (No such file or directory)

ubuntuone-control-panel-gtk package also failed to install with following error

ubuntuone-control-panel-gtk : Depends: python-aptdaemon.gtkwidgets but it is not going to be installed or python-aptdaemon-gtk but it is not going to be installed

Please help anyone.

Leo Arias (elopio) wrote :

Hi Halim, Sandra, Nils, crtm,

Have you tried on the terminal the following command?
sudo apt-get install ubuntuone-control-panel-qt

ayoub popitto (ayoub) on 2012-04-28
Changed in ubuntuone-installer (Ubuntu):
assignee: nobody → ayoub popitto (ayoub)
Sebastien Bacher (seb128) wrote :

Hey Rodney, could you look at those, it's showing on the top precise reported bugs

Changed in ubuntuone-installer (Ubuntu):
milestone: none → precise-updates
Changed in ubuntuone-installer:
status: Incomplete → New
Changed in ubuntuone-installer (Ubuntu):
assignee: ayoub popitto (ayoub) → Rodney Dawes (dobey)
status: Incomplete → New
Roberto Alsina (ralsina) wrote :

@Sebastian Bacher

He already has looked, there is a bug for it, and he's working on a fix. It's a bit difficult because he has never been able to reproduce it, but we are on track for a fix.

There is a simple wrkaround in the meantime: apt-get install ubuntuone-control-panel-qt

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-installer (Ubuntu):
status: New → Confirmed
Simeon (simeon5) wrote :

This just happened to me when I tried to install the Ubuntu One client while offline. It worked ok once I connected to the internet so maybe that is what is causing it?

John W Sheffield (washerguy1) wrote :

frezzes up on my HP Mini

tags: added: u1-sru
dobey (dobey) on 2012-05-16
Changed in ubuntuone-installer (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntuone-installer:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-installer (Ubuntu Quantal):
milestone: precise-updates → none
Changed in ubuntuone-installer (Ubuntu Precise):
milestone: none → precise-updates
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-installer (Ubuntu Quantal):
importance: High → Medium
Changed in ubuntuone-installer (Ubuntu Precise):
importance: Undecided → High
Changed in ubuntuone-installer (Ubuntu Oneiric):
importance: Undecided → High
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-installer (Ubuntu Precise):
status: New → In Progress
Changed in ubuntuone-installer (Ubuntu Quantal):
status: In Progress → Triaged
Changed in ubuntuone-installer (Ubuntu Oneiric):
status: New → Triaged
Changed in ubuntuone-installer (Ubuntu Precise):
status: In Progress → Triaged
tags: added: precise
dobey (dobey) wrote :

Subscribing ubuntu-release as the fix introduces a bit of UI for showing the error to the user, and allowing a retry of install, or cancelling. However, no new strings are added in the patch. Also, the new bit of UI is integrated into the main app window, and only shown when an error occurs, and shouldn't affect any current documentation.

dobey (dobey) wrote :

Anyone experiencing this bug, could you please try to use https://launchpad.net/~ubuntuone/+archive/nightlies/+files/ubuntuone-installer_3.1%2Br26-16%7Eprecise1_all.deb and post your results here? It should tell you what error you are hitting exactly, and will allow you to retry after fixing it (eg, in case network is down and you need to reconnect). Outside of disabling the network and deleting files from the apt cache, I am unable to reproduce any errors that would result in this problem, myself. This package should hopefully fix the problem for everyone. Thanks.

Mary Corbin (corbinmk) wrote :

Rodney Dawes,

I tried following your instructions and it did not work. It tells me that it is unable to resolve certain libraries:

python
ubuntu-control-panel
ubuntu-control-panel-common

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-installer - 3.0.2-0ubuntu1

---------------
ubuntuone-installer (3.0.2-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Use a logo image with the correct dimensions. (LP: #1004003)
    - Fix the alignment of various widgets. (LP: #1004524)
    - Handle better some error conditions when installing. (LP: #853060)
  * debian/control:
    - Update dependencies to run tests during package build.
    - Update dependencies to support building on older supported Ubuntu.
  * debian/rules:
    - Run the tests during package build.
 -- Rodney Dawes <email address hidden> Mon, 18 Jun 2012 17:16:45 -0400

Changed in ubuntuone-installer (Ubuntu Quantal):
status: Triaged → Fix Released
Kate Stewart (kate.stewart) wrote :

GIven the impact of this, would be good to get this fixed for 12.04.1 if possible.

Changed in ubuntuone-installer (Ubuntu Precise):
milestone: precise-updates → ubuntu-12.04.1
rainmaker (indian) wrote :

After installation while online with updates, on completion, if one tries to install Ubuntu One ones sees that wobbling list of updates that one has not installed. Is that why?

Steve Langasek (vorlon) wrote :

Rodney,

The impact here is that this bug is the top crasher on errors.ubuntu.com. Is it possible to get a fix for this for inclusion in 12.04.1? We would need a fix available in precise-proposed this week for that to happen.

Hello Deep, or anyone else affected,

Accepted ubuntuone-installer into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntuone-installer/3.0.2-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntuone-installer (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
description: updated
Joshua Hoover (joshuahoover) wrote :

Test case passes with proposed enabled with ubuntuone-installer 3.0.2-0ubuntu1.1

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-installer - 3.0.2-0ubuntu1.1

---------------
ubuntuone-installer (3.0.2-0ubuntu1.1) precise-proposed; urgency=low

  * New upstream release. (LP: #1018991)
    - Use a logo image with the correct dimensions. (LP: #1004003)
    - Fix the alignment of various widgets. (LP: #1004524)
    - Handle better some error conditions when installing. (LP: #853060)
  * 00_system-cache-only.patch:
    - Only update cache for system sources.list. (LP: #1015709)
 -- Rodney Dawes <email address hidden> Thu, 09 Aug 2012 14:40:34 -0400

Changed in ubuntuone-installer (Ubuntu Precise):
status: Fix Committed → Fix Released
Frank King (king-fwalter) wrote :

I would like to be able to install this on my pc. thanks for any help. fk

Changed in ubuntuone-installer (Ubuntu):
assignee: Rodney Dawes (dobey) → chad walters (chadwalters18)
dobey (dobey) on 2012-12-31
Changed in ubuntuone-installer (Ubuntu):
assignee: chad walters (chadwalters18) → Rodney Dawes (dobey)
alok rawat (alokraawat) on 2013-01-20
Changed in ubuntuone-installer (Ubuntu):
assignee: Rodney Dawes (dobey) → alok rawat (alokraawat)
dobey (dobey) on 2013-01-20
Changed in ubuntuone-installer (Ubuntu):
assignee: alok rawat (alokraawat) → Rodney Dawes (dobey)
maarten (opperstrietser) on 2013-02-19
Changed in ubuntuone-installer (Ubuntu Precise):
assignee: Rodney Dawes (dobey) → maarten (opperstrietser)
dobey (dobey) on 2013-02-19
Changed in ubuntuone-installer (Ubuntu Precise):
assignee: maarten (opperstrietser) → Rodney Dawes (dobey)
wuxuefeng (wxfcd) on 2013-03-15
Changed in ubuntuone-installer (Ubuntu):
assignee: Rodney Dawes (dobey) → wuxuefeng (wxfcd)
dobey (dobey) wrote :

People, please don't go changing bug assignees at random, and especially not on old already-fixed bugs.

Changed in ubuntuone-installer (Ubuntu):
assignee: wuxuefeng (wxfcd) → Rodney Dawes (dobey)
Changed in ubuntuone-installer (Ubuntu Oneiric):
status: Triaged → Won't Fix
Download full text (3.7 KiB)

Hi,   Sorry, I don-t understand what you want I do....  Can you translate a little bit in french?

Last update, I had some problems with systematic crashes of dpkg.

Message :

installArchives() failed: dpkg: unrecoverable fatal error, aborting:
 syntax error in statoverride file
Error in function:
 ????

I can't upgrade anything now. Have you an idea ?

I put a conky to have meteo on desktop in realtime : is there this conky that crash dpkg?   My desktop  in "piece jointe"

Thanks for your help.

Guy Roche

mail <email address hidden>
mail <email address hidden>

domicile 0324 376446
mobile 0619 178018

> Message du 15/03/13 15:25
> De : "Rodney Dawes"
> A : <email address hidden>
> Copie à :
> Objet : [Bug 853060] Re: ubuntuone-installer crashed with GError in function(): Failed to execute child process "ubuntuone-control-panel-gtk" (No such file or directory)
>
>
> People, please don't go changing bug assignees at random, and especially
> not on old already-fixed bugs.
>
>
> ** Changed in: ubuntuone-installer (Ubuntu)
> Assignee: wuxuefeng (wxfcd) => Rodney Dawes (dobey)
>
> ** Changed in: ubuntuone-installer (Ubuntu Oneiric)
> Status: Triaged => Won't Fix
>
> ** Changed in: ubuntuone-installer/stable-2-0
> Status: New => Won't Fix
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> ubuntu-12.04.1.
> Matching subscriptions: No Audio after update kernel 3 2 025 in Ubuntu 12 04 32bits. Good in kernel 3 2 024 ! Alsa 1 025 not compiled in kernel 3 2 025. It's the same problem with ubuntu 12 10 alpha I tried today too !(but kernel 3 4 ...). A+
> https://bugs.launchpad.net/bugs/853060
>
> Title:
> ubuntuone-installer crashed with GError in function(): Failed to
> execute child process "ubuntuone-control-panel-gtk" (No such file or
> directory)
>
> Status in Ubuntu One Installer:
> Fix Released
> Status in ubuntuone-installer stable-2-0 series:
> Won't Fix
> Status in ubuntuone-installer stable-3-0 series:
> Fix Released
> Status in ubuntuone-installer trunk series:
> Fix Released
> Status in “ubuntuone-installer” package in Ubuntu:
> Fix Released
> Status in “ubuntuone-installer” source package in Oneiric:
> Won't Fix
> Status in “ubuntuone-installer” source package in Precise:
> Fix Released
> Status in “ubuntuone-installer” source package in Quantal:
> Fix Released
>
> Bug description:
> TEST CASE:
>
> 1. Click on Ubuntu One icon in Launcher
> 2. Click the "Install" button
> 3. Enter password to allow installation
>
> Expected Result: Installer installs necessary packages and presents
> Ubuntu One setup wizard
>
> Result: Crash (see details below)
>
> ---
>
> Crashed
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: ubuntuone-installer 1.7.4-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
> Uname: Linux 3.0.0-11-generic i686
> ApportVersion: 1.23-0ubuntu1
> Architecture: i386
> Date: Sun Sep 18 13:19:26 2011
> ExecutablePath: /usr/bin/ubuntuone-installer
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/ubuntuone-ins...

Read more...

Boa tarde!
Estou usando o Ubuntu 12.04 LTS no virtualbox e não estou conseguindo instalar as atualizações e tambem não consigo instalar o Ubuntu one, talves seja o motivo de está dando erro. Grato! Sandro.

Mark Chapman (n-mark) wrote :

Hi Rodney - My computer crashed as I installed Ubuntu One - & I followed a process that took me through to messaging you. I am not quite sure how this works. Can u send me the fix? Thx, Mark

@Mark Chapman This bug is marked Fix Released for Ubuntu 12.04 LTS and 12.10. You can simply get the fix by running updates through the Update Manager if you have not done so already. If you are running Ubuntu 11.10, the fix is not available for that version and I suggest you upgrade Ubuntu to a later version.

If you already have the latest updates and you are still getting this problem, however, then I'd suggest you file a new bug report.

Chad Loveland (chase31976) wrote :

There was an error creating the child process for this terminal Failed to execute child process “/snap/bin/avahi.avahi-daemon” (No such file or directory) attempting to use the Avahi

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers