ubuntuone-control-panel-qt consistently fails to start

Bug #963538 reported by joehill on 2012-03-23
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ubuntuone-control-panel (Ubuntu)
High
Natalia Bidart

Bug Description

One my desktop computer every time I try to run ubuntuone-control-panel-qt, it fails to start. I get the following output in the terminal:

Traceback (most recent call last):
  File "/usr/bin/ubuntuone-control-panel-qt", line 29, in <module>
    from ubuntuone.controlpanel.gui.qt import main
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/main/__init__.py", line 24, in <module>
    from ubuntuone.controlpanel.gui.qt.gui import start
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/gui.py", line 22, in <module>
    from ubuntuone.controlpanel.gui.qt.ui import mainwindow_ui
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/ui/mainwindow_ui.py", line 53, in <module>
    from ubuntuone.controlpanel.gui.qt.controlpanel import ControlPanel
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/controlpanel.py", line 46, in <module>
    from ubuntuone.controlpanel.gui.qt.ui import controlpanel_ui
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/ui/controlpanel_ui.py", line 225, in <module>
    from ubuntuone.controlpanel.gui.qt.folders import FoldersPanel
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/folders.py", line 28, in <module>
    from ubuntuone.controlpanel.utils import default_folders
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/utils/__init__.py", line 42, in <module>
    from ubuntuone.controlpanel.utils import linux
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/utils/linux.py", line 22, in <module>
    from dirspec.basedir import xdg_config_home
ImportError: No module named dirspec.basedir

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubuntuone-client 2.99.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
Date: Sat Mar 24 00:45:07 2012
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client
UbuntuOneSyncdaemonExceptionsLog:
 2012-03-23 22:19:09,833 - twisted - ERROR - Unhandled error in Deferred:
 2012-03-23 22:19:09,859 - twisted - ERROR - Unhandled Error
 Traceback (most recent call last):
 Failure: twisted.internet.error.ConnectionLost: Connection to the other side was lost in a non-clean fashion: Connection lost.
UpgradeStatus: Upgraded to precise on 2012-03-22 (1 days ago)

joehill (joseph-hill) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed

It looks like a dependency for python-dirspec is missing in the Ubuntu One packages; Installing the python-dirspec package fixes the problem.

dobey (dobey) on 2012-03-26
affects: ubuntuone-client (Ubuntu) → ubuntuone-control-panel (Ubuntu)
Changed in ubuntuone-control-panel (Ubuntu):
importance: Undecided → High
assignee: nobody → Natalia Bidart (nataliabidart)
Changed in ubuntuone-control-panel (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 2.99.91-0ubuntu2

---------------
ubuntuone-control-panel (2.99.91-0ubuntu2) precise; urgency=low

  * debian/control:
    - Adding missing dependency on python-dirspec for
      python-ubuntuone-control-panel (LP: #963538).
 -- Natalia Bidart (nessita) <email address hidden> Mon, 26 Mar 2012 13:45:58 -0300

Changed in ubuntuone-control-panel (Ubuntu):
status: In Progress → Fix Released
Joe Liau (joe) wrote :

I'm still getting this problem in 13.04

python-dirspec is installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers