Unity icon acts funny after upgrade that introduces QT control panel

Bug #939691 reported by Rick McBride on 2012-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
Status tracked in Trunk
Stable-3-0
High
dobey
Trunk
High
dobey
ubuntuone-control-panel (Ubuntu)
High
dobey
Precise
High
dobey

Bug Description

Icon behavior in the Unity launcher for the U1 CP is unusual after the most recent upgrade introducing the QT control panel.

I at one point had a grey "?" icon that was non-responsive replacing my CP icon. I later determined that this was becuase I hadn't done the requisite dist-upgrade. However we also have seen some weeridness as follows:

http://ubuntuone.com/54UZc4bqdnU5BAoLMWxiGj
12:36 < Chipaca> dobey: when i locked it to the launcher, it got a gray background. When
                 unlocked, it isn't visible in alt-tab
12:36 < Chipaca> something weird is going on :(
12:37 < dobey> Chipaca: yeah, and i know exactly what it is :)
12:37 < Chipaca> dobey: all the same bug?
12:37 < dobey> yes

Assigning to Rodney as he apparently knows what the problem is. (combination of bamf, unity, and missing wm class stuffs, basically)

Related branches

Rick McBride (rmcbride) on 2012-02-23
Changed in ubuntuone-client:
status: New → Confirmed
assignee: nobody → Rodney Dawes (dobey)
tags: added: u1-qa
dobey (dobey) on 2012-02-23
no longer affects: ubuntuone-client
no longer affects: ubuntuone-client/stable-3-0
no longer affects: ubuntuone-client/trunk
dobey (dobey) on 2012-02-23
Changed in ubuntuone-control-panel (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Rodney Dawes (dobey)
Rick McBride (rmcbride) wrote :

strangely, I have now seen other wierd behavior. Twice I tried to launch the control panel from the notifications menu and got nothing.

I launched qt control panel from the terminal, and it then launched, creating an icon on the launcher that has two icon spaces above it. once of which gives an ubuntuone mouseover/quickmenu that does nothing.

Rick McBride (rmcbride) wrote :

and having locked THAT icon to the launcher, it fails to launch either control panel.

Rick McBride (rmcbride) wrote :

http://ubuntuone.com/6U5yuVBJNs62BwzOzpPGj1

is the screenshot for the above described behavior.

LP's attachment interface is throwing an error.

Rick McBride (rmcbride) wrote :

and now the attachement interface works again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 2.99.5-0ubuntu2

---------------
ubuntuone-control-panel (2.99.5-0ubuntu2) precise; urgency=low

  * debian/patches/fix-939691.patch:
    - Set appname arg for QApplication to avoid duplication. (LP: #939691)
 -- Rodney Dawes <email address hidden> Thu, 23 Feb 2012 15:43:21 -0500

Changed in ubuntuone-control-panel (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments