ubuntuone-control-panel-qt crashed with UnicodeDecodeError in /usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/filesyncstatus.py: 'ascii' codec can't decode byte 0xc3 in position 24: ordinal not in range(128)

Bug #937809 reported by Roman Yepishev on 2012-02-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Trunk
High
Natalia Bidart
ubuntuone-control-panel (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntuone-control-panel-qt
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-control-panel-qt", line 63, in <module>
    with_icon=options.with_icon)
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/main/__init__.py", line 50, in main
    from ubuntuone.controlpanel.gui.qt.gui import start
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/gui.py", line 25, in <module>
    from ubuntuone.controlpanel.gui.qt.ui import mainwindow_ui
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/ui/mainwindow_ui.py", line 53, in <module>
    from ubuntuone.controlpanel.gui.qt.controlpanel import ControlPanel
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/controlpanel.py", line 42, in <module>
    from ubuntuone.controlpanel.gui.qt.ui import controlpanel_ui
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/ui/controlpanel_ui.py", line 228, in <module>
    from ubuntuone.controlpanel.gui.qt.filesyncstatus import FileSyncStatus
  File "/usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/filesyncstatus.py", line 73, in <module>
    {'msg': WARNING_MARKUP % FILE_SYNC_ERROR, 'action': FILE_SYNC_RESTART,
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 24: ordinal not in range(128)

Nothing else is printed to the terminal - 2.99.4-0ubuntu1

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: ubuntuone-control-panel-qt 2.99.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.92-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Tue Feb 21 16:12:27 2012
ExecutablePath: /usr/bin/ubuntuone-control-panel-qt
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120119)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/ubuntuone-control-panel-qt
PythonArgs: ['/usr/bin/ubuntuone-control-panel-qt']
SourcePackage: ubuntuone-control-panel
Title: ubuntuone-control-panel-qt crashed with UnicodeDecodeError in /usr/lib/python2.7/dist-packages/ubuntuone-control-panel/ubuntuone/controlpanel/gui/qt/filesyncstatus.py: 'ascii' codec can't decode byte 0xc3 in position 24: ordinal not in range(128)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Roman Yepishev (rye) wrote :
tags: removed: need-duplicate-check
Roman Yepishev (rye) on 2012-02-21
visibility: private → public
Roman Yepishev (rye) wrote :

This is happening because gettext.gettext() returns 'str' but e.g. Spanish translation is in utf-8.

to reproduce on en_US (latin1-compatible) installs - export LANG=es_ES.UTF-8 LANGUAGE=es_ES:en_US:en LC_ALL=en_US.UTF-8
and then launch ubuntuone-control-panel-qt

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 2.99.5-0ubuntu1

---------------
ubuntuone-control-panel (2.99.5-0ubuntu1) precise; urgency=low

  * New upstream release:
    - Control Panel shows quota in red with more accuracy depending on the
      free space (LP: #901314).
    - The Qt UI will make the file sync button inactive while a (re-) connection
      is in progress (LP: #878867).
    - Center the Qt UI main window when openning it (LP: #934173).
  * debian/control:
    - added a new binary package ubuntuone-control-panel-common providing
      common files and images for the frontend packages.
    - ubuntuone-control-panel-qt and ubuntuone-control-panel-gtk now depend on
      ubuntuone-control-panel-common.
    - bumping dependencies on ubuntu-sso-client to 2.99.5 and on
      ubuntuone-client to 2.99.4.
  * debian/patches/fix-937809-938626.patch:
    - Make gettext return unicode so we can format strings with unicode
      variables (LP: #937809).
    - No more strings coming up from the Designer ui files to ensure those get
      listed for translation (LP: #938626).
  * debian/ubuntuone-control-panel-common.install: new binary package listing
    files used by both the Qt and the GTK+ UIs.
  * debian/watch: updated milestone to 2.99.5.
 -- Natalia Bidart (nessita) <email address hidden> Wed, 22 Feb 2012 17:29:31 -0300

Changed in ubuntuone-control-panel (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers