U1 control panel scroll bar doesn't scroll anything

Bug #932246 reported by Steve Magoun on 2012-02-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntuone-control-panel (Ubuntu)
Undecided
Ubuntu One Client Engineering team

Bug Description

The U1 control panel seems to have a vertical scroll bar at all times, but the scroll bar doesn't do anything.

To reproduce:
1) Launch the U1 control panel
2) Resize the window to its minimum (default?) size

Expected results:
There is no vertical scroll bar in the control panel because there is not enough content to fill up the window or require vertical scrolling

Actual results:
There is always a vertical scroll bar. Scrolling has no apparent effect

(If the U1 control panel is resized to be large enough - around 900px high - the scrollbar does go away)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubuntuone-control-panel 2.99.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic 3.2.5
Uname: Linux 3.2.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Tue Feb 14 13:40:59 2012
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-control-panel
UpgradeStatus: Upgraded to precise on 2012-02-13 (0 days ago)

Steve Magoun (smagoun) wrote :
Paolo Rotolo (paolorotolo) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in ubuntuone-control-panel (Ubuntu):
status: New → Confirmed
Leo Arias (elopio) on 2012-02-17
tags: added: gtk-u1
Leo Arias (elopio) wrote :

I can reproduce this on a fully updated precise machine, so I'm marking it as triaged.

We are working on a new control panel with a different set of UI libraries, so this will probably have a low priority. We will take care that this doesn't on the new UI, of course.

Thanks for your report.

Changed in ubuntuone-control-panel (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Leo Arias (elopio) on 2012-02-17
tags: added: gtk-ui
removed: gtk-u1
dobey (dobey) wrote :

Setting this to Fix Released as the new Qt based control panel is in Precise now, and does not have this problem.

Changed in ubuntuone-control-panel (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers