Ubuntu

Filesync fails with org.freedesktop.DBus.Error.UnknownMethod error

Reported by Björn Tillenius on 2011-09-25
262
This bug affects 61 people
Affects Status Importance Assigned to Milestone
ubuntuone-control-panel (Ubuntu)
Undecided
Ubuntu One Client Engineering team

Bug Description

When I open the control panel, the filesync fails with the following error:

  org.freedesktop.DBus.Error.UnknownMethod: Method "current_status" with signature "" on interface "com.ubuntuone.SyncDaemon.Status" doesn't exist

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubuntuone-control-panel 1.1.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Sun Sep 25 13:52:45 2011
PackageArchitecture: all
ProcEnviron:
 LC_TIME=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-control-panel
UpgradeStatus: Upgraded to oneiric on 2011-09-24 (0 days ago)

Björn Tillenius (bjornt) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-control-panel (Ubuntu):
status: New → Confirmed
Farran (farran) wrote :

Just for the record, this affected me in 11.04 as well, but I couldn't find any fix for it at all. In fact, it would regularly hang my system so I had to remove it.
Ubuntu One was reinstalled during the upgrade (which I only just did) and it still gives exactly the same error:

File Sync error. (org.freedesktop.DBus.Error.UnknownMethod: Method "current_status" with signature "" on interface "com.ubuntuone.SyncDaemon.Status" doesn't exist)

Josh Smith (saxsux) wrote :

I'd been having this problem too, since I upgraded from Natty to Oneiric beta. Deleting ~/.config/ubuntuone and ~/.local/share/ubuntuone and restarting my computer seems to have sorted it out.

fmarcia (franck-marcia) wrote :

Thanks, saxsux
It worked!
But I had to resync everything though

I tried to remove the folders: ~/.config/ubuntuone and ~/.local/share/ubuntuone but still see the same issue. What seems strange to me is, that after deletinf the config folder I still do not have to present my credentials. could it be that they are stored somewhere as well?

Here is my error:
u1sdtool --status

Oops, an error ocurred:
Traceback (most recent call last):
Failure: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "current_status" with signature "" on interface "com.ubuntuone.SyncDaemon.Status" doesn't exist

Sal Vador (sjwernowski) wrote :

Thanks! I removed ~/.config/ubuntuone and ~/.local/share/ubuntuone, restarted and sync worked.

I did however have to go and re-check the boxes of the folders I wanted to sync like fmarcia stated, but that didn't take long.

The problem only started for me, and from what I can tell, since I installed 11.10.

Thanks again!

I finally solved the problem by also removing the credentials from the gnome key ring

I had the same problem got solved by deleting the mentioned folders AND removing credentials from gnome key ring. (Ubuntu 11.10)

c3d (deserters) on 2011-11-29
description: updated

deleting folders and credentials doesn't work for me

also tried to reinstall ubuntuone stuffs without success

diego.125k (diego-guerrero125) wrote :

Bump!!
I see it's a litle old issue and is not solved. It just happened to me for no reason

What I did, but still dont work

$rm -R ~/.config/ubuntuone
$rm -R ~/.local/share/ubuntuone
$sudo apt-get purge ubuntuone-installer
$sudo apt-get autoclean
$sudo apt-get autoremove
$sudo apt-get update
$sudo apt-get upgrade
(the last 4 are may be redundant, but just in case)
$sudo apt-get install ubuntuone-installer ubuntuone-control-panel-gtk
$sudo ubuntuone-installer
(click on install button)
$ubuntuone-control-panel-gtk

it seems to work, asked me for u1 user/pass and when connecting. the same error on red label on the GUI =( so sad!
(sorry my english...)

Thanks in advance for any update, I really use u1

Leo Arias (elopio) on 2012-01-18
Changed in ubuntuone-control-panel (Ubuntu):
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
tags: added: desktop+
diego.125k (diego-guerrero125) wrote :

after what I did yesterday, in the next power up, then login.. I see the notification about new folders available for sync! Its working now

so, what i did:

remove both folders
purge an reinstall U1
reboot

Leo Arias (elopio) wrote :

Thanks for the information Diego.

Björn Tillenius, can you please tell us if this is still an issue for you?

Changed in ubuntuone-control-panel (Ubuntu):
status: Confirmed → Incomplete
Björn Tillenius (bjornt) wrote :

I think I did something similar to what Diego did to get it to work again. I can't reproduce it.

Leo Arias (elopio) wrote :

Thanks Björn. I'll close this bug as I can't reproduce it either. If somebody is still experiencing this problem, please reopen and add the steps to reproduce.

pura vida.

Changed in ubuntuone-control-panel (Ubuntu):
status: Incomplete → Invalid

i have this problem also please help

diego.125k (diego-guerrero125) wrote :

It is back on the same Notebook, but not in my Desktop PC or my Netbook.. I thing i'll have to purge/reinstall/reboot again

Changed in ubuntuone-control-panel (Ubuntu):
status: Invalid → Confirmed
tobyS (tobias-schlitt) wrote :

Same issue here. Any news on that?

Roman Yepishev (rye) wrote :

I was able to reproduce this by creating a zero-bytes size file in tritcask directory. Guillermo, this looks like bug #825366 but we don't crash with mmap error.

Leo Arias (elopio) on 2012-03-19
Changed in ubuntuone-control-panel (Ubuntu):
status: Confirmed → Triaged
wildel (delphine-wilner) wrote :

Same problem happened to me although I did not see any major change in my system configuration (using Oneiric, worked fine before today, no idea why it stopped working all of a sudden).

I removed ~/.config/ubuntuone and ~/.local/share/ubuntuone, restarted the computer and the sync now works again.
Thanks!

JC Hulce (soaringsky) wrote :

This bug has prevented my Oneiric machine from syncing for months. I removed the keyring entry and ~/.config/ubuntuone and ~/.local/share/ubuntuone, restarted the computer and the sync now works again.

I have followed the instructions of diego and also JC Hulce on 12.04, I am still getting the same errors

I ran:
sudo apt-get remove --purge ubuntuone-installer && sudo apt-get autoclean && sudo apt-get autoremove && sudo apt-get update && sudo apt-get upgrade && sudo apt-get install ubuntuone-installer ubuntuone-control-panel-gtk

In xsession-errors I am getting:
* (nautilus:2241): WARNING **: Error calling current_status: Method "current_status" with signature "" on interface "com.ubuntuone.SyncDaemon.Status" doesn't exist

** (nautilus:2241): CRITICAL **: syncdaemon_status_info_get_online: assertion `SYNCDAEMON_IS_STATUS_INFO (sinfo)' failed

I noticed an error message in an error window saying something about JSON, but I couldn't copy the message.

Any help appreciated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers