String freeze exception: still offers Evolution plug-in for contact sync in Oneiric

Bug #849494 reported by Christopher Kyle Horton on 2011-09-13
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
High
Natalia Bidart
ubuntuone-control-panel (Ubuntu)
Medium
Natalia Bidart

Bug Description

The Ubuntu One Control Panel still offers users contact sync with a plug-in for Evolution, but Oneiric now comes with Thunderbird instead of Evolution by default. See attached screenshot around where the mouse pointer is.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubuntuone-control-panel 1.1.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Tue Sep 13 18:24:05 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110909)
PackageArchitecture: all
SourcePackage: ubuntuone-control-panel
UpgradeStatus: Upgraded to oneiric on 2011-09-13 (0 days ago)

Related branches

Changed in ubuntuone-control-panel (Ubuntu):
status: New → Confirmed
assignee: nobody → Natalia Bidart (nataliabidart)
importance: Undecided → Medium
Changed in ubuntuone-control-panel:
assignee: nobody → Natalia Bidart (nataliabidart)
importance: Undecided → High
status: New → Confirmed
summary: - Ubuntu One Control Panel still offers Evolution plug-in for contact sync
+ String freeze exception: still offers Evolution plug-in for contact sync
in Oneiric
Changed in ubuntuone-control-panel:
status: Confirmed → In Progress
Changed in ubuntuone-control-panel (Ubuntu):
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

I don't quite understand what the problem is here? Evolution is still in main and will be there for upgraders, and a lot of people still use it. Does U1 actually work for thunderbird contacts sync?

Natalia Bidart (nataliabidart) wrote :

Agreed that lots of people still use and will keep using Evolution, but we're targeting the new Ubuntu users, who will have only Thunderbird installed by default.

From those that still use Evolution, we have 2 cases: ubuntu upgrades or clean installs. For the former case, everything will keep working the same (evolution and evolution-couchdb will be installed, upgraded, and working). For the latter, the user will have to explicitly install the evolution package, and ergo will also have to install evolution-couchdb.

When a new Ubuntu user register a new device against Ubuntu One, we want to offer the contact sync functionality for the default email client they will be using, not for Evolution that may not be even installed in his system.

Regarding U1 working with Thunderbird, is my understanding that is indeed working since Chris worked on those bits (big thanks to him!). Of course it wasn't working until the new couchdb was uploaded (last night as per Rodney's info), but it should be working with the latest couch.

Thanks for looking into this!

This is probably a bit off-topic, but just out of curiosity, Natalia: when you say U1 contact sync is now working with Thunderbird, do you know which package supplies this functionality? Is it still evolution-couchdb or something else? I'm eager to test that out but have not even attempted doing so yet because of this bug.

dobey (dobey) wrote :

Martin, as far as I know, Thunderbird is able to display contacts from evolution-data-server already, and is only missing the UI pieces necessary to interact with CouchDB and add an address book and such, within Thunderbird. Chris has an extension for this, which I believe is not yet packaged in Oneiric, but is a requirement for Oneiric, and will be very soon. I did see that he did the necessary splitting of evolution-couchdb into two separate packages earlier today, though. So I expect it will be there soon.

Martin Pitt (pitti) wrote :

Thanks for the clarifications. Fine for me to update the string then, but please don't do it until it is actually working with tbird, i. e. the missing extension is packaged.

David Planella (dpm) wrote :

Thanks for the heads up.

Is the plugin not compatible with both?

I'd say it's ok from the translations side, but it might be worth rephrasing the string to 'e-mail client' or something along those lines, so that the string does need to be changed every time we change our default e-mail client.

Chris Coulson (chrisccoulson) wrote :

Note, that contact sync currently doesn't work with either Thunderbird or Evolution anyway. Both display the same error message here ('There was a problem opening the address book "Ubuntu One" - the message returned was: Cannot open book: Could not create DesktopcouchSession object'.)

I've got an extension ready to upload (thunderbird-couchdb) which handles the initial addressbook creation, but all that it does at the moment is cause thunderbird to display the same error message from eds every time it does something with the addressbook. I'm still not keen on uploading something which is only going to result in people reporting bugs against thunderbird

dobey (dobey) wrote :

Chris, it seems this issue somewhere in evolution-couchdb, couchdb-glib, or e-d-s itself. Using the desktopcouch Python API, it seems I can talk to couchdb just fine, and read content stored there. Most likely, this is probably some change in e-d-s 3.x that breaks things. Rodrigo and I just did a bit of debugging on IRC, and it seems to point that direction. Possibly a change that breaks plug-ins that work the way evolution-couchdb does.

I think we should get it uploaded asap. It's not going to be installed by default anyway, so I don't think the risk is that great. And most installations will probably only come after a new ubuntuone-control-panel is uploaded which has the changes described in this bug implemented.

Changed in ubuntuone-control-panel:
status: In Progress → Fix Committed
dobey (dobey) on 2011-09-26
Changed in ubuntuone-control-panel:
milestone: none → 2.0.0
Changed in ubuntuone-control-panel (Ubuntu):
milestone: none → ubuntu-11.10
Changed in ubuntuone-control-panel:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 2.0.0-0ubuntu1

---------------
ubuntuone-control-panel (2.0.0-0ubuntu1) oneiric; urgency=low

  * New upstream release:

    [ Alejandro J. Cura <email address hidden>]
      - Do not throw a webclient error when closing
        (LP: #845105).
    [ Natalia B. Bidart <email address hidden> ]
      - Removed all code related to Bookmarks (LP: #850142).
      - Replaces references to "Evolution" by "Thunderbird" (LP: #849494).
    [ Rodney Dawes <email address hidden> ]
      - Don't install a .desktop file for control panel
        (part of LP: #838778).
      - Point the indicator/Unity API at the installer .desktop file
        (part of LP: #838778).
      - Set the WMCLASS so Unity will fall back properly
        (part of LP: #838778).
      - Fix a few grammar mistakes (LP: #835093).
      - Don't show the "Get NGB free!" label on "Join now" button at all
        (LP: #819955).

  * debian/control:
    - ubuntuone-control-panel-gtk depends now on ubuntuone-installer >= 2.0.0.
    - require ubuntuone-client >= 2.0.0.
    - require ubuntu-sso-client >= 1.4.0.
    - no longer install a .desktop file (will be installed by ubuntuone-installer).
 -- Natalia Bidart (nessita) <email address hidden> Mon, 26 Sep 2011 14:55:15 -0300

Changed in ubuntuone-control-panel (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers