After installing Ubuntu One, there are 2 Ubuntu One launchers in System Settings

Bug #838778 reported by Jeremy Bicha on 2011-09-01
352
This bug affects 77 people
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
High
dobey
ubuntuone-control-panel (Ubuntu)
High
dobey
Oneiric
High
dobey

Bug Description

Install Ubuntu One. Open System Settings. There are two Ubuntu One launchers.

Possible Fixes:
1. Have the real Ubuntu One replace (provides?) the installer
2. The installer should be smart enough to hide itself from System Settings after being installed.
3. Since the installer provides a System Settings icon that can launch the real Ubuntu One, don't have the real Ubuntu One provide a System Settings launcher. This would require the real Ubuntu One to depend on the installer to work as designed, but perhaps having the installer still installed isn't a good idea.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubuntuone-installer 1.7.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
Date: Thu Sep 1 08:35:34 2011
PackageArchitecture: all
SourcePackage: ubuntuone-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeremy Bicha (jbicha) wrote :
Rodrigo Moya (rodrigo-moya) wrote :

The .desktop file in ubuntuone-installer should not include the magic to make it show in g-c-c shell. That is, it should not have the X-GNOME-Settings-Panel field and the Categories field should be changed to a different value

Changed in ubuntuone-installer:
assignee: nobody → Rodney Dawes (dobey)
status: New → Triaged
importance: Undecided → High
Changed in ubuntuone-installer (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
Dmitry Shachnev (mitya57) wrote :

(Copying my comment from bug 837660)

This is caused by incorrect flags in ubuntuone-control-panel-gtk.desktop.

Fix:
--- Categories=GNOME;GTK;Settings;DesktopSettings;X-GNOME-Settings-Panel;X-GNOME-PersonalSettings
+++ Categories=GNOME;GTK;Settings;DesktopSettings;X-GNOME-PersonalSettings

I have this problem on a fresh install of Oneiric Beta 1. No prior setup with Ubuntu One was done. I also get duplicate Ubuntu One entries in the Dash (as noted in a comment and screenshot attachment I made on bug 841141, which was marked as a duplicate of this one).

Changed in ubuntuone-installer (Ubuntu):
importance: Undecided → High
Mikey (michael-r-a-gray) wrote :

QUOTING Dmitry Shachnev (mitya57):

This is caused by incorrect flags in ubuntuone-control-panel-gtk.desktop.

Fix:
--- Categories=GNOME;GTK;Settings;DesktopSettings;X-GNOME-Settings-Panel;X-GNOME-PersonalSettings
+++ Categories=GNOME;GTK;Settings;DesktopSettings;X-GNOME-PersonalSettings

-------------------------

I tried making this change to /usr/share/app-install/desktop/ubuntuone-control-panel-gtk.desktop but the file seemed to be empty or not there (I was using gedit to access it). Could you please give some instructions on how to make this change as it would be great to sort this if it's an easy fix?

Jeremy Bicha (jbicha) wrote :

Michael, the app-install desktop files are for Software Center icons. Try /usr/share/applications/ instead.

Thanks for the hint, Jeremy. I edited /usr/share/applications/ubuntuone-control-panel-gtk.desktop using nano according to Dmitry's fix, and I can confirm it works for getting rid of the duplicate Ubuntu One entry in System Settings. I'm still getting duplicate entries in the Dash, however.

Rodrigo Moya (rodrigo-moya) wrote :

What should be changed is /usr/share/applications/ubuntuone-installer.desktop, not /usr/share/applications/ubuntuone-control-panel-gtk.desktop, since the latter is a 1-time thing, so has no place in the control center

Changed in ubuntuone-installer (Ubuntu Oneiric):
status: Confirmed → Triaged
dobey (dobey) wrote :

Actually, we need to do a fair bit more work to make this right, providing the user experience we want. It seems we need to remove the control panel .desktop completely, and use _NET_WM_CLASS within it, so we don't get duplicate launchers in unity.

dobey (dobey) on 2011-09-08
affects: ubuntuone-installer → ubuntuone-control-panel
affects: ubuntuone-installer (Ubuntu Oneiric) → ubuntuone-control-panel (Ubuntu Oneiric)
Changed in ubuntuone-control-panel (Ubuntu Oneiric):
assignee: nobody → Rodney Dawes (dobey)
Siert (sgz) wrote :

This bug affects me aswell, see attached screencap.

tags: added: rls-mgr-o-tracking
Changed in ubuntuone-control-panel:
status: Triaged → Fix Committed

When will the fix be pushed out? I still don't see the problem resolved, and my system as of right now is fully up-to-date.

dobey (dobey) wrote :

It is fixed in trunk and nightlies, but not yet in Ubuntu, as is reflected in this bug's status.

There are some other fixes we want to put in a new release, and they require some freeze exceptions; and any new release at the moment will require a freeze exception for being uploaded during beta freeze.

dobey (dobey) on 2011-09-26
Changed in ubuntuone-control-panel:
milestone: none → 2.0.0
Changed in ubuntuone-control-panel (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
Changed in ubuntuone-control-panel:
status: Fix Committed → Fix Released

I'm using the last patches on the date of this post and still I'm experiencing the issue. Is the fix going to be implemented on the final release?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 2.0.0-0ubuntu1

---------------
ubuntuone-control-panel (2.0.0-0ubuntu1) oneiric; urgency=low

  * New upstream release:

    [ Alejandro J. Cura <email address hidden>]
      - Do not throw a webclient error when closing
        (LP: #845105).
    [ Natalia B. Bidart <email address hidden> ]
      - Removed all code related to Bookmarks (LP: #850142).
      - Replaces references to "Evolution" by "Thunderbird" (LP: #849494).
    [ Rodney Dawes <email address hidden> ]
      - Don't install a .desktop file for control panel
        (part of LP: #838778).
      - Point the indicator/Unity API at the installer .desktop file
        (part of LP: #838778).
      - Set the WMCLASS so Unity will fall back properly
        (part of LP: #838778).
      - Fix a few grammar mistakes (LP: #835093).
      - Don't show the "Get NGB free!" label on "Join now" button at all
        (LP: #819955).

  * debian/control:
    - ubuntuone-control-panel-gtk depends now on ubuntuone-installer >= 2.0.0.
    - require ubuntuone-client >= 2.0.0.
    - require ubuntu-sso-client >= 1.4.0.
    - no longer install a .desktop file (will be installed by ubuntuone-installer).
 -- Natalia Bidart (nessita) <email address hidden> Mon, 26 Sep 2011 14:55:15 -0300

Changed in ubuntuone-control-panel (Ubuntu Oneiric):
status: Triaged → Fix Released

Confirming that this fix works for me, getting rid of the duplicate entries both in the System Settings and in the Dash.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers