Join button says you only get 2GB of free storage

Bug #819955 reported by Dave Morley on 2011-08-02
106
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
Status tracked in Trunk
Stable-1-0
Medium
Unassigned
Trunk
Medium
dobey
Ubuntu Translations
Medium
Unassigned
ubuntuone-control-panel (Ubuntu)
Medium
dobey
Natty
Undecided
Unassigned
Oneiric
Medium
dobey

Bug Description

The panel in natty and oneiric both say that there is only 2 gig of storage on u1 not the 5 gig available.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubuntuone-control-panel 1.0.0-0ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Tue Aug 2 19:12:13 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-control-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Dave Morley (davmor2) wrote :
dobey (dobey) on 2011-08-02
Changed in ubuntuone-control-panel (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
dobey (dobey) wrote :

It's the 'Join' button on the first page, in the event you don't have an account, which unfortunately always gets displayed because it takes a second to check for local credentials. It has no bearing on what you actually get with an account, whih is now 5GB as of the recent plan change announcement and new web site deployment.

summary: - u1 control panel incorrectly states that you only have 2gig of storage
+ Join button says you only get 2GB of free storage
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :

added a screenshot for clarity :)

Paolo Rotolo (paolorotolo) wrote :

I can confirm this issue.
See the screenshot for more information.

Milo Casagrande (milo) wrote :

I subscribed the Ubuntu Translations Coordinators since we should be in UI freeze right now and this needs attention on their side too.

Any ETA on fixing this? I'll attach a trivia patch, not linking a branch since it is very trivial (it is just the output of bzr diff).

Thank you for your attention.
Ciao.

Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → Medium
dobey (dobey) wrote :

Milo, I have just proposed a branch to fix this upstream. We don't want to just change the label to show a different value, because if we again change it later, we then have to deal with updating it on all supported versions. I have instead just removed this label, which avoids breaking the translations, as it is a separate string, at least for Oneiric.

For 11.04, I am not sure what we should do, as it is a stable release, and changing strings there is not fun. Plus I don't think it's that big of an issue, since people are still getting 2GB for free. They just also get 3 more GB on top of that. :)

Lilian A. Moraru (lilianmoraru) wrote :

It's actually a big deal if Canonical/Ubuntu really wants to have more people using this service.

dobey (dobey) on 2011-09-07
Changed in ubuntuone-control-panel (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)

The attachment "Trivia patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in ubuntuone-control-panel (Ubuntu):
milestone: none → ubuntu-11.10
Changed in ubuntuone-control-panel:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 2.0.0-0ubuntu1

---------------
ubuntuone-control-panel (2.0.0-0ubuntu1) oneiric; urgency=low

  * New upstream release:

    [ Alejandro J. Cura <email address hidden>]
      - Do not throw a webclient error when closing
        (LP: #845105).
    [ Natalia B. Bidart <email address hidden> ]
      - Removed all code related to Bookmarks (LP: #850142).
      - Replaces references to "Evolution" by "Thunderbird" (LP: #849494).
    [ Rodney Dawes <email address hidden> ]
      - Don't install a .desktop file for control panel
        (part of LP: #838778).
      - Point the indicator/Unity API at the installer .desktop file
        (part of LP: #838778).
      - Set the WMCLASS so Unity will fall back properly
        (part of LP: #838778).
      - Fix a few grammar mistakes (LP: #835093).
      - Don't show the "Get NGB free!" label on "Join now" button at all
        (LP: #819955).

  * debian/control:
    - ubuntuone-control-panel-gtk depends now on ubuntuone-installer >= 2.0.0.
    - require ubuntuone-client >= 2.0.0.
    - require ubuntu-sso-client >= 1.4.0.
    - no longer install a .desktop file (will be installed by ubuntuone-installer).
 -- Natalia Bidart (nessita) <email address hidden> Mon, 26 Sep 2011 14:55:15 -0300

Changed in ubuntuone-control-panel (Ubuntu Oneiric):
status: Confirmed → Fix Released

Switch "Won't Fix" for Natty? It is not supported any more?

dobey (dobey) wrote :

Lilian, Ubuntu 11.04 is a stable release, and the strings and UI are frozen for it. However, 11.04 is still supported, and you still get the new 5GB for free when you sign up.

Gabor Kelemen (kelemeng) wrote :

Rodney: so you would agree that it won't be fixed in Natty, and it is safe to set the bug status accordingly, just as Lilian asked? Then I'm doing my part towards making this bug disappear from our bug lists :).

Changed in ubuntu-translations:
status: Confirmed → Fix Released
Changed in ubuntuone-control-panel (Ubuntu Natty):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions