Devices tab shows nothing when syncdaemon is not responsive

Bug #726867 reported by Jono Bacon on 2011-02-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
High
Natalia Bidart
ubuntuone-control-panel (Ubuntu)
High
Natalia Bidart

Bug Description

Binary package hint: ubuntuone-control-panel

When I click the Devices tab all I see is "Value could not be retrieved" and no details of the various devices I have synced with Ubuntu One. I know I have synced a series of devices, so I should see them there.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubuntuone-control-panel-gtk 0.9.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Mon Feb 28 15:32:43 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-control-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jono Bacon (jonobacon) wrote :
Natalia Bidart (nataliabidart) wrote :

Hi Jono!

Thanks a lot for your report. This issue is caused by basically by 2 main reasons:

* either the device list can't be retrieved from our servers (either lack of internet connection or bad tokens)
* or syncdaemon is not working properly (bad tokens, file sync disabled in this device, etc)

The first case is reflected in bug #720704. The second one should be fixed as a side effect of fixing it, since we need to decouple the retrieval of devices from the web from the retrieval of throttling limits from syncdaemon.

Anyways, I'm leaving this bug opened (with an updated description) to reflect the problem in the second case.

Cheers!

summary: - Devices tab shows nothing
+ Devices tab shows nothing when syncdaemon is not responsive
Changed in ubuntuone-control-panel:
status: New → Triaged
Changed in ubuntuone-control-panel (Ubuntu):
status: New → Triaged
assignee: nobody → Naty Bidart (nataliabidart)
Changed in ubuntuone-control-panel:
assignee: nobody → Naty Bidart (nataliabidart)
Changed in ubuntuone-control-panel (Ubuntu):
importance: Undecided → High
Changed in ubuntuone-control-panel:
importance: Undecided → High
tags: added: desktop+ u1-natty
Changed in ubuntuone-control-panel:
status: Triaged → In Progress
Changed in ubuntuone-control-panel (Ubuntu):
milestone: none → ubuntu-11.04-beta-2
tags: added: u1-natty-beta
removed: u1-natty
Changed in ubuntuone-control-panel:
status: In Progress → Fix Committed
Changed in ubuntuone-control-panel (Ubuntu):
status: Triaged → In Progress
Jono Bacon (jonobacon) wrote :

What is the current status on this bug? This is still present in Natty.

Natalia Bidart (nataliabidart) wrote :

Hi Jono,

As you can see from the the bug history, a fix has been committed to trunk this week, so you can expect the fix to be present for beta-2.

I'm sorry we couldn't tackle this sooner, but we were focused on killing UI issues to meet the UI freeze date.
Thanks a lot for caring about this!

Cheers, Naty.

Changed in ubuntuone-control-panel:
status: Fix Committed → Fix Released
Changed in ubuntuone-control-panel (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers