ubuntuone-control-panel-qt has no scrollbars on quantal

Bug #1007421 reported by Ken VanDine
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
Status tracked in Trunk
Stable-4-0
Undecided
Unassigned
Trunk
Undecided
Roberto Alsina
overlay-scrollbar
Medium
Unassigned
overlay-scrollbar (Ubuntu)
Undecided
Unassigned
ubuntuone-control-panel (Ubuntu)
Undecided
Ubuntu One Client Engineering team

Bug Description

This is no longer a crasher (at least on quantal). On quantal now with the new overlay scrollbars, there is no scrollbar. I get mouse wheel scrolling but never a scrollbar. In quantal, overlay scrollbars was made into a gtk module. If I disable the module, I get a scrollbar.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: ubuntuone-control-panel-qt 3.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
CrashCounter: 1
Date: Fri Jun 1 09:17:36 2012
ExecutablePath: /usr/bin/ubuntuone-control-panel-qt
ExecutableTimestamp: 1334178472
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110223)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/ubuntuone-control-panel-qt
ProcCwd: /
SegvAnalysis:
 Segfault happened at: 0x7f8ffeb15077 <_ZNK9QGtkStyle18drawComplexControlEN6QStyle14ComplexControlEPK19QStyleOptionComplexP8QPainterPK7QWidget+5239>: mov 0x30(%r15),%r14
 PC (0x7f8ffeb15077) ok
 source "0x30(%r15)" (0x00000030) not located in a known VMA region (needed readable region)!
 destination "%r14" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: ubuntuone-control-panel
StacktraceTop:
 QGtkStyle::drawComplexControl(QStyle::ComplexControl, QStyleOptionComplex const*, QPainter*, QWidget const*) const () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QScrollBar::paintEvent(QPaintEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QWidget::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QScrollBar::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
Title: ubuntuone-control-panel-qt crashed with SIGSEGV in QGtkStyle::drawComplexControl()
UpgradeStatus: Upgraded to precise on 2011-11-18 (196 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare vboxusers

Related branches

Revision history for this message
Ken VanDine (ken-vandine) wrote :
description: updated
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 QGtkStyle::drawComplexControl(QStyle::ComplexControl, QStyleOptionComplex const*, QPainter*, QWidget const*) const () from /tmp/tmpLI0BUp/usr/lib/x86_64-linux-gnu/libQtGui.so.4
 ?? () from /tmp/tmpLI0BUp/usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QScrollBar::paintEvent(QPaintEvent*) () from /tmp/tmpLI0BUp/usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QWidget::event(QEvent*) () from /tmp/tmpLI0BUp/usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QScrollBar::event(QEvent*) () from /tmp/tmpLI0BUp/usr/lib/x86_64-linux-gnu/libQtGui.so.4

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in ubuntuone-control-panel (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
Ken VanDine (ken-vandine) wrote : Re: ubuntuone-control-panel-qt crashed with SIGSEGV in QGtkStyle::drawComplexControl()

This is due to the overlay-scrollbars from the PPA being installed, which is now a gtk module. In quantal it doesn't crash, but I get no scrolling.

visibility: private → public
Changed in ubuntuone-control-panel (Ubuntu):
importance: Medium → Undecided
summary: - ubuntuone-control-panel-qt crashed with SIGSEGV in
- QGtkStyle::drawComplexControl()
+ ubuntuone-control-panel-qt has no scrollbars on quantal
description: updated
Changed in ayatana-scrollbar:
importance: Undecided → Medium
Changed in ayatana-scrollbar:
assignee: nobody → Andrea Cimitan (cimi)
Revision history for this message
Leo Arias (elopio) wrote :

I can scroll but I don't see the bars.

Changed in ubuntuone-control-panel (Ubuntu):
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
status: New → Confirmed
tags: added: desktop+
Changed in ubuntuone-control-panel:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
status: New → Confirmed
Revision history for this message
dobey (dobey) wrote :

Leo, I don't think there is anything we can do for this specifically, in the control panel. It seems to almost certainly be an issue in the theme or scrollbar code for the overlay scrollbars.

Revision history for this message
Leo Arias (elopio) wrote :

Ok, I just thought it was weird that it only happens on Ubuntu One. All the other scrolls work without issues.

Changed in ayatana-scrollbar:
status: New → Confirmed
Revision history for this message
Roberto Alsina (ralsina) wrote :

After talking with Andrea, I will do a workaround.

Changed in ubuntuone-control-panel:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Roberto Alsina (ralsina)
status: Confirmed → In Progress
Changed in ubuntuone-control-panel:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in overlay-scrollbar (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 3.99.3-0ubuntu2

---------------
ubuntuone-control-panel (3.99.3-0ubuntu2) quantal; urgency=low

  * 00_scrolled_workaround.patch:
    - Avoid loading the scrollbar GTK+ module. (LP: #1007421)
 -- Rodney Dawes <email address hidden> Fri, 03 Aug 2012 11:39:01 -0400

Changed in ubuntuone-control-panel (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Barry Drake (b-drake) wrote :

Confirming - the latest update works OK for me. Thanks.

Andrea Cimitan (cimi)
Changed in overlay-scrollbar:
assignee: Andrea Cimitan (cimi) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers