should not use /usr/bin/env python shebang

Bug #984089 reported by Zygmunt Krynicki on 2012-04-17
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-4-0
Undecided
dobey
Trunk
Undecided
dobey
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-4-0
Undecided
dobey
Trunk
Undecided
Unassigned
ubuntuone-dev-tools
Status tracked in Trunk
Stable-4-0
Undecided
dobey
Trunk
Undecided
dobey
ubuntu-sso-client (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
ubuntuone-client (Ubuntu)
Undecided
Ubuntu One Client Engineering team
Quantal
Undecided
Ubuntu One Client Engineering team
ubuntuone-dev-tools (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

This makes scripts break when invoked from python virtualenv.
IIRC Packaged python programs must use /usr/bin/python per debian policy.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubuntuone-client 3.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu3
Architecture: amd64
Date: Tue Apr 17 17:50:09 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120218)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Zygmunt Krynicki (zyga) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
dobey (dobey) on 2012-04-25
summary: - u1sdtool should not use /usr/bin/env python shebang
+ should not use /usr/bin/env python shebang
description: updated
Rick McBride (rmcbride) on 2012-05-07
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
dobey (dobey) on 2012-06-05
Changed in ubuntuone-dev-tools (Ubuntu Quantal):
status: New → Triaged
Changed in ubuntu-sso-client:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-dev-tools - 3.99.1-0ubuntu1

---------------
ubuntuone-dev-tools (3.99.1-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Avoid using /usr/bin/env python in scripts. (LP: #984089)
    - Deafult to more appropriate reactor on OS X and Windows.
    - Fix clean-up of UNIX domain sockets on OS X.
 -- Rodney Dawes <email address hidden> Tue, 26 Jun 2012 17:19:57 -0400

Changed in ubuntuone-dev-tools (Ubuntu Quantal):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-sso-client (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 3.99.2-0ubuntu1

---------------
ubuntu-sso-client (3.99.2-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Avoid using /usr/bin/env python in scripts. (LP: #984089)
    - Avoid using xrange, which is not in Python 3. (LP: #1016774)
    - Handle winreg vs. _winreg for Python 2 and 3. (LP: #1016957)
    - Remove the GTK+ UI. (LP: #1017690)
    - Handle urllib differences between Python 2 and 3. (LP: #1018587)
    - Use io.StringIO everywhere, for Python 2 and 3. (LP: #1018599)
    - Use new print syntax for Python 3. (LP: #1018611)
  * debian/control:
    - Remove the -gtk UI package, and update the deps.
  * debian/ubuntu-sso-client-gtk.install:
    - Removed.
 -- Rodney Dawes <email address hidden> Fri, 20 Jul 2012 12:49:23 -0400

Changed in ubuntu-sso-client (Ubuntu Quantal):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 3.99.2-0ubuntu1

---------------
ubuntuone-client (3.99.2-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Avoid using /usr/bin/env python in scripts. (LP: #984089)
    - Avoid auto-installing a reactor on some imports.
  * debian/rules:
    - Ensure locale is en_US.UTF-8 for running tests.
 -- Rodney Dawes <email address hidden> Fri, 20 Jul 2012 17:27:33 -0400

Changed in ubuntuone-client (Ubuntu Quantal):
status: Confirmed → Fix Released
tags: added: u1-support-escalated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers