File moved to file.odt.u1conflict.# every time I save it

Bug #881266 reported by joehill on 2011-10-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntuone-client (Ubuntu)
Undecided
Unassigned

Bug Description

I'm working on an odt file in LibreOffice and, after suspending my computer last night and resuming this morning, every time I tried to save it I would get a message from LibreOffice saying "The file has been changed since it was opened for editing in LibreOffice" etc. I closed the file and tried to reopen and discovered the file no longer existed. I looked in Thunar (using XFCE now) and found that indeed the file didn't exist, but there was a series of files named filename.odt.u1conflict and then the same name with .1, .2, up to .5 appended. If I remove this extension, it immediately reverts back, so it's impossible to have a file just called filename.odt.

I just killed ubuntuone-syncdaemon and restarted with ubuntuone-launch, and filename.odt reappeared, with a modified time of the moment I restarted ubuntuone.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubuntuone-client 2.0.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-13.21-generic 3.0.6
Uname: Linux 3.0.0-13-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Tue Oct 25 08:49:13 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (10 days ago)

joehill (joseph-hill) wrote :
joehill (joseph-hill) wrote :

And I should mention that the version that appeared as the base filename, unsurprisingly, was the one I saved last night before suspending, not the one I modified this morning, so I had to delete the one Ubuntu One had downloaded to my computer under that name and replaced it with ....5.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers