gnome-settings-daemon crashed with SIGSEGV in g_str_hash()

Bug #744383 reported by Humberto Hassey on 2011-03-28
62
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-4
High
dobey
Trunk
High
dobey
ubuntuone-client (Ubuntu)
High
dobey
Maverick
High
dobey
Natty
High
dobey

Bug Description

Binary package hint: gnome-settings-daemon

Mar 28 09:50:00 ProBook kernel: [ 74.242101] show_signal_msg: 39 callbacks suppressed
Mar 28 09:50:00 ProBook kernel: [ 74.242106] gnome-settings-[1965]: segfault at 0 ip 0058c6f7 sp bf8c52d4 error 4 in libglib-2.0.so.0.2600.1[52b000+cd000]

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gnome-settings-daemon 2.32.0-0ubuntu3.1
ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
Architecture: i386
Date: Mon Mar 28 09:50:00 2011
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANG=es_MX.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x58c6f7 <g_str_hash+7>: movsbl (%edx),%eax
 PC (0x0058c6f7) ok
 source "(%edx)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 g_str_hash () from /lib/libglib-2.0.so.0
 g_hash_table_lookup () from /lib/libglib-2.0.so.0
 ?? () from /usr/lib/gnome-settings-daemon-2.0/libubuntuone.so
 g_cclosure_marshal_VOID__POINTER () from /usr/lib/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
Title: gnome-settings-daemon crashed with SIGSEGV in g_str_hash()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare users

----

TEST CASE:
Requires a computer setup with an Ubuntu One account

1. Add enough files to go over your Ubuntu One account quota

Expected result: Message about being over quota displayed once and no gnome-settings-daemon crash

Related branches

Humberto Hassey (hhasseyf) wrote :

StacktraceTop:
 g_str_hash (v=0x0) at /build/buildd/glib2.0-2.26.1/glib/gstring.c:134
 g_hash_table_lookup (hash_table=0x95a44c0, key=0x0)
 quota_exceeded_callback (daemon=0x95bb7b0,
 g_cclosure_marshal_VOID__POINTER (closure=0x967beb8,
 g_closure_invoke (closure=0x967beb8, return_value=0x0,

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Sebastien Bacher (seb128) wrote :

it's crashing is gsd-ubuntu.c

visibility: private → public
affects: gnome-settings-daemon (Ubuntu) → ubuntuone-client (Ubuntu)
Roman Yepishev (rye) on 2011-03-28
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Roman Yepishev (rye)
assignee: Roman Yepishev (rye) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
importance: Medium → High
David Ayers (ayers) wrote :

I'm currently experiencing this issue also.

It happens reliably when my UbuntuOne storage and music folders trip together the UbuntuOne quota.

I find it strange that the ubuntuone-client can cause gnome-settings-daemon to crash. I would imagine that gnome-settings-daemon should be fixed in a way that other processes cannot crash it. But I haven't looked at the integration to be sure.

Please let me know if you need further information.

tags: added: u1-maverick-sru
tags: added: support
Changed in ubuntuone-client:
status: New → Confirmed
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
Changed in ubuntuone-client (Ubuntu):
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodney Dawes (dobey)
dobey (dobey) wrote :

Not quite sure why this is breaking exactly yet, but I am working on it and will have a fix uploaded in the next day or so.

David Ayers (ayers) wrote :

Thanks for the feedback and for looking into it, Rodney!
Can you reproduce the crash?
If not I can try to setup a VM to see if I can reproduce it there.

David Ayers (ayers) wrote :

I have extended my Ubuntuone subscription by 20 GB but the crash still happens. So this seems unrelated to tripping the quota.

Please also see bug #554280 which I believe this to be a duplicate of.

dobey (dobey) on 2011-04-05
Changed in ubuntuone-client (Ubuntu Maverick):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
status: New → In Progress
Changed in ubuntuone-client (Ubuntu Natty):
status: Confirmed → In Progress
David Ayers (ayers) wrote :

Currently the crash doesn't happen anymore. Not sure if something needed to propagate. I'm currently having issue with file syncing (probably due to my ISP) so I can't easily test if tripping the new quota makes the issue reappear.

David Ayers (ayers) wrote :

I retract the part of comment #9 that suggests this may be a duplicate of bug #554280 ... it just happens that the crash happens at the same place.

Changed in ubuntuone-client (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-2
tags: added: u1-natty-beta
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.6.0-0ubuntu1

---------------
ubuntuone-client (1.6.0-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Avoid conflict when same file already exists locally (LP: #711389)
    - Must move fils to trash on deletion (LP: #690673)
    - Support disconnection during initial connect attempt (LP: #711211)
    - Log version number on startup (LP: #715455)
    - Memory usage too high (LP: #721483)
    - Unsubscribed folders show as synced, if they exist (LP: #741835)
    - gnome-settings-daemon crash in g_str_hash (LP: #744383)
    - Should not re-queue uploads directly (LP: #744608)
    - No feedback when creating folder from symlink fails (LP: #747299)
    - [FFE] Use API to set urgency from background process (LP: #747677)
    - Open control panel to volumes when quota exceeded (LP: #702176)
    - Set the launcher to urgent when quota exceeded (LP: #702183)
    - nautilus crash in g_str_hash (LP: #724882)
    - Disable/enable file sync is buggy (LP: #744980)

  [Chris Coulson]
  * gnome-settings-daemon crash in g_return_fail_if_warning (LP: #744980)
 -- Rodney Dawes <email address hidden> Sun, 10 Apr 2011 21:24:30 -0400

Changed in ubuntuone-client (Ubuntu Natty):
status: In Progress → Fix Released

Accepted ubuntuone-client into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
description: updated
Joshua Hoover (joshuahoover) wrote :

Test case passed using proposed update ubuntuone-client 1.4.6-0ubuntu3

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.4.6-0ubuntu3

---------------
ubuntuone-client (1.4.6-0ubuntu3) maverick-proposed; urgency=low

  * 02_gsd-plugin-fixes.patch:
    - Fix crash looking up NULL string in hash table (LP: #744383)
    - Chain the dispose event up properly [Chris Coulson] (LP: #629306)
 -- Rodney Dawes <email address hidden> Tue, 05 Apr 2011 17:54:37 -0400

Changed in ubuntuone-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers