Old crashdb.conf.d entries with bug_pattern_base (even if it is None) cause crash in apport.

Bug #731526 reported by Roman Yepishev
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Invalid
Undecided
Unassigned
Apport
High
Martin Pitt
Indicator Applet
Invalid
Undecided
Unassigned
apport (Ubuntu)
High
Martin Pitt
Natty
High
Martin Pitt
ubuntuone-client (Ubuntu)
Low
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: apport

Right now ubuntuone-client in natty suffers from a broken unity library.
Upon adding the bugpattern to the bugpatterns.xml and testing it with test-local with positive results I found that apport reporting tool started to crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: apport-gtk 1.19-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CrashReports:
 600:1000:1000:68754:2011-03-08 20:45:36.604509000 +0200:2011-03-08 20:45:37.604509000 +0200:/var/crash/_usr_lib_ubuntuone-client_ubuntuone-syncdaemon.1000.crash
 600:1000:1000:48421:2011-03-08 20:45:36.684509000 +0200:2011-03-08 20:45:41.654509001 +0200:/var/crash/_usr_share_apport_apport-gtk.1000.crash
Date: Tue Mar 8 20:45:37 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with KeyError in get_crashdb(): 'bug_pattern_url'
UpgradeStatus: Upgraded to natty on 2010-12-05 (93 days ago)
UserGroups: adm admin audio cdrom dialout libvirtd lpadmin mythtv plugdev sambashare

Revision history for this message
Roman Yepishev (rye) wrote :
Revision history for this message
Apport retracing service (apport) wrote : This bug is a duplicate

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #625259, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
visibility: private → public
Revision history for this message
Roman Yepishev (rye) wrote : Re: apport-gtk crashed with KeyError in get_crashdb(): 'bug_pattern_url' for ubuntuone bugpattern

Removing the duplicate status since it looks like a recent move to a single bugpatterns.xml could have caused it.
Investigating...

Revision history for this message
Roman Yepishev (rye) wrote :

Hm, at some point in time db becomes
name = ubuntuone
db = {'project': 'ubuntuone-client', 'impl': 'launchpad', 'bug_pattern_base': None}

Revision history for this message
Roman Yepishev (rye) wrote :

Ok, it turns out here's what gets bundled with ubuntuone:
ubuntuone = {
        'impl' : 'launchpad',
        'project' : 'ubuntuone-client',
        'bug_pattern_base' : None,
}

in ubuntuone-client-crashdb.conf

Since we are using bug_pattern_base, we break apport reporting. Reassigning to myself.

affects: apport (Ubuntu) → ubuntuone-client (Ubuntu)
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Roman Yepishev (rye)
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Roman Yepishev (rye) wrote :

As far as I see this will also affect bug patterns for indicator-applet and indicator-appmenu since they also provide /etc/crashdb.conf.d/ entries.

summary: - apport-gtk crashed with KeyError in get_crashdb(): 'bug_pattern_url' for
- ubuntuone bugpattern
+ Old crashdb.conf.d entries with bug_pattern_base (even if it is None)
+ cause crash in apport.
Revision history for this message
Roman Yepishev (rye) wrote :

On a second thought this looks like a bug in apport that changing crashdb.conf.d entries won't be able to fix. It looks like conf.d entries will need to provide bug_pattern_urls which should not be required in case main bugpatterns.xml is used.

Changed in ubuntuone-client (Ubuntu):
status: Confirmed → New
Changed in apport:
status: New → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Indeed. I'm going to fix apport so that it (1) doesn't crash on an absent 'bug_pattern_url' (and just doesn't use bug patterns in that case), and (2) falls back to the default bug pattern URL for custom crashdb.conf.d/ files.

I keep the indicator-applet and ubuntuone-client tasks open for removing the now obsolete bug_pattern_base entry from their configuration, but that's now low priority.

Changed in apport:
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
Changed in apport (Ubuntu Natty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Martin Pitt (pitti)
milestone: none → ubuntu-11.04-beta-1
Changed in ubuntuone-client (Ubuntu Natty):
status: New → Won't Fix
Changed in ubuntuone-client (Ubuntu):
status: New → Triaged
importance: High → Low
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in apport trunk in r1866 and r1867.

Changed in apport:
status: In Progress → Fix Released
Changed in apport (Ubuntu Natty):
status: In Progress → Fix Committed
Changed in ubuntuone-client (Ubuntu Natty):
importance: High → Undecided
assignee: Roman Yepishev (rye) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.19-0ubuntu3

---------------
apport (1.19-0ubuntu3) natty; urgency=low

  * Merge fixes from trunk:
    - apport-retrace: Intercept SystemErrors from ill-formed gzip attachments
      as well.
    - Fix crash if crash database configuration does not specify a
      bug_pattern_url. Just assume None. (LP: #731526)
    - If a custom crash database does not specify a bug_pattern_url, fall back
      to using the default database's. (LP: #731526)
 -- Martin Pitt <email address hidden> Wed, 09 Mar 2011 19:21:16 +0100

Changed in apport (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in indicator-applet:
status: New → Invalid
Changed in indicator-appmenu:
status: New → Invalid
Roman Yepishev (rye)
Changed in ubuntuone-client (Ubuntu):
assignee: Roman Yepishev (rye) → nobody
Changed in ubuntuone-client (Ubuntu):
status: Triaged → Incomplete
status: Incomplete → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers