Ubuntu

Ubuntuone-client software wont start even after fresh install of the software packages.

Reported by RedSingularity on 2010-10-26
62
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
Ubuntu One Foundations+ team
desktopcouch
Undecided
Unassigned
ubuntuone-client (Ubuntu)
Medium
Ubuntu One Foundations+ team

Bug Description

Binary package hint: ubuntuone-client

After fully uninstalling and removing all of ubuntuone files and folders from my system and doing a fresh install of the software, it seems there is an error.

To reproduce:
----------------------------------------
1) sudo apt-get autoremove ubuntuone-client
2) sudo apt-get autoremove ubuntuone-client-tools
Now look for any residual files......
3) sudo find / -name ubuntuone
Remove any files that the previous command turned up.....
4) Run the same command again and it should turn up NO results at all. (If it does, keep deleting the files it brings up until the find command turns up nothing.)
5) sudo apt-get install ubuntuone-client ubuntuone-client-tools ubuntuone-client-gnome python-ubuntuone
6) Run ubuntuone-preferences in a terminal
7) Output is the following:
-------------------------------------
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-preferences", line 1143, in <module>
    prefs_dialog = UbuntuOneDialog()
  File "/usr/bin/ubuntuone-preferences", line 535, in __init__
    self.__construct()
  File "/usr/bin/ubuntuone-preferences", line 975, in __construct
    self.devices.list_devices()
  File "/usr/bin/ubuntuone-preferences", line 379, in list_devices
    fsync_enabled = self.sdtool.is_files_sync_enabled()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/tools.py", line 708, in is_files_sync_enabled
    return get_user_config().get_files_sync_enabled()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/config.py", line 148, in wrapped
    return meth(self, *args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/config.py", line 321, in get_files_sync_enabled
    return self.get_parsed(MAIN, 'files_sync_enabled')
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/config.py", line 266, in get_parsed
    return self.default.get(section, option).value
  File "/usr/lib/python2.6/ConfigParser.py", line 311, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: '__main__'

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ubuntuone-client 1.2.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Oct 25 23:43:08 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client

-------------------------------------------------------------------

Copied from /etc/xdg/ubuntuone/ to ~/.config/ubuntuone/ the files syncdaemon.conf and logging.conf.

syncdaemon contains a __main__ section and is about 3.6KB.

Next I executed /usr/bin/ubuntuone-preferences whilst watching the ~/.config/ubuntuone/ directory.

The dialog successfully opens and show my Ubuntu One account details.

I noticed that the syncdaemon.conf file had changed length to 78 bytes.

Checking I see that the __main__ section is missing.

I investigated the source code in /usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/config.py

This code seems to be responsible for deleting the section before re-writing the configuration file:

    def save(self):
        """Save the config object to disk"""
        # cleanup empty sections
        for section in [MAIN, THROTTLING]:
            if self.has_section(section) and not self.options(section):
                self.remove_section(section)
        with open(self.config_file+'.new', 'w') as fp:
            self.write(fp)

I'm not clear on how the self.options("__main__") test is supposed to work here but it seems to be cause of the issue.

RedSingularity (redsingularity) wrote :
summary: - Ubuntuone-client software wont start
+ Ubuntuone-client software wont start even after fresh install of the
+ software.
summary: Ubuntuone-client software wont start even after fresh install of the
- software.
+ software packages.
Duane Hinnen (duanedesign) wrote :

RedSingularity,
looks like some package is missing. Could you please try the following command in a Terminal and let me know the result.

sudo apt-get install ubuntuone-client python-ubuntuone-storage*

Since you removed Ubuntu One and are reinstalling it you will need to ensure that you delete your old Ubuntu One Token in order for the 'fresh' install to prompt you to add your computer. You can find and delete the token by opening Applications->Accessories->Passwords and Encryption Keys, go to the Passwords tab, right-click and delete the Ubuntu One token.

thank you,
duanedesign

RedSingularity (redsingularity) wrote :

Looks like those packages are installed already,

tim@Alpha:~$ sudo apt-get install ubuntuone-client python-ubuntuone-storage*
[sudo] password for tim:
Reading package lists... Done
Building dependency tree
Reading state information... Done
ubuntuone-client is already the newest version.
Note, selecting python-ubuntuone-storageprotocol for regex 'python-ubuntuone-storage*'
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

As for the token, I removed it and still no dice. I get the same error thats in the description.

Duane Hinnen (duanedesign) wrote :

Looks as though one of your config files might be missing. Can you see if you have this file:

~/.config/ubuntuone/syncdaemon.conf

It should look something like this:

[bandwidth_throttling]
read_limit = 2097152
write_limit = 2097152
on = False

[__main__]
files_sync_enabled = True

thank you,
duanedesign

RedSingularity (redsingularity) wrote :

I am closing this as the problem has been resolved. Thanks for taking the time to help though :)

Changed in ubuntuone-client (Ubuntu):
status: New → Invalid
Richard Rath (rcrath) wrote :

I am having this exact same error. Tried uninstalling, removing config folders, removing password key, and reinstalling and rebooting. continue to have the problem. Ubuntu one was working, but now does not. I am also having problems with desktop couch not starting, which is what I think is at the root of the problem.

Changed in ubuntuone-client (Ubuntu):
status: Invalid → Incomplete
Anonymousdog (anonymousdog) wrote :

Have same issue on Mythbuntu 10.04 upgraded from 8.04. If I create the ~/.config/ubuntuone/syncdaemon.conf file as in comment #4, ubuntuone-preferences will launch one time (still throwing all the errors in the original report except for the "ConfigParser.NoSectionError: No section: '__main__'". All status fields are empty, and service check boxes may or may not reflect that file sync is enabled...that's totally random. When the prefs app is closed, it deletes the '__main__' section from the syncdaemon.conf file; so, the prefs app won't relaunch until the syncdaemon.conf file is rebuilt. There's quite a bit broken with this functionality in Mythbuntu.

StalkerVik (stalkervik) wrote :

I am having this exact same error.

RedSingularity (redsingularity) wrote :

If you all run:

ubuntuone-preferences

do you get a bunch of error output like in the bug description?

Richard Rath (rcrath) wrote :

No, ubuntu-preferences runs with no errors, it shows the account properly, but won't connect, and no devices show up. I am pretty sure my problem lies with desktop couch but have not been able to get any input from them, and except for the terminal output, the symptoms are the same (purge programs, delete pgp key, reinstall...nothing) so I thought maybe whatever you did to resolve this might work for me too.

Philippe (philippe-rast) wrote :

Hi even though ubuntu-one is in the startup applications it won't connect to the u1 server. Never.
At every startup I need to initiate the connection myself. Here's what I enter:

philippe@ILR-B328a:~$ u1sdtool -c
Oops, an error ocurred:
Traceback (most recent call last):
Failure: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
philippe@ILR-B328a:~$ u1sdtool --stat
State: LOCAL_RESCAN
    connection: Not User Not Network
    description: doing local rescan
    is_connected: False
    is_error: False
    is_online: False
    queues: WORKING_ON_METADATA

philippe@ILR-B328a:~$ u1sdtool --stat
State: READY
    connection: Not User With Network
    description: ready to connect
    is_connected: False
    is_error: False
    is_online: False
    queues: WORKING_ON_METADATA

philippe@ILR-B328a:~$ u1sdtool -c
philippe@ILR-B328a:~$ u1sdtool --stat
State: QUEUE_MANAGER
    connection: With User With Network
    description: processing queues
    is_connected: True
    is_error: False
    is_online: True
    queues: IDLE

This happens on my ubuntu 10.10 64bit pc and on my ubuntu 10.10 32bit notebook at two different locations. One in the university net and the other at home.
Sometimes the above mentioned approach won't work and I need to killall u1 associated processes and restart the whole procedure.

Apparently I have all components to connect to the server but it just won't start by its own. Silly.

Philippe (philippe-rast) wrote :

btw, I tried all the solutions with removing the keys from seahorse and detaching the pc from the u1 server and reconnecting from scratch. On both pc and notebook - I still get this Ooops error.

Rodney Dawes (dobey) wrote :

Philippe, it looks like you are having a different issue. Please file a new separate bug for it.

Changed in desktopcouch:
status: New → Invalid
TJ (tj) wrote :

I'm observing the same issue on 10.04 mythbuntu installation, with the same traceback.

The file doesn't exist ~/.config/ubuntuone/syncdaemon.conf

I've only just come to try using Ubuntu One with Rhythmbox on the affected PC. I've never been able to run the preferences application.

Rhythmbox synced to Ubuntu One storage one time and successfully pulled in the music files. I bought more tracks but have not been able to sync them to the mythbuntu PC.

$ dpkg-query -l '*ubuntuone*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=====================-=====================-==========================================================
ii libubuntuone-1.0-1 0.3.1-0ubuntu1 Ubuntu One widget library
un nautilus-ubuntuone <none> (no description available)
ii python-ubuntuone 0.3.1-0ubuntu1 Ubuntu One widget library
ii python-ubuntuone-clie 1.2.2-0ubuntu2 Ubuntu One client Python libraries
ii python-ubuntuone-stor 1.2.0-0ubuntu1 Python library for Ubuntu One file storage and sharing ser
un python2.6-ubuntuone <none> (no description available)
un python2.6-ubuntuone-c <none> (no description available)
un python2.6-ubuntuone-s <none> (no description available)
ii rhythmbox-ubuntuone-m 0.0.9-0ubuntu1 Ubuntu One Music Store Rhythmbox plugin
ii ubuntuone-client 1.2.2-0ubuntu2 Ubuntu One client
ii ubuntuone-client-gnom 1.2.2-0ubuntu2 Ubuntu One client GNOME integration
un ubuntuone-oauth-login <none> (no description available)
un ubuntuone-storage-pro <none> (no description available)
un ubuntuone-storagefs <none> (no description available)

TJ (tj) on 2011-02-03
Changed in ubuntuone-client:
status: New → Confirmed
TJ (tj) wrote :

I'm not up to speed with the code as yet but I've found the crux of the issue.

Firstly, I copied from /etc/xdg/ubuntuone/ to ~/.config/ubuntuone/ the files syncdaemon.conf and logging.conf.

syncdaemon contains a __main__ section and is about 3.6KB.

Next I executed /usr/bin/ubuntuone-preferences whilst watching the ~/.config/ubuntuone/ directory.

The dialog successfully opens and show my Ubuntu One account details.

I noticed that the syncdaemon.conf file had changed length to 78 bytes.

Checking I see that the __main__ section is missing.

I investigated the source code in /usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/config.py

This code seems to be responsible for deleting the section before re-writing the configuration file:

    def save(self):
        """Save the config object to disk"""
        # cleanup empty sections
        for section in [MAIN, THROTTLING]:
            if self.has_section(section) and not self.options(section):
                self.remove_section(section)
        with open(self.config_file+'.new', 'w') as fp:
            self.write(fp)

I'm not clear on how the self.options("__main__") test is supposed to work here but it seems to be cause of the issue.

TJ (tj) wrote :

I've confirmed that commenting out the suspect lines, and then restarting the ubuntuone syncdaemon (or log-out then log-in since it auto-starts on log-in) provides a work-around for the issue/

I edited the /usr/share/pyshared/ubuntuone/syncdaemon/config.py file using a text editor to have:

        # cleanup empty sections
        #for section in [MAIN, THROTTLING]:
        # if self.has_section(section) and not self.options(section):
        # self.remove_section(section)

saved the file and restarted the syncdaemon.

Since then, running ubuntuone-preferences doesn't cause the syncdaemon.conf file to lose the __main__ section, and syncing works again in the background for my account files.

Changed in ubuntuone-client (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
tags: added: foundations+
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Ubuntu One Foundations+ team (ubuntuone-foundations+)
description: updated
Changed in ubuntuone-client:
importance: Undecided → High
assignee: nobody → Ubuntu One Foundations+ team (ubuntuone-foundations+)
tags: added: support
deivid (deivid-rodriguez) wrote :

TJ's workaround fixes the problem for me! Great job!

tags: added: u1-support
removed: support
Changed in ubuntuone-client:
importance: High → Medium
Changed in ubuntuone-client (Ubuntu):
importance: High → Medium
tags: removed: u1-support
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers