Ubuntu One Preferences applet doesn't display info properly

Bug #657850 reported by Kevin Robles on 2010-10-10
120
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-4
High
dobey
Trunk
Medium
dobey
ubuntuone-client (Ubuntu)
High
dobey
Maverick
High
dobey
Natty
High
dobey

Bug Description

Binary package hint: ubuntuone-client

I can sync files to Ubuntu One. I ran a script given to me by rye, from #ubuntuone channel which added an applet to my desktop that can show me how much is left of space. However, the U1 preferences window doesn't display any data appropriately, such as how much space I have left. Not even my email, name, or current plan. Under Devices it lists my machine as <LOCAL MACHINE> but that's it. And it also took me forever just to get it so sync properly through the preferences. At least it connects and syncs, or it says it does. But it doesn't show any other info.

screenshot: http://i51.tinypic.com/15hlnqh.png
script is attached.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: ubuntuone-client-gnome 1.4.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Sun Oct 10 14:47:08 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client
UbuntuOneSyncdaemonExceptionsLog:

UbuntuOneUserSyncdaemonConfig:
 [bandwidth_throttling]
 read_limit = 2097152
 write_limit = 2097152
 on = False

TEST CASE:
Install maverick-proposed client packages
Associate with existing account (or create new one)
Verify that client has connected and correct information is displayed. Note that this may take a brief period of time to populate the preferences UI as network communication must take place before this data is locally available.

Related branches

Kevin Robles (cc-stryker) wrote :
Roman Yepishev (rye) wrote :

Reproducible with
ubuntuone-client-gnome:
  Installed: 1.4.4.1-0ubuntu1
  Candidate: 1.4.4.1-0ubuntu1

If management db of couchdb does not contain pairing record for Ubuntu One, ubuntuone-preferences prints
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/bin/ubuntuone-preferences", line 1051, in got_newcredentials
    self.present()
  File "/usr/bin/ubuntuone-preferences", line 1031, in present
    self.dialog.connect_desktopcouch_exclusion()
  File "/usr/bin/ubuntuone-preferences", line 708, in connect_desktopcouch_exclusion
    self.dcouch = dcouch.ReplicationExclusion()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/replication_services/ubuntuone.py", line 134, in __init__
    raise ValueError("No pairing record for ubuntuone.")
ValueError: No pairing record for ubuntuone.

And can be recovered from this state ( http://ubuntuone.com/p/JeY/ ) only by triggering CredentialsFound signal by another application.

Roman Yepishev (rye) on 2010-10-11
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
status: New → Opinion
importance: Undecided → High
status: Opinion → Confirmed
Roman Yepishev (rye) wrote :

This issue can be fixed by running the following command from the terminal while ubuntuone-preferences window is open (all in one line, quotes should be included):

dbus-send --print-reply --dest=com.ubuntu.sso /credentials com.ubuntu.sso.ApplicationCredentials.login_to_get_credentials "string:Ubuntu One" "string:Workaround for LP:657850" int64:0

Roman Yepishev (rye) wrote :

dbus-send --print-reply \
                    --dest=com.ubuntu.sso \
                    /credentials \
                    com.ubuntu.sso.ApplicationCredentials.login_to_get_credentials \
                    "string:Ubuntu One" "string:Workaround for LP:657850" int64:0

Roman Yepishev (rye) on 2010-10-11
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Kevin Robles (cc-stryker) wrote :

kevin@kevin-laptop:~$ dbus-send --print-reply --dest=com.ubuntu.sso /credentials com.ubuntu.sso.ApplicationCredentials.login_to_get_credentials "string:Ubuntu One" "string:Workaround for LP:657850" int64:0
method return sender=:1.91 -> dest=:1.121 reply_serial=2
kevin@kevin-laptop:~$

It works! Now it displays all of the information properly. Thank you!

Thomas Martinez (djt49507) wrote :

I tried this and it still isn't showing the info correctly and there is no movement on the sync progress bar. It also says "unknown".

Kevin C. (kedoc) wrote :

I have the same problem. But I also tried this quick fix and it does not work for me either.

When I try this command in a terminal :
kedoc@compaq-laptop:~$ dbus-send --print-reply --dest=com.ubuntu.sso /credentials com.ubuntu.sso.ApplicationCredentials.login_to_get_credentials "string:Ubuntu One" "string:Workaround for LP:657850" int64:0
method return sender=:1.123 -> dest=:1.188 reply_serial=2

The terminal where ubuntuone-preferences was launched printed :
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/bin/ubuntuone-preferences", line 1051, in got_newcredentials
    self.present()
  File "/usr/bin/ubuntuone-preferences", line 1031, in present
    self.dialog.connect_desktopcouch_exclusion()
  File "/usr/bin/ubuntuone-preferences", line 708, in connect_desktopcouch_exclusion
    self.dcouch = dcouch.ReplicationExclusion()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/replication_services/ubuntuone.py", line 124, in __init__
    ctx=ctx)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server.py", line 56, in __init__
    server_class=server_class, oauth_tokens=oauth_tokens, ctx=ctx)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 155, in __init__
    self._reconnect()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server.py", line 64, in _reconnect
    super(CouchDatabase, self)._reconnect(uri=uri)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 187, in _reconnect
    if self._database_name not in self._server:
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 124, in __contains__
    self.resource.head(validate_dbname(name))
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 981, in head
    return self._request('HEAD', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1035, in _request
    raise ServerError((status_code, error))
ServerError: (500, '')

Kevin C. (kedoc) wrote :

It seems that my files are no longer synchronized. Maybe the problem is a bit more complicated.

I tried this tutorial : https://wiki.ubuntu.com/UbuntuOne/FAQ/HowDoICompletelyRemoveAndReinstallUbuntuOne
But it did not change anything...

Jesper R (jre) wrote :

I have also tried the proposed fix.

When running the ubuntuone-preferences afterwards I however get a slightly different error message:

ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/bin/ubuntuone-preferences", line 1051, in got_newcredentials
    self.present()
  File "/usr/bin/ubuntuone-preferences", line 1031, in present
    self.dialog.connect_desktopcouch_exclusion()
  File "/usr/bin/ubuntuone-preferences", line 708, in connect_desktopcouch_exclusion
    self.dcouch = dcouch.ReplicationExclusion()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/replication_services/ubuntuone.py", line 134, in __init__
    raise ValueError("No pairing record for ubuntuone.")
ValueError: No pairing record for ubuntuone.

Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Manuel de la Pena (mandel)
status: New → Confirmed
importance: Undecided → High
Kevin C. (kedoc) wrote :

My bad, I correct what I said yesterday : my files are still synchronizing.

As far as I can see on https://one.ubuntu.com/account/machines/, I also notice that the client has created several registration for this same computer with different hash values.

Changed in ubuntuone-client (Ubuntu Maverick):
status: New → Confirmed
importance: Undecided → High
dobey (dobey) on 2011-01-07
Changed in ubuntuone-client (Ubuntu Natty):
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodney Dawes (dobey)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.5.2-0ubuntu1

---------------
ubuntuone-client (1.5.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - ImportError: No module named tools (LP: #692566)
    - Preferences doesn't display info properly (LP: #657850)
    - Ubuntu One crashes in scan() (LP: #692496)A
    - Provide a specific login D-Bus service (LP: #697211)
 -- Rodney Dawes <email address hidden> Fri, 07 Jan 2011 10:36:49 -0500

Changed in ubuntuone-client (Ubuntu Natty):
status: In Progress → Fix Released
dobey (dobey) on 2011-02-18
Changed in ubuntuone-client (Ubuntu Maverick):
assignee: nobody → Rodney Dawes (dobey)
milestone: none → maverick-updates
status: Confirmed → In Progress

Accepted ubuntuone-client into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
Rick McBride (rmcbride) wrote :

Verified according to TEST CASE: in description.

UI presents information as designed now.

description: updated
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.4.6-0ubuntu2

---------------
ubuntuone-client (1.4.6-0ubuntu2) maverick-proposed; urgency=low

  * 01-get-published-race.path:
    - Fix a race condition with requesting published files (LP: #661292)

ubuntuone-client (1.4.6-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - SD deletes files when local error on partial creation (LP: #657195)
    - Partials fail to be created with "filename too long" (LP: #662660)
    - New shares to me are not downloaded (LP: #664019)
    - Deleting UDF on one computer does not delete elsewhere (LP: #674092)
    - Preferences does not display info properly (LP: #657850)
    - "Out of Space" dialog is broken (LP: #650671)
    - Nautilus allows publishing files in others' shares (LP: #712674)
    - SSO help text does not appear translated (LP: #686647)
    - Nautilus is not aware of published files (LP: #661292)
    - Ubuntu One crashes in scan() (LP: #692496)
    - Volume info with None for free space causes QuotaExceeded (LP: #671023)
    - Settings daemon extension should not request credentials (LP: #702171)
 -- Rodney Dawes <email address hidden> Fri, 04 Mar 2011 12:10:05 -0500

Changed in ubuntuone-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions