UbuntuOne "out of space" dialog is broken

Bug #650671 reported by Toni Palonen on 2010-09-28
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-4
High
dobey
Trunk
High
dobey
ubuntuone-client (Ubuntu)
High
Ubuntu One Client Engineering team
Maverick
High
dobey
Natty
High
Ubuntu One Client Engineering team

Bug Description

Binary package hint: ubuntuone-client

UbuntuOne is trying to open an "out of space" dialog for the account, but the dialog window never fully opens. Instead it loops on creating the window very fast and consumes all cpu%. There is no way of reading or closing the flickering window.

TEST CASE:
Pre-req - Ubuntu One account setup on computer and connected to service
1. Place a file over Ubuntu One account limit in ~/Ubuntu One ($ dd if=/dev/zero of=bigfile bs=1b count=4500000)
2. Copy multiple files or folders to ~/Ubuntu One/
3. Open Applications > Accessories > Terminal and run:
   killall ubuntuone-syncdaemon
   u1sdtool -c

Result: Out of space dialog pops up multiple times
Expected result: Out of space dialog pops up once

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: ubuntuone-client 1.4.3-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Sep 29 00:41:15 2010
ExecutablePath: /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fi_FI.utf8
SourcePackage: ubuntuone-client
UbuntuOneSyncdaemonExceptionsLog:

UbuntuOneUserSyncdaemonConfig:
 [bandwidth_throttling]
 on = False
 read_limit = 2097152
 write_limit = 2097152

Related branches

Toni Palonen (tonipalonen) wrote :
Toni Palonen (tonipalonen) wrote :

Video of the bug in action.

tags: added: desktop+ u1-maverick-sru
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Roman Yepishev (rye) wrote :

Hello,

Could you please check whether you have appmenu-gtk installed?
I have just experienced an issue with gnome-settings-daemon that became reinitializing plugins pretty fast causing layout settings to be reinitialized and this may also cause the flickering you were experiencing.

Additional question - is that 100% reproducible?

Roman Yepishev (rye) wrote :

We need to rate-limit the response for quota notifications since sometimes we may get outdated information in metadata causing this window to be created for every file that syncdaemon adds to the queue.

Another condition that triggers this error is when syncdaemon restarts the upload of the files that failed last time, subscription storage became less than available and this window will be popping up for every file being added to the queue again.

Roman Yepishev (rye) wrote :

The quick and dirty workaround for that is to remove ubuntuone plugin for gnome-settings-daemon and relogin:
sudo rm /usr/lib/gnome-settings-daemon-2.0/libubuntuone.so

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
importance: Undecided → High
importance: High → Medium
Changed in ubuntuone-client:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Alejandro J. Cura (alecu)
Randy (rjcayea) wrote :

This flickering bug still effects me as of 12-30-10

Changed in ubuntuone-client (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
Changed in ubuntuone-client (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.5.3-0ubuntu1

---------------
ubuntuone-client (1.5.3-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Metadata load is too slow (LP: #436612)
    - Out of space dialog is broken (LP: #650671)
    - Should not autoconnect when there are no credentials (LP: #701588)
    - gsd extension should not ask for sso credentials (LP: #702171)
 -- Rodney Dawes <email address hidden> Tue, 25 Jan 2011 16:42:52 -0500

Changed in ubuntuone-client (Ubuntu Natty):
status: Triaged → Fix Released
dobey (dobey) on 2011-02-18
Changed in ubuntuone-client (Ubuntu Maverick):
assignee: nobody → Rodney Dawes (dobey)
milestone: none → maverick-updates
status: Triaged → In Progress

Accepted ubuntuone-client into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
description: updated
Joshua Hoover (joshuahoover) wrote :

Tested and verified fix on Maverick with ubuntuone-client 1.4.6-0ubuntu1

Martin Pitt (pitti) on 2011-02-25
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.4.6-0ubuntu2

---------------
ubuntuone-client (1.4.6-0ubuntu2) maverick-proposed; urgency=low

  * 01-get-published-race.path:
    - Fix a race condition with requesting published files (LP: #661292)

ubuntuone-client (1.4.6-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - SD deletes files when local error on partial creation (LP: #657195)
    - Partials fail to be created with "filename too long" (LP: #662660)
    - New shares to me are not downloaded (LP: #664019)
    - Deleting UDF on one computer does not delete elsewhere (LP: #674092)
    - Preferences does not display info properly (LP: #657850)
    - "Out of Space" dialog is broken (LP: #650671)
    - Nautilus allows publishing files in others' shares (LP: #712674)
    - SSO help text does not appear translated (LP: #686647)
    - Nautilus is not aware of published files (LP: #661292)
    - Ubuntu One crashes in scan() (LP: #692496)
    - Volume info with None for free space causes QuotaExceeded (LP: #671023)
    - Settings daemon extension should not request credentials (LP: #702171)
 -- Rodney Dawes <email address hidden> Fri, 04 Mar 2011 12:10:05 -0500

Changed in ubuntuone-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers