Ribbons strings do not show up translated

Bug #640955 reported by Gabor Kelemen on 2010-09-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
ubuntuone-client (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ubuntuone-client

For some reason, the strings on the Nautilus U1 ribbon do not show up translated, even if they are present in the mo file.

Related branches

Gabor Kelemen (kelemeng) wrote :
David Planella (dpm) on 2010-09-17
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
Gabor Kelemen (kelemeng) wrote :

Including gi18n-lib.h instead ofgi18n.h solved it.

tags: added: desktop+ u1-maverick
Rodrigo Moya (rodrigo-moya) wrote :

Thanks Gabor for the patch. I had to change it in other places, which I guess had the same problem, so attached branch has the fix

Changed in ubuntuone-client (Ubuntu):
status: New → Fix Committed
status: Fix Committed → New
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → High
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.4.2-0ubuntu1

---------------
ubuntuone-client (1.4.2-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Adding a try-except block around clientdefs constants import to be able to run on development environments (Natalia Bidart) (LP: #628956)
    - Fix LR to delete the share metadata or unsubscribe the udf if the volume
      directory is missing from disk but VolumeManager still have the volume as
      "active" (Guillermo Gonzalez) (LP: #556783)
    - FSM creates the directories now, not Sync (Facundo Batista)
    - Default logging for ubuntuone-preferences is INFO (Natalia Bidart)
      (LP: #640438)
    - Plug a memory leak (Rodrigo Moya)
    - Added contacts for users with no addressbooks are kept in memory correctly
      now (Rodrigo Moya) (LP: #640171)
    - Fixed syncdaemon_metadata_get_is_synced to work for post-generations
      folders (Rodrigo Moya) (LP: #640392)
    - Fix a regression in VolumeManager, now it calls refresh_shares after
      server rescan (Guillermo Gonzalez) (LP: #638187)
    - Use com.syncdaemon.SyncDaemon.UniqueInstance name to check for existing
      instance of syncdaemon (Roman Yepishev) (LP: #639017)
    - Include glib's gi18n-lib.h, which forces definition of GETTEXT_PACKAGE
      (Rodrigo Moya) (LP: #640955)
    - Add syncdaemon_authentication_clear_token API for the music store to deal
      with invalid tokens (Rodrigo Moya) (LP: #634384)
 -- Rodrigo Moya <email address hidden> Mon, 20 Sep 2010 22:37:05 +0200

Changed in ubuntuone-client (Ubuntu):
status: New → Fix Released
David Planella (dpm) on 2010-09-21
Changed in ubuntu-translations:
status: Triaged → Fix Released
David Planella (dpm) wrote :

I've got the version that's supposed to contain the fix, and the language pack contains the updates. However, the ribbon is still shown in English only.

Could someone else confirm?

Changed in ubuntu-translations:
status: Fix Released → Incomplete
Gabor Kelemen (kelemeng) wrote :

I have removed and reinstalled the newest u1client (so that is is not my test package), but it appears translated.
David: have you tried turn it off and on again?

El dc 22 de 09 de 2010 a les 09:46 +0000, en/na Gabor Kelemen va
escriure:
> I have removed and reinstalled the newest u1client (so that is is not my test package), but it appears translated.
> David: have you tried turn it off and on again?
>

That was it, logging in to Ubuntu One made the translations load. I'll
do more testing, and I'll see if we have to file a new bug for
translations not being loaded until the client is connected.

Changed in ubuntu-translations:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers