nautilus crashed with SIGSEGV in syncdaemon_status_interface_get_current_status()

Bug #635629 reported by Groening on 2010-09-11
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubuntuone-client (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubuntuone-client

This bug is getting really nasty since my upgrade to maverick.

Whenever I change directories within my home directory (actually a separate non encrypted partition) nautilus keeps crashing or at least will take 15+ sec to walk directories.

Ubuntuone is configured to sync contacts ONLY!

I have no idea, what is causing that problem...

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: ubuntuone-client-gnome 1.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Sat Sep 11 11:22:20 2010
ExecutablePath: /usr/bin/nautilus
ProcCmdline: nautilus
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f9e0f3737aa <vfprintf+16746>: repnz scas %es:(%rdi),%al
 PC (0x7f9e0f3737aa) ok
 source "%es:(%rdi)" (0x00000001) not located in a known VMA region (needed readable region)!
 destination "%al" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: ubuntuone-client
StacktraceTop:
 syncdaemon_status_interface_get_current_status () from /usr/lib/libsyncdaemon-1.0.so.1
 syncdaemon_daemon_has_network () from /usr/lib/libsyncdaemon-1.0.so.1
 location_widget_new () from /usr/lib/nautilus/extensions-2.0/libnautilus-ubuntuone.so
 ?? () from /usr/lib/nautilus/extensions-2.0/libnautilus-ubuntuone.so
 ?? ()
Title: nautilus crashed with SIGSEGV in syncdaemon_status_interface_get_current_status()
UserGroups: adm admin audio cdrom dialout fax lpadmin netdev plugdev sambashare video www-data

Related branches

Groening (vonbehren-c) wrote :
Michael Gratton (mjog) wrote :

Yeah, I'm getting the same problem after upgrade. I don't have an encrypted disk, but whenever I open a subdirectory of my home Nautilus would crash as per above.

Opening sub-directories that are bookmarked (i.e. appear in the Nautilus places menu) of ~ causes this crash, but not others. .xsession-errors reports this just before the crash:

> ** (nautilus:13503): WARNING **: Error calling get_folders: Message did not receive a reply (timeout by message bus)
> (nautilus:13503): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
> (nautilus:13503): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
> ** (nautilus:13503): WARNING **: Error calling get_folders: Message did not receive a reply (timeout by message bus)
> ** (nautilus:13503): WARNING **: Error calling get_folders: Message did not receive a reply (timeout by message bus)
> (nautilus:13503): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
> This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
> The overwriting error message was: Message did not receive a reply (timeout by message bus)

File syncing is currently disabled. The dir ~/Ubuntu One appears in nautilus with a red cross overlay when viewing ~. Displaying ~ takes ages, with a whole bunch of "Error calling get_folders: Message did not receive a reply" reported in .xsession-errors while this is happening.

Michael Gratton (mjog) wrote :

Minor additional point: uninstalling ubuntuone-client-gnome fixes this problem, and these log messages go away.

Groening (vonbehren-c) wrote :

seems to be a duplicate of bug 610725

Like Mike's "workaround" uninstalling ubuntuone completely as described below solved it for me too:
https://bugs.launchpad.net/ubuntuone-client/+bug/610725/comments/3

Never the less... this is no fix of course but the only way to keep the system usable atm.

Michael Gratton (mjog) wrote :

That bug is about performance or UI concerns (depending on which bug you're talking about you mention two different ones), this bug is a crasher.

They may be related, but even if nautilus is behaving obtrusively or slowly, it shouldn't be crashing. Undup'ing.

Ant (anthonyvigh) wrote :

I have the same problem, opening my Downloads folder results in nautilus crash.

Colin Watson (cjwatson) wrote :

ubuntuone-client (1.4.1-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Fix VolumeManager.subscribe_udf method to handle the error cases properly
      (Guillermo Gonzalez) (LP: #632439)
    - Make ubuntuone-launch work with the new sso (John Lenton) (LP: #631822)
    - Wait for READY before asking for connection (John Lenton) (LP: #525743
      and LP: #518027)
    - Move operations live in limbo until confirmed (Facundo Batista)
    - Fix a few problems with emblems (Rodrigo Moya) (LP: #607247)
    - Load UDFs as soon as syncdaemon is ready (Rodrigo Moya) (LP: #612541)
    - Load public files as soon as syncdaemon is ready (Rodrigo Moya)
      (LP: #627339)
    - When VM receives an event on a volume it doesn't have, refresh them
      (Facundo Batista)
    - Made u1sync client work from the command line. No more "authorize" option,
      only --oauth (Natalia Bidart) (LP: #634337)
    - Marker chains are errbacked ok now (Facundo Batista)
    - Remove multiple returns in VolumeManager.subscribe_udf method (Guillermo
      Gonzalez)
    - Do calls to libproxy in a separate process (John Lenton) (LP: #633241)
    - OAuth consumer key and secret can be passed as parameter (Natalia Bidart)
      (LP: #637022)
    - Don't generate a new file if we're deleting or overwriting it
      (Facundo Batista)
    - Make sure that the u1 music path is present (Manuel de la Peña)
      (LP: #558762)
    - Make the "Current plan" label show the actual value returned from the
      server (John Lenton) (LP: #551138)
    - Add --with-sso option to configure, for building with uninstalled
      sso-client (Rodney Dawes)
    - Fix volume manager to create the fsm node on server rescan if the node
      isn't there (Guillermo Gonzalez) (LP: #632454)
    - Fix Local rescan to process read only shares and resume interrupted
      downloads (Guillermo Gonzalez) (LP: #598189)
    - Make sure we load list of shared folders in Nautilus plugin (Rodrigo Moya)
      (LP: #633013)
    - Dereference the possible markers in limbos (Facundo Batista)
    - Don't start syncdaemon from Nautilus plugin. Just wait for it to be
      available (Rodrigo Moya) (LP: #613219, LP: #635629 and LP: #628877)

 -- Rodrigo Moya <email address hidden> Wed, 15 Sep 2010 22:17:37 +0200

Changed in ubuntuone-client (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers