nautilus crash in IA__g_str_hash() when running u1sdtool --subscribe-folder

Bug #570261 reported by Milan Bouchet-Valat on 2010-04-26
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-2
High
dobey
Trunk
High
dobey
ubuntuone-client (Ubuntu)
Medium
dobey
Lucid
Undecided
Unassigned

Bug Description

-------------------------------------------------------

TEST CASE:

1. In a terminal session: u1sdtool --subscribe-folder ~/PATH

Result: FolderSubscribeError: DOES_NOT_EXIST (id=/home/username/PATH) and Nautilus crashes
Expected result: DOES_NOT_EXIST (id=/home/username/PATH) returned

-------------------------------------------------------

Binary package hint: ubuntuone-client

Fully reproducible when I run, with any PATH:
u1sdtool --subscribe-folder ~/PATH
FolderSubscribeError: DOES_NOT_EXIST (id=/home/milan/PATH)

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: ubuntuone-client-gnome 1.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
CrashCounter: 1
Date: Mon Apr 26 17:55:38 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/nautilus
ProcCmdline: nautilus --sm-client-id 10794a7095342a6d5126959346462618600000022660050 --sm-client-state-file /home/hostname/.config/session-state/nautilus-1272230187.desktop
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x397097 <IA__g_str_hash+7>: movsbl (%edx),%eax
 PC (0x00397097) ok
 source "(%edx)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: ubuntuone-client
StacktraceTop:
 IA__g_str_hash (v=0x0) at /build/buildd/glib2.0-2.24.0/glib/gstring.c:134
 g_hash_table_lookup_node (hash_table=0xa08a9b0, key=0x0,
 g_hash_table_remove_internal (hash_table=0xa08a9b0, key=0x0, notify=1)
 ?? ()
 ubuntuone_nautilus_marshal_VOID__OBJECT_STRING ()
Title: nautilus crashed with SIGSEGV in IA__g_str_hash()
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare scanner tape video

Related branches

Milan Bouchet-Valat (nalimilan) wrote :
description: updated

StacktraceTop:
 IA__g_str_hash (v=0x0) at /build/buildd/glib2.0-2.24.0/glib/gstring.c:134
 g_hash_table_remove_internal (hash_table=0xa08a9b0,
 ?? ()
 ubuntuone_nautilus_marshal_VOID__OBJECT_STRING ()
 marshal_dbus_message_to_g_marshaller (closure=0xa12da38,

Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
summary: - nautilus crashed with SIGSEGV in IA__g_str_hash()
+ nautilus crash in IA__g_str_hash() when running u1sdtool --subscribe-
+ folder
dobey (dobey) on 2010-04-26
Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
status: New → In Progress
dobey (dobey) on 2010-04-27
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-client (Ubuntu):
milestone: none → lucid-updates
assignee: nobody → Rodney Dawes (dobey)
status: New → In Progress
dobey (dobey) on 2010-05-27
tags: added: u1-lucid-sru
Milan Bouchet-Valat (nalimilan) wrote :

Nice to see hard bugs in U1 are getting fixed! ;-)

description: updated

Accepted ubuntuone-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Joshua Hoover (joshuahoover) wrote :

Test case passed with 1.2.2-0ubuntu2 proposed installed.

Martin Pitt (pitti) wrote :

Since it was fixed in trunk a while ago, I assume that maverick's current version (1.3.2) has the fix as well. Closing all the maverick tasks.

tags: added: verification-done
removed: verification-needed
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

ubuntuone-client (1.2.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release.
    - Properly handle valid UTF-8 non-ASCII names for UDFs (LP: #557160)
    - Fix nautilus crash when running u1sdtool --subscribe-folder (LP: #570261)
    - Cannot reactivate "File sync" on services tab (LP: #570721)
    - Retry interrupted uploads (LP: #575817)
    - Improve logging at INFO level (LP: #578248)
    - u1sdtool --delete-folder with invalid id hangs (LP: #583412)
    - ubuntuone-syncdaemon crashed with OSError (LP: #452682)
    - ubuntuone-preferences "Got empty result for devices list." (LP: #576263)
  * Rmmove fix-571548.patch and fix-567223.patch; included upstream now.
 -- Rodney Dawes <email address hidden> Wed, 16 Jun 2010 13:42:32 -0400

Changed in ubuntuone-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers