Ubuntu One Preferences freezes when opened

Bug #568826 reported by Glenton Jelbert
This bug affects 26 people
Affects Status Importance Assigned to Milestone
ubuntuone-client (Ubuntu)
Ubuntu One Client Engineering team
Nominated for Lucid by patomas

Bug Description

Binary package hint: ubuntuone-client

My Ubuntu One is not syncing with the server (although I have a second computer which continues to be connected).

I tried to open Ubuntu One Preferences, and the application opened, but in a frozen state. That is, I could not change tab, and clicking on the buttons had no effect. I could not close it, and right-clicking on the top gave a drop-down box, but selecting close did not cause any difference. I can minimise the window, but when I reopen, the window is blank except for "Ubuntu One Preferences" across the top.

I gave it several hours, but have just killed it with system monitor.

Incidentally I tried this a few days ago, and the effect was the same on this computer. Rebooting has had no effect.

1. I'm using the lucid lynx.
2. I'm not sure what the package is called. I accessed via System - Preferences - Ubuntu One.
3. I expected to be able to fiddle around with my Ubuntu One settings (as I have done on my other lap top, also updated with Lucid Lynx). I was trying to see whether I could get my Ubuntu One to be connected to the server.
4. The preferences applet was unresponsive.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ubuntuone-client-gnome 1.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
CheckboxSubmission: c245bbe2358f671ec83b4ebf046a802a
CheckboxSystem: 1e8a26b69c24fde71cf39f7ba43d0b26
Date: Fri Apr 23 13:54:22 2010
ExecutablePath: /usr/bin/ubuntuone-preferences
InterpreterPath: /usr/bin/python2.6
SourcePackage: ubuntuone-client
 bookmarked = True
 connected = False
 connect = 0
 show_applet = 1
 2010-04-23 10:46:25,160 - ubuntuone.SyncDaemon.ActionQueue - ERROR - The request 'oauth_authenticate' failed with the error:

 read_limit = 2097152
 write_limit = 2097152
 on = False

Revision history for this message
Glenton Jelbert (glenton-jelbert) wrote :
Revision history for this message
Yuriy Padlyak (gneeot) wrote :

Any progress on this? It's really annoying..

Revision history for this message
ben van 't ende (benvantende) wrote :

i got it working using this from my blog http://blog.vantende.net/post/archive/2010/04/23/ubuntuone_on_kubuntu_lucid_lynx/

after rebooting however ubuntuone fails again with:

** Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-preferences", line 1142, in <module>
    prefs_dialog = UbuntuOneDialog()
  File "/usr/bin/ubuntuone-preferences", line 534, in __init__
  File "/usr/bin/ubuntuone-preferences", line 974, in __construct
  File "/usr/bin/ubuntuone-preferences", line 376, in list_devices
    token = get_access_token(self.keyring)
  File "/usr/bin/ubuntuone-preferences", line 124, in get_access_token
    'oauth-consumer-key': 'ubuntuone'})

Revision history for this message
Jean Roberto Souza (sjeanr) wrote :

I believe I had the same problem on my Lucid install and I was able to fix it!

By watching the System Monitor I was able to identify that the client would Freeze when trying to log in, and then it would stop responding.

To solve that, I first tried to reinstall the package and also cleaning ubuntuone cache but it didn't work.

Later I found one simple instruction that solved the Freezing issue and now my files have been synchronized successfully.

By researching other bugs related to ubuntuone I realized that some times users would be indicated to do the following:

Log in at ubuntu one website!

Open Terminal!

On terminal type:

sudo apt-get install ubuntuone-client-tools

and then

u1sync --authorize

This will install "Ubuntu-client-tools" package and then open the browser to ask for your credentials on Ubuntu one website. I suggest you to be logged in on the website before doing it. ubuntuone.com

I still not sure why Ubuntuone was Freezing when trying to log in. I also noticed that on the Ubuntu one preference window it was showing "Unknown" where it was supposed to show the user account information.

I tested a very small file (feel bytes) and it took more then 5 minutes to show on Ubuntu one to the point I was able to go to the website and see the file with an Uploading status! But that is another problem!

I hope this will be helpful for those in trouble! Have a good day!

Revision history for this message
jorno (jorn-odberg) wrote :

I installed Ubuntu 10.04 Lucid LTS (Release Candidate) today, and installed every update available.

I startet Ubuntu One, and got asked to authenticate, which I did. After this, the Ubuntu One preferences dialog hangs after a few seconds, no matter what I try to do.

Really annoying, and I hope (for the sake of Ubuntu) that this will get fixed before Lucid is released.

Kind regards from Norway.

Revision history for this message
Duane Hinnen (duanedesign) wrote :


can you try opening ubuntuone-preferences from the Terminal and post any output printed to the Terminal?

Open a Terminal and run:


Revision history for this message
Geek87 (geek87) wrote :


I cannot pair my laptop with UbuntuOne whereas it works with my desktop. Sometimes the preferences dialog freezes. Here is the output from the terminal:

Apache CouchDB has started, time to relax.
Browse your desktop CouchDB at file:///home/yann/.local/share/desktop-couch/couchdb.html
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/bin/ubuntuone-preferences", line 1083, in got_newcredentials
  File "/usr/bin/ubuntuone-preferences", line 1071, in present
  File "/usr/bin/ubuntuone-preferences", line 747, in connect_desktopcouch_exclusion
    self.dcouch = dcouch.ReplicationExclusion()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/replication_services/ubuntuone.py", line 167, in __init__
    raise ValueError("No pairing record for ubuntuone.")
ValueError: No pairing record for ubuntuone.

Revision history for this message
manolo (manuel-sales) wrote :

I have discovered that the Ubuntu One Preferences window freezes when I have no wifi/network connection.
I have repeated several times and is always the same, if connection no problem if no connection window freezes.

I dont know if it is exactly the same problem as mine, but I think it is better to group with yours.

I also have Ubuntu 10.4 (brand new instaled) and I'm new to Ubuntu One, I registered yesterday and the file sync takes ages.

Good luck!

patomas (patomas)
description: updated
Revision history for this message
Thomas Nordstrom (thomas-iglo) wrote :

I think I have the same problems as a few others here:

$ ubuntuone-preferences
Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
  File "/usr/lib/python2.6/threading.py", line 484, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/bin/ubuntuone-preferences", line 162, in do_rest_request
  File "/usr/bin/ubuntuone-preferences", line 680, in got_quota_info
    self.update_quota_display(used, total)
  File "/usr/bin/ubuntuone-preferences", line 634, in update_quota_display
    'percent' : percent })
KeyError: 'brukt'

"brukt" is Norwegian and equals to "used"

I also had no problem on Ubuntu 9.10

Revision history for this message
Id2ndR (id2ndr) wrote :

Same think to me even after removing the files:

$ for pid in `ps -ef | grep ubuntuone | awk '{ print $2 }'`; do kill $pid; done
$ rm -rf .local/share/ubuntuone .cache/ubuntuone .config/ubuntuone
$ ubuntuone-preferences Exception in thread Thread-4:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
  File "/usr/lib/python2.6/threading.py", line 484, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/bin/ubuntuone-preferences", line 162, in do_rest_request
  File "/usr/bin/ubuntuone-preferences", line 348, in parse_devices
  File "/usr/bin/ubuntuone-preferences", line 304, in error
AttributeError: 'module' object has no attribute 'MODAL'

[1]+ Stopped ubuntuone-preferences

Revision history for this message
jhfhlkjlj (fdsuufijjejejejej-deactivatedaccount) wrote :

related to bug 567223?

Revision history for this message
Duane Hinnen (duanedesign) wrote :

Some people have experienced freezing of Ubuntu One Preferences when trying to set up there Ubuntu One account. After signing up for service and then going to add their computer, the Preferences Panel will freeze. In case this is the situation with any of the posters here please:
   1. close the Ubuntu One Preferences application window (if it's already open)
   2. open your Terminal (located in Applications >> Accessories)
   3. and type the following:

 u1sdtool -q; killall ubuntuone-login; u1sdtool -c

This should force a web browser to open and put you at step 2 of this process:

More details:

thank you,

Revision history for this message
Kimble85 (kim-betti) wrote :

I'm getting exactly the same error as Thomas Nordstrom.

Revision history for this message
Jostein (josteinaj) wrote :

duanedesign: I have this problem and tried running your command, but nothing happened (no brower window appeared.) All I get is "ubuntuone-syncdaemon stopped.", and then nothing...

Revision history for this message
André Savik (asavik) wrote :

I, too, have exactly the same issue as Thomas Nordstrøm. To put it bluntly, Ubuntu One has never worked at a level even close to a professional product, and I now understand it probably never will.

The essential problem I pointed out in https://bugs.launchpad.net/ubuntuone-client/+bug/482851 still remains: Ubuntu One's developers have made a concious choice to hide serious error conditions from their users.

Incidentally, I'm cancelling my subscription to Ubuntu One and moving my files over to Dropbox, which still works without a hitch.

Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
tags: added: desktop+
Revision history for this message
Roy G. Larsen (roy-embla) wrote :

I, too, have exactly the same issue as Thomas Nordstrøm.

I modified /usr/bin/ubuntuone-preferences:

Commented out the following lines: 634-638

 # self.usage_label.set_text(
 # _("%(used)0.1f %(type)s Used (%(percent)0.1f%%)") % {
 # 'used' : real_used,
 # 'type' : real_type,
 # 'percent' : percent })

and saved the file as root.

Now it works, but it doesn't display how much file space you are using...

Revision history for this message
Jostein (josteinaj) wrote :

Roy: Nice! Works for me too. Still doesn't really transfer any data though, but at least it's not frozen anymore.

Revision history for this message
torarve (tor-arve-stangeland) wrote :

Alternative solution that shows how much file space your are using, but only in English language:
            _("%(USED)0.1f %(TYPE)s Used (%(PERCENT)0.1f%%)") % {
                'USED' : real_used,
                'TYPE' : real_type,
                'PERCENT' : percent })
        self.usage_graph.set_fraction(percent / 100)

It is caused by translating names/identifiers found inside %(...). I am currently trying to find out how to submit a correct translation for nb (Norwegian, bokmål).

Revision history for this message
torarve (tor-arve-stangeland) wrote :

Update: Found the following https://bugs.launchpad.net/ubuntu/+source/ubuntuone-client/+bug/571616. Seems this fixes some of the reported issues, but not all.

Vallery Lancey (muscovy)
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.