volume_manager.py, sometimes share is a dict, and sometims a _Share

Bug #529666 reported by Rick Spencer on 2010-02-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Guillermo Gonzalez
ubuntuone-client (Ubuntu)
High
dobey

Bug Description

Binary package hint: ubuntuone-client

After deleting keys to work around bug #529629, /usr/bin/python /usr/lib/ubuntuone-client/ubuntuone-syncdaemon still did not work, resulting in error:

  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/volume_manager.py", line 1341, in _upgrade_share_to_volume
    if share.path == self._root_dir or share.id == '':
AttributeError: 'dict' object has no attribute 'path'

After adding this at line 1341 it started working:
 if type(share) is dict:
  return Shared(volume_id=share["volume_id"],node_id=share["node_id"])

I presume it is not by design that share is sometimes a dict and sometimes a _Share, so I am submitting a bug rather than a patch.

ProblemType: Bug
.home.rick..cache.ubuntuone.log.syncdaemon.exceptions.log:

.home.rick..config.ubuntuone.syncdaemon.conf:
 [bandwidth_throttling]
 read_limit = 0
 write_limit = 0
 on = False
.home.rick..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 connected = False
 connect = 0
 show_applet = 0
 bookmarked = True
Architecture: i386
Date: Sun Feb 28 15:52:07 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
NonfreeKernelModules: wl
Package: ubuntuone-client 1.1.2-0ubuntu2
PackageArchitecture: all
ProcEnviron:
 LANG=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: ubuntuone-client
Uname: Linux 2.6.32-14-generic i686

Related branches

Guillermo Gonzalez (verterok) wrote :

Hi Rick,

After reading the #ubuntuone backlog, looks like a partial metadata upgrade (something broke during the metadata upgrade).

can you check if there are any logs of the first failure? (before getting this error)

Thanks.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in ubuntuone-client:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Guillermo Gonzalez (verterok)
tags: added: broken-metadata
chicken159 (services) wrote :

Just in case this helps - at best a clue, probably a coincidence: I have been having all sorts of problems with ubuntuone, and one of them seemed to match this bug - in fact it was the last one I'd followed up before I got it working on this machine - what 'seemed' to fix it, and also get the syncing working, was my latest remove and reinstall - only after removing and purging all the ubuntuone packages, and couchdb packages, in desperate scorched-earth mode I manually searched and removed any files on the system containing 'ubuntuone' (except icons etc.). This included a bunch of python files...unfortuntately I didn't note which. But just in case the problems I've been seeing are also other people's, and they relate to old files being left behind when they should have been removed...

tags: added: u1-lucid
tags: added: chicharra
tags: added: package
Changed in ubuntuone-client:
status: Triaged → In Progress
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Guillermo Gonzalez (verterok)
status: Confirmed → In Progress
Changed in ubuntuone-client:
milestone: none → lucid-beta-2
Changed in ubuntuone-client (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-client:
status: Fix Committed → In Progress
Changed in ubuntuone-client (Ubuntu):
assignee: Guillermo Gonzalez (verterok) → Rodney Dawes (dobey)
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
tags: removed: package
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers