Bandwith limit preference doesn't appear to be saved

Bug #465030 reported by Herb McNew on 2009-10-30
202
This bug affects 41 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
James Tatum
ubuntuone-client (Ubuntu)
Medium
dobey
Karmic
Medium
Unassigned

Bug Description

STEPS TO REPRODUCE/TEST:

1. Open Internet->Applications->Ubuntu One
2. Right-click on Ubuntu One client applet & select "Preferences"
3. Click on "Limit Bandwidth Usage"
4. Set "Maximum upload speed (KB/s):" to 128
5. Set "Maximum download speed (KB/s):" to 128
6. Click the "Close" button
7. Right-click on Ubuntu One client applet & select "Preferences"

Result: "Limit Bandwidth Usage" checkbox is unchecked & upload and download speed inputs are set to 2048

Expected result: "Limit Bandwidth Usage" checkbox is checked & upload and download speed inputs are set to 128

--------------------------------------

ORIGINAL DESCRIPTION:

Binary package hint: ubuntuone-client

When I use the gnome applet preferences dialog to change my bandwidth limit it doesn't appear to be saved. I go to Preferences, check the "Limit Bandwidth Usage" box, set the upload and download limits to 128 KB/s and click close. If I then go back into Preferences, the "Limit Bandwidth Usage" box is unchecked and the grayed out upload and download limits are back to the default of 2048 KB/s

ProblemType: Bug
.home.herb..cache.ubuntuone.log.syncdaemon.exceptions.log:

.home.herb..config.ubuntuone.syncdaemon.conf:
 [bandwidth_throttling]
 read_limit = 2097152
 write_limit = 131072
 on = True
.home.herb..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 bookmarked = True
 connected = True
 connect = 0
 show_applet = 0
Architecture: i386
Date: Fri Oct 30 11:45:13 2009
DistroRelease: Ubuntu 9.10
Package: ubuntuone-client 1.0.2-0ubuntu2
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: ubuntuone-client
Uname: Linux 2.6.31-14-generic i686

Related branches

Herb McNew (herb) wrote :
altima (timashkov) wrote :

the same with me. when unlimited it usurps the whole band, and no other application can reach the Internet.

same for me :(

Morten Jensen (mortenut) on 2009-11-01
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
papukaija (papukaija) wrote :

The limit seems to be saved (see [bandwidth_throttling] above), but the ubuntuone-applet doesn't read it.

James Tatum (jtatum) on 2009-11-06
Changed in ubuntuone-client:
status: New → Confirmed
James Tatum (jtatum) wrote :

Created a branch to address this: lp:~jtatum/ubuntuone-client/bug-465030

Changed in ubuntuone-client:
assignee: nobody → James Tatum (jtatum)
James Tatum (jtatum) on 2009-11-06
Changed in ubuntuone-client:
status: Confirmed → In Progress
KaiserSoze (rodolfog) wrote :

+1 with problem here. I have to quit application in order to have internet back.

James Tatum (jtatum) wrote :

Branch was merged.

Changed in ubuntuone-client:
status: In Progress → Fix Committed
Rick McBride (rmcbride) wrote :

The bandwidth saving issue is seperate and distinct from the "protocol mismatch" error. While the appearance of that message is somewhat related, the fact that the settings were not being saved is a seperate bug.

jakslev (jakslev) wrote :

My Ubuntu One will not connect at start up. I have to click on "Bandwidth limitation" and then it will connect. When I go back in it will have greyed out all the boxes again. I am still able to surf the internet and it doesn't seem that it doing anything except waking up the application.

Stilla hanging on to Dropbox while this continues :o)

dobey (dobey) on 2009-12-10
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Medium
status: Confirmed → In Progress
dobey (dobey) on 2009-12-10
tags: added: ubuntuone-sru

Accepted ubuntuone-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Rune K. Svendsen (runeks) wrote :

With the proposed fix, the saved values are now shown when I open the Preferences-dialog.
However, the actual bandwidth limiting doesn't seem to work. With the limit set at 64 KB/s, it still uploads at around 100 KB/s on my computer. Although, if I set the limit to 0, the download stops and the client program disconnects. I guess that means it works when limiting the bandwidth to 0 KB/s :).

Changed in ubuntuone-client:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Rick McBride (rmcbride) on 2010-01-13
Changed in ubuntuone-client:
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu Karmic):
importance: Undecided → Medium
Joshua Hoover (joshuahoover) wrote :

Tested proposed update on a fresh Karmic install with all standard updates & proposed updates for ubuntuone-client & dependent packages. Ran steps to reproduce and got the following unexpected result: "Maximum upload speed" set to 128 & "Maximum download speed" set to 0 - FAIL.

description: updated
Joshua Hoover (joshuahoover) wrote :

Roman found that the fields only appear to save when focus is removed from the input field. So, if you set the upload and download inputs and take focus (mouse off) the fields after changing the value, they should save properly. This is not proper behavior but at least gives us an idea of what is really going on. It's not that one field saves properly and another does not.

John Mahoney (jmahoney) wrote :

Also, a min upload of 64 kB is really 64 * 8 = 512 kilobites per second. Most people do not calculate data transfer in kiloBytes and also 512 kilobites is still faster than the max. uplink on many dls routers, so therefore no throttling is achieved.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.3-0ubuntu1

---------------
ubuntuone-client (1.0.3-0ubuntu1) karmic-proposed; urgency=high

  * New upstream release
    - Remove patch files now in upstream for #462828
    - Require python-ubuntuone-storageprotocol >= 1.0.1
    - BadTransition: SYS_CONNECTION_MADE (LP: #457147)
    - ValueError: invalid literal for int() with base 10: 'None' (LP: #476777)
    - Protocol version error with bw throttling enabled (LP: #455544)
    - Folder deletion from other machines results in conflicts (LP: #462003)
    - Syncdaemon doesn't disable throttling (LP: #483592)
    - Syncdaemon crashes with NoAccessToken (LP: #488413)
    - Error creating share from Nautilus: callback() (LP: #492100)
    - Work without NetworkManager installed (LP: #357395)
    - Create a POT during the build (LP: #455527)
    - Bring back timestamps in oauth-login.log (LP: #459175)
    - Applet starts syncdaemon without a token (LP: #491573)
    - Prefs changes don't take immediate affect (LP: #457564)
    - BW limit settings don't appear to be saved (LP: #465030)
    - Distinguish auth errors from other errors (LP: #450633)
    - Fix for running on python < 2.6.3 (LP: #451670)
 -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 15:45:52 -0500

Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Roman Yepishev (rye) wrote :

The original description stated that the preferences are not saved.

Now preferenced are saved but it does not work quite right.

I have copied Joshua's response to bug #509740 which reports the issue with focus-related saving of values.

dobey (dobey) on 2010-02-10
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
Roman Yepishev (rye) on 2010-02-17
description: updated
Stefan Stasik (stefan-stasik) wrote :

Hi: It seems to me that I am still having problems with this issue. No matter what I set in my client setting, sync-daemon ignores my setting, and just uploads at my full upload bandwidth. Does anyone have suggestions why this could be the case, if this bug has been fixed?

my version of client, Lucid: ubuntuone-client v1.2.2

papukaija (papukaija) wrote :

@Stefan: This bug is fixed. Please open a new bug report (after searching for existing ones).

It's not fixed in Lucid with all updates. I still have same problem. It's a real problem when bandwith is shared.

psypher (psypher246) wrote :

Yup I have the same issue. haven't tried the feature in a while. But recently Ubuntu One has vastly improved in it's upload speed and it's actually using 10MB/s on upload and download. So tried the shaping but does not work.

Keep up the good work, it has vastly improved in other areas as well.
Thanks

papukaija (papukaija) wrote :

You are probably reproducing bug 509740, please check that with the reproducing steps included in that bug's description. If you can't reproduce that bug, then you are seeing a new bug (please open a new bug report with bandwidth-throttling tag). Thanks in advance!

psypher (psypher246) wrote :

HI does not seem to be related. I have logged a new bug: https://bugs.launchpad.net/ubuntu/+source/ubuntuone-client/+bug/634013

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers