Some file types must be ignored (backups, vcs...)

Bug #462407 reported by Juan Montoya on 2009-10-28
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Wishlist
Unassigned
Nominated for Stable-1-2 by HornedBeast
ubuntuone-client (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubuntuone-client

I believe some files should be ignored, maybe the user may specificy some file filters on his own.

Playing with Ubuntu One for a while I found files such as backups (mydoc.txt~) and hidden files such as .bashrc are synchronized too. I believe temporary files and generated files (python .pyc files, java .class files and version control files such as .svn or CVS) are synchronized too.

So, what if I add a netbeans java project to Ubuntu One? Everytime I compile the project Ubuntu One wil synchronize a lot of files, right?
This will overload the servers with unnecessary traffic.

So, ignore file filters would be good, and,
Manual synchronization should be advisable (I save files a lot when I'm working with them).
Maybe a warning before shutting down the system would be nice if manual synchronization is enabled ("# files have been modified, synchronize before shutdown?").

Stephan Peijnik (speijnik) wrote :

I can second this request.

Especially automatically generated files should probably not end up on Ubuntu One, however, hidden files (or directories), such as an .bzr directory might be important. In my opinion the best option would be making this configurable on a per-directory basis, if this is feasible.

Also, I noticed that backup files Emacs generates (such as #<filename>#) are synchronized too. This are temporary files only and should probably never be synchronized.

Michael Rooney (mrooney) wrote :

I'll mark this as Triaged since I can also confirm the issue and think it is ready for a developer to look at.

I too have been driven a little insane when editing files in ~/Ubuntu One :) When you open the file with vim it creates a swap, so you get a notification that it is starting a sync. A few seconds later you get a second one telling you it has finished. Now you make a change, save and exit, and you get 2 more notifications. More humorously, if you close the file before the sync is done, it will tell it is "done updating 0 files".

I think a conservative list of ignored files would be good like vim/emacs/gedit temporary files. All hidden files might not be good as as you might use Ubuntu One to sync configuration files as I do and then you might run in to a problem. At the VERY least, it seems very logical to at least ignore these files for notifications if it is deemed problematic to start ignoring some files (though I think starting with editor temp files is a safe start).

Changed in ubuntuone-client (Ubuntu):
status: New → Triaged
Changed in ubuntuone-client:
status: New → Triaged
importance: Undecided → Wishlist
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Wishlist
Jayson Reis (jaysonsantos2003) wrote :

That whould be good if we could specify which files we don't what to be synchronized using regular expressions, so we can catch a lot of things.

Facundo Batista (facundo) wrote :

This is fixed since revno 452.

The following files are being ignored:

\A#.*\Z
\A.*~\Z
\A.*\.py[oc]\Z
\A.*\.sw[nop]\Z
\A.*\.swpx\Z
\A\..*\.tmp\Z

(those are Python regexes that should match the whole file).

Note that you can change that in your local config.

Changed in ubuntuone-client (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntuone-client:
status: Triaged → Fix Committed
Facundo Batista (facundo) wrote :

Sorry, it was fixed since revno 439.

Jayson Reis (jaysonsantos2003) wrote :

Is that revision in mainline ?

Jayson Reis (jaysonsantos2003) wrote :

I'm asking because this kind of logs.

2010-03-30 14:51:39,686 - ubuntuone.SyncDaemon.sync - DEBUG - T:LOCAL:F cda357ec-10ea-481c-ae28-67a8da52553c ['a770102c-377f-443d-bd84-9667851a8dff'::'1fd89857-3fff-48ed-8ba7-faf705a09821'] ''Projetos/copaloft/src/copaloft/paginasplanas/__init__.pyc'' | Called new_local_file_created
2010-03-30 15:00:53,919 - ubuntuone.SyncDaemon.ActionQueue - DEBUG - MakeFile share:'a770102c-377f-443d-bd84-9667851a8dff' node:marker:382df72b-47f6-4f8e-b579-0cdbfe5c8d72 MakeFile(marker='marker:382df72b-47f6-4f8e-b579-0cdbfe5c8d72', parent_id='marker:e59f63d9-1d44-4553-9c6c-541f048bbc6e', share_id="'a770102c-377f-443d-bd84-9667851a8dff'", name="u'__init__.pyc'") starting

Roman Yepishev (rye) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 462828, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in ubuntuone-client:
status: Fix Committed → Confirmed
Changed in ubuntuone-client (Ubuntu):
status: Fix Committed → Confirmed
tags: added: bugpattern-invalid-duplicate
tags: removed: amd64 apport-bug
description: updated
Roman Yepishev (rye) on 2010-04-01
Changed in ubuntuone-client:
status: Confirmed → Fix Committed
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Committed
Andrew Burcin (andrew-burcin) wrote :

Is this committed into the 1.2.1 client in Lucid? I see it was committed before 1.2.1 was released (19.04) but I can't find any configuration files in the local configuration directory. If it is already in the code shipping with Lucid, can you tell me where this config file should be? As with many people I want to use this to ignore various temp files and VCS repositories.

HornedBeast (andrew-barlow) wrote :

"Is this committed into the 1.2.1 client in Lucid? I see it was committed before 1.2.1 was released (19.04) but I can't find any configuration files in the local configuration directory. If it is already in the code shipping with Lucid, can you tell me where this config file should be? As with many people I want to use this to ignore various temp files and VCS repositories."

I second this! Would love to know where this is! I've been searching through Python Scripts for days trying to find it!

HornedBeast (andrew-barlow) wrote :

Aha! I've found it!

On Ubuntu 10.04 its under : /etc/xdg/ubuntuone/syncdaemon.conf

Simply append and mend:

ignore.default = \A#.*\Z
                 \A.*~\Z
                 \A.*\.py[oc]\Z
                 \A.*\.sw[nop]\Z
                 \A.*\.swpx\Z
                 \A\..*\.tmp\Z

With whatever you want. You can add .iso, for example, by doing this...

ignore.default = \A#.*\Z
                 ........---.........
                 \A\..*\.tmp\Z
                 \A.*\.iso\Z

Hope that helps someone out!

Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers