BadTransition: SYS_CONNECTION_MADE - Ubuntu One crashes coming out of sleep/hibernate

Bug #457147 reported by Shantanu on 2009-10-21
This bug affects 705 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Critical
Facundo Batista
Ubuntu One storage protocol
Critical
Facundo Batista
ubuntuone-client (Ubuntu)
Critical
dobey
Declined for Dapper by dobey
Declined for Hardy by dobey
Declined for Intrepid by dobey
Declined for Jaunty by dobey
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
ubuntuone-storage-protocol (Ubuntu)
Critical
dobey
Declined for Dapper by dobey
Declined for Hardy by dobey
Declined for Intrepid by dobey
Declined for Jaunty by dobey
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: ubuntuone-client

ubuntu one crash on coming out of sleep mode.

NOTE: This bug also appears to affect users when coming out of hibernate and when the network connection is connected and then disconnected. Those are the cases I'm finding so far that produce the BadTransition debug entry.

ProblemType: Bug
.home.shantanu..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 connected = True
 connect = 0
 show_applet = 1
 bookmarked = True
Architecture: i386
CheckboxSubmission: 4e108058a24c96a9948d9eb1f4223902
CheckboxSystem: b633b4f40868d491c2ae5b50030ce6f3
Date: Wed Oct 21 17:59:52 2009
DistroRelease: Ubuntu 9.10
Package: ubuntuone-client 1.0.2-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: ubuntuone-client
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:1979): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1979): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:2083): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:2100): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:2080): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

Related branches

Shantanu (shantanu-deshpande) wrote :
Joshua Hoover (joshuahoover) wrote :

Hi Shantanu, My apologies for the crashes. We thought we had these fixed but apparently the issue remains when coming out of sleep or hibernate. I'm going to assign this to a developer so that he can look into this further and follow up here with any questions. Thank you, Joshua

Changed in ubuntuone-client (Ubuntu):
status: New → Triaged
Changed in ubuntuone-client:
status: New → Triaged
importance: Undecided → High
assignee: nobody → John Lenton (chipaca)
tags: added: foundations+
description: updated
summary: - ubuntu one crash on coming out of sleep mode
+ BadTransition: Ubuntu One crashes coming out of sleep/hibernate

Confirmed on Acer Aspire One ZG5 (8gb SSD)

Changed in ubuntuone-client:
importance: High → Critical
tags: added: ubuntuone-sru
tags: added: facundo-lucid
Ash Goodman (ash-ashdezign) wrote :

Same is happening to me.

summary: - BadTransition: Ubuntu One crashes coming out of sleep/hibernate
+ BadTransition: SYS_CONNECTION_MADE - Ubuntu One crashes coming out of
+ sleep/hibernate
tags: added: common
tags: added: chicharra-lucid-problems
removed: facundo-lucid
Srikanth Varadarajan (svaradar) wrote :

Confirmed to happen in MacBook Pro. It does not happen all the time, its random.

John Lenton (chipaca) on 2009-11-28
Changed in ubuntuone-client:
assignee: John Lenton (chipaca) → Lucio Torre (lucio.torre)
Changed in ubuntuone-client:
assignee: Lucio Torre (lucio.torre) → Naty Bidart (nataliabidart)
tags: added: bad-transition
Changed in ubuntuone-client:
assignee: Naty Bidart (nataliabidart) → Facundo Batista (facundo)
Changed in ubuntuone-client:
status: Triaged → Fix Committed
Changed in ubuntuone-client (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Changed in ubuntuone-client (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
dobey (dobey) on 2009-12-03
Changed in ubuntuone-client:
status: Fix Released → Fix Committed
dobey (dobey) on 2009-12-09
Changed in ubuntuone-client (Ubuntu):
status: Fix Committed → In Progress
dobey (dobey) on 2009-12-11
Changed in ubuntuone-storage-protocol:
status: New → Fix Released
importance: Undecided → Critical
assignee: nobody → Facundo Batista (facundo)
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
dobey (dobey) on 2009-12-11
Changed in ubuntuone-storage-protocol (Ubuntu):
status: New → In Progress
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Critical
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Critical
Jonathan Davies (jpds) on 2009-12-14
Changed in ubuntuone-storage-protocol (Ubuntu):
milestone: none → karmic-updates
Changed in ubuntuone-client (Ubuntu):
milestone: none → karmic-updates
citizen (pipe-iki) wrote :

It happened now first time. Earlier waked up from suspend normally. There were no software updates between that I know of.

Accepted ubuntuone-storage-protocol into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-storage-protocol (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted ubuntuone-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Karmic):
status: New → Fix Committed
knuutsen (peter-vornberg) wrote :

@Martin Pitt:
Ok i will do it but no package available for now....

greets
knuutsen

Bole (pgonzamailcn) wrote :

Also happened to me on a HP Pavilion dv2000

Talha Khan (tkhan4486) wrote :

I have added karmic-proposed to my list of repositories, but I cannot seem to find ubuntuone-storage-protocol. However, in Synaptic I see python-ubuntuone-storageprotocol, and that package seems to be upgradable from 1.0.0-0ubuntu1 (from karmic) to 1.0.1-0ubuntu1 (from karmic-proposed). Should I install this package and report the results?

Also, it seems that I can upgrade ubuntuone-client to version 1.0.3-0ubuntu1. Should I go ahead and upgrade this package while I wait for ubuntuone-storage-protocol to appear?

Talha Khan [2010-01-09 20:17 -0000]:
> I have added karmic-proposed to my list of repositories, but I cannot
> seem to find ubuntuone-storage-protocol. However, in Synaptic I see
> python-ubuntuone-storageprotocol, and that package seems to be
> upgradable from 1.0.0-0ubuntu1 (from karmic) to 1.0.1-0ubuntu1 (from
> karmic-proposed). Should I install this package and report the results?

Please do. ubuntuone-storage-protocol is the source package name,
python-ubuntuone-storageprotocol is the binary package (.deb).

> Also, it seems that I can upgrade ubuntuone-client to version
> 1.0.3-0ubuntu1. Should I go ahead and upgrade this package while I wait
> for ubuntuone-storage-protocol to appear?

Reporting testing results is highly appreciated. Please see
http://people.canonical.com/~ubuntu-archive/pending-sru.html and
search for "ubuntuone-client" to get a list of bugs that this version
fixes. Please give feedback in those particular bugs.

Thanks!

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Úr Balázs (urbalazs) wrote :

Confirm on FUJITSU SIEMENS AMILO L7320

Ash Goodman (ash-ashdezign) wrote :

confirmed: happening on Dell Inspiron

Happening on Toshiba Satellite M30. Doesn't seem to happen when on AC power, only when on battery.

papukaija (papukaija) wrote :

The package from karmic-proposed fixes this bug.

Talha Khan (tkhan4486) wrote :

I have tested only upgrading python-ubuntuone-storageprotocol to 1.0.1-0ubuntu1:

Please note that I am on a laptop with a wireless connection.

-Ubuntu one connects after restarting the computer, logging out/back in, and switching users and back.
-When disabling wireless or networking after connecting to Ubuntu one, the disconnected icon comes up, but no error message appears. When wireless or networking is enabled, Ubuntu one connects with no errors.
-When performing suspend or hibernate, Ubuntu one sometimes connects, sometimes gives an error message.

I will come up with results after upgrading ubuntone-client later

Roman Yepishev (rye) wrote :

I have tested this with ubuntuone client 1.0.3-0ubuntu1 (karmic-proposed).

The syncdaemon does not crash anymore when the system returns from suspend.

However, in case a file is being uploaded while computer is suspended then syncdaemon becomes stuck in STANDOFF_WAITING_WITH_NETWORK_WITH_BOTH state. It does not upload the old file and new files do not get uploaded as well. This is a separate bug #487257.

Rick McBride (rmcbride) wrote :

I've also verified that it no longer crashes resuming from suspend. I did not observe a stuck syncdaemon state, but it's reasonable to expect that there is some connection.

Martin Pitt (pitti) on 2010-02-05
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.3-0ubuntu1

---------------
ubuntuone-client (1.0.3-0ubuntu1) karmic-proposed; urgency=high

  * New upstream release
    - Remove patch files now in upstream for #462828
    - Require python-ubuntuone-storageprotocol >= 1.0.1
    - BadTransition: SYS_CONNECTION_MADE (LP: #457147)
    - ValueError: invalid literal for int() with base 10: 'None' (LP: #476777)
    - Protocol version error with bw throttling enabled (LP: #455544)
    - Folder deletion from other machines results in conflicts (LP: #462003)
    - Syncdaemon doesn't disable throttling (LP: #483592)
    - Syncdaemon crashes with NoAccessToken (LP: #488413)
    - Error creating share from Nautilus: callback() (LP: #492100)
    - Work without NetworkManager installed (LP: #357395)
    - Create a POT during the build (LP: #455527)
    - Bring back timestamps in oauth-login.log (LP: #459175)
    - Applet starts syncdaemon without a token (LP: #491573)
    - Prefs changes don't take immediate affect (LP: #457564)
    - BW limit settings don't appear to be saved (LP: #465030)
    - Distinguish auth errors from other errors (LP: #450633)
    - Fix for running on python < 2.6.3 (LP: #451670)
 -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 15:45:52 -0500

Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-storage-protocol - 1.0.1-0ubuntu1

---------------
ubuntuone-storage-protocol (1.0.1-0ubuntu1) karmic-proposed; urgency=low

  * New upstream release
    - Avoid extra throttling and bytes message calls (LP: #479204)
    - Correctly raise StorageRequestError on ERROR (LP: #450633)
    - Avoid double connection factory confusion (LP: #457147)
 -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 14:30:00 -0500

Changed in ubuntuone-storage-protocol (Ubuntu Karmic):
status: Fix Committed → Fix Released
Sjums07 (h-m-m-b-l) on 2010-02-16
Changed in ubuntuone-client:
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
status: Fix Released → Incomplete
dobey (dobey) on 2010-02-16
Changed in ubuntuone-client:
status: Incomplete → Fix Released
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntuone-storage-protocol (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntuone-storage-protocol:
status: Fix Released → In Progress
status: In Progress → Confirmed
Changed in ubuntuone-client (Ubuntu):
status: Fix Released → Confirmed
Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Released → Fix Committed
Changed in ubuntuone-storage-protocol (Ubuntu):
status: Fix Released → Fix Committed
Changed in ubuntuone-storage-protocol:
status: Confirmed → Fix Released
Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in ubuntuone-storage-protocol (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Invalid
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released

Well, I still get Ubuntu One crashes after resuming from suspend if there is no internet conneciton available.

Nigel Titley (nigel) wrote :

Likewise. Just got one. If you are on a wireless connection and it it not available when coming out of suspend then it crashes.

Once it has crashed it seems to need a reboot before it can be started again.

Nigel Titley (nigel) wrote :

Belay that last comment. Starting it by hand seems to be OK

DavidZemon (david-zemon) wrote :

still crashing for me as well. I'm always on wireless, never ehternet.
HP EliteBook 8530w

cement_head (andorjkiss) wrote :

This crashes for me as well - HP6910p using Karmic Koala

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:qt4-3.1-ia32:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic

dobey (dobey) on 2010-12-20
Changed in ubuntuone-client (Ubuntu Lucid):
status: New → Fix Released
Changed in ubuntuone-storage-protocol (Ubuntu Lucid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers