ubuntuone-syncdaemon crashed with OSError in __init__() (symlink on shares)

Bug #452682 reported by Sashin on 2009-10-16
140
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-2
Medium
Guillermo Gonzalez
Trunk
Medium
Guillermo Gonzalez
ubuntuone-client (Ubuntu)
Medium
dobey
Lucid
Undecided
Unassigned

Bug Description

When the symlink for ~/Ubuntu One/Shared With Me gets changed to a non-existant file, syncdaemon throws an exception and stops working. Exception from syncdaemon-exceptions.log looks like this:

  File "/usr/lib/ubuntuone-client/ubuntuone-syncdaemon", line 184, in <module>
    main(sys.argv)
  File "/usr/lib/ubuntuone-client/ubuntuone-syncdaemon", line 134, in main
    ignore_files=options.ignore)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py", line 108, in __init__
    self.vm = volume_manager.VolumeManager(self)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/volume_manager.py", line 312, in __init__
    os.symlink(self.m.shares_dir, self.m.shares_dir_link)
OSError: [Errno 17] File exists

-----------------------------------------------------------------------

TEST CASE:

From a terminal session, run:

u1sdtool -q
cd ~/Ubuntu\ One
rm Shared\ With\ Me
ln -s foo Shared\ With\ Me
u1sdtool --start

Expected result: Shared With Me symlink points to ~/.local/share/ubuntuone/shares and files in Shared With Me folder are accessible.

-----------------------------------------------------------------------

Binary package hint: ubuntuone-client

If I open ubuntu one nothing happens for a while and I get this error.

ProblemType: Crash
.home.sashin..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 bookmarked = False
 connected = False
 connect = 0
 show_applet = 0
Architecture: amd64
Date: Fri Oct 16 12:00:50 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
InterpreterPath: /usr/bin/python2.6
Package: ubuntuone-client 1.0.1-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_AU.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
PythonArgs: ['/usr/lib/ubuntuone-client/ubuntuone-syncdaemon']
SourcePackage: ubuntuone-client
Tags: ubuntu-unr
Title: ubuntuone-syncdaemon crashed with OSError in __init__()
Uname: Linux 2.6.31-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare

Related branches

Sashin (sashin) wrote :
tags: removed: need-duplicate-check
Mark G. Saye (markgsaye) wrote :

Sashin, thanks for your bug report. According to the syncdaemon-exceptions log file, there seems to be a problem accessing the directory: /home/sashin/.local/share/ubuntuone/shares - please could you check the existence and permissions of that directory, and let us know what you find? Thanks.

Yes, this folder exists and it looks like it can only be affected by
root.

Do you remember running anything related to ubuntu one as root, and/or modifying permissions manually which could have caused this? The ubuntu one client does not normally run as root, and hence should not be able to change file permissions like this.

Changed in ubuntuone-client (Ubuntu):
status: New → Incomplete
importance: Undecided → High
Joshua Hoover (joshuahoover) wrote :

Hi Sashin, As Eric already stated, Ubuntu One should not be run as root. If you installed or ran Ubuntu One as root, then you will likely have problems like this. If you did not install or run Ubuntu One as root, please let us know and we'll look into it further. Thank you, Joshua

Changed in ubuntuone-client (Ubuntu):
importance: High → Undecided
assignee: nobody → Joshua Hoover (joshuahoover)
tags: added: bugpattern-needed
Duane Hinnen (duanedesign) wrote :

recent exception log from a duplicate.

2010-04-05 21:42:43,288 - ubuntuone.SyncDaemon - ERROR - Unexpected error
Traceback (most recent call last):
  File "/usr/lib/ubuntuone-client/ubuntuone-syncdaemon", line 184, in <module>
    main(sys.argv)
  File "/usr/lib/ubuntuone-client/ubuntuone-syncdaemon", line 134, in main
    ignore_files=options.ignore)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py", line 108, in __init__
    self.vm = volume_manager.VolumeManager(self)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/volume_manager.py", line 312, in __init__
    os.symlink(self.m.shares_dir, self.m.shares_dir_link)
OSError: [Errno 17] File exists

Changed in ubuntuone-client (Ubuntu):
status: Incomplete → New
Lucio Torre (lucio.torre) wrote :

it seems to me that this bug has been hijacked with a new error. As it already has many duplicates assigned and the old error does not have any new information, ill make this bug about the second error, the failing symlink.

summary: - ubuntuone-syncdaemon crashed with OSError in __init__()
+ ubuntuone-syncdaemon crashed with OSError in __init__() (symlink on
+ shares)
Changed in ubuntuone-client (Ubuntu):
assignee: Joshua Hoover (joshuahoover) → Lucio Torre (lucio.torre)
status: New → Confirmed
Changed in ubuntuone-client (Ubuntu):
assignee: Lucio Torre (lucio.torre) → Guillermo Gonzalez (verterok)
Guillermo Gonzalez (verterok) wrote :

Hi,

Can anyone of the affected by this bug paste the output of:

ls -la ~/Ubuntu\ One/Shared\ With\ Me

Thanks!

Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntuone-client:
status: New → In Progress
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Confirmed
Changed in ubuntuone-client:
assignee: nobody → Guillermo Gonzalez (verterok)
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu):
milestone: none → lucid-updates
Changed in ubuntuone-client (Ubuntu):
assignee: Guillermo Gonzalez (verterok) → nobody
tags: added: u1-lucid-sru
description: updated
description: updated
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)

Accepted ubuntuone-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Joshua Hoover (joshuahoover) wrote :

Test case passed with 1.2.2-0ubuntu2 proposed installed.

Martin Pitt (pitti) wrote :

Since it was fixed in trunk a while ago, I assume that maverick's current version (1.3.2) has the fix as well. Closing all the maverick tasks.

tags: added: verification-done
removed: verification-needed
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

ubuntuone-client (1.2.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release.
    - Properly handle valid UTF-8 non-ASCII names for UDFs (LP: #557160)
    - Fix nautilus crash when running u1sdtool --subscribe-folder (LP: #570261)
    - Cannot reactivate "File sync" on services tab (LP: #570721)
    - Retry interrupted uploads (LP: #575817)
    - Improve logging at INFO level (LP: #578248)
    - u1sdtool --delete-folder with invalid id hangs (LP: #583412)
    - ubuntuone-syncdaemon crashed with OSError (LP: #452682)
    - ubuntuone-preferences "Got empty result for devices list." (LP: #576263)
  * Rmmove fix-571548.patch and fix-567223.patch; included upstream now.
 -- Rodney Dawes <email address hidden> Wed, 16 Jun 2010 13:42:32 -0400

Changed in ubuntuone-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
Mitch Towner (kermiac) wrote :

Set report to "public" as people from duplicates are asking about the status of the "master" bug report. There does not appear to be any private/sensitive data within this report.

visibility: private → public
To post a comment you must log in.