connects to server even if autoconnect is set to 'never'

Bug #451154 reported by Andreas Schildbach on 2009-10-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
dobey
ubuntuone-client (Ubuntu)
High
dobey
Nominated for Karmic by dobey

Bug Description

Binary package hint: ubuntuone-client

Even if I set ubuntuone-client to connect never, I get on each login a Firefox instance thrown at me with that authenticate dialog.

Ubuntu One should be made much less intrusive. Let annoying auto-popups stay in the Windows realm.

ProblemType: Bug
.home.aschildbach..cache.ubuntuone.log.syncdaemon.exceptions.log:

.home.aschildbach..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 bookmarked = True
 connected = False
 connect = 2
 show_applet = 1
Architecture: i386
Date: Wed Oct 14 12:24:43 2009
DistroRelease: Ubuntu 9.10
Package: ubuntuone-client 1.0.1-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SourcePackage: ubuntuone-client
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:2805): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2805): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2840): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2834): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Related branches

Andreas Schildbach (schildbach) wrote :
Kåre Birger Lapstuen (lapstue) wrote :

I'm also experiencing this, might be connect to the server problems mentioned in bug #450582

https://bugs.launchpad.net/ubuntu/+source/ubuntuone-client/+bug/450582

Andreas Schildbach (schildbach) wrote :

How could this be a server problem if the client should not even try to connect?

Andreas Schildbach (schildbach) wrote :

Unduplicating, because the duplicate bug is a server problem.

This problem however, cannot be caused by the server because the client is not allowed to connect the server in the first place. I will update the description to make this clearer.

summary: - throws 'Authenticate to Ubuntu One' web-dialog at me on each login
+ connects to server even if autoconnect is set to 'never'
dobey (dobey) wrote :

Sorry. I thought the bug was about the fact that it keeps asking to reauthorize. Thanks for clarifying.

Changed in ubuntuone-client:
status: New → In Progress
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → High
assignee: nobody → Rodney Dawes (dobey)
dobey (dobey) on 2009-10-15
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2009-10-16
Changed in ubuntuone-client (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.2-0ubuntu1

---------------
ubuntuone-client (1.0.2-0ubuntu1) karmic; urgency=low

  * New upstream release.
    - Avoid conflicts due to bouncing FS events (LP: #449605)
    - Don't try to authorize if connect on start is never (LP: #451154)

 -- Rodney Dawes <email address hidden> Fri, 16 Oct 2009 13:35:00 -0400

Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
dobey (dobey) on 2009-11-30
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers