Entire Hard Drive Marked as ubuntuone-synchronized

Bug #450112 reported by tim_o on 2009-10-13
540
This bug affects 131 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Critical
dobey
ubuntuone-client (Ubuntu)
Critical
dobey
Nominated for Karmic by dobey

Bug Description

Binary package hint: ubuntuone-client

Every file on my root hard drive is suddenly showing the green check mark emblem.

The file properties dialog indicates that this emblem is ubuntuone-synchronized. Unchecking the emblem and closing the file properties dialog does not make it go away.

It doesn't seem that Ubuntu One is trying to actually sync them up.

ProblemType: Bug
.home.tim..cache.ubuntuone.log.syncdaemon.exceptions.log:

.home.tim..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 bookmarked = True
 connected = False
 connect = 0
 show_applet = 0
Architecture: amd64
Date: Mon Oct 12 23:16:35 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia wl
Package: ubuntuone-client 1.0.0-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
SourcePackage: ubuntuone-client
Uname: Linux 2.6.31-13-generic x86_64

Related branches

tim_o (tle) wrote :

Hello. Thank you for taking the time to report this bug. I can confirm this on a just updated and rebooted Karmic. Nearly all (not all) files are marked as synced with a green check mark, but are not subject to synchronisation.

Assigning ubuntu-desktop-bugs for further investigation.

Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: New → Confirmed
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)

i can confirm this bug in my karmic install

Simple use case for reproduce :
$ touch /tmp/test
$ nautilus /tmp/

You will see the "u1 synced" emblem in the "test" file but obviously u1 client has nothing to sync from my /tmp.
I hope the solution to this bug will revert this emblems.

Stuart Langridge (sil) on 2009-10-13
tags: added: ubuntuone-karmic
Anton Kraus (done) wrote :

I can confirm that this bug affects all four of my local hard drives.
Samba shares do not show this behaviour, however.

The bug only appears when the Humanity icon theme (light or dark variant) is in use.

Nicklas W Bjurman (lordmetroid) wrote :

This bug happens to me to.
I tried to make a samba share, all required packages to do so was apparently not installed per default.
Before I installed them samba packages(can not remember exactly which two packages that was downloaded) all worked fine, but afterwards all files and folders on my entire system was marked with the ubuntuone-synchronized emblem.

James Lewis (james-fsck) wrote :

Just updated by test laptop, and see the green ticks everywhere also. you cannot remove them in properties either!

Changed in ubuntuone-client (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Rodney Dawes (dobey)
importance: Undecided → High
status: Confirmed → Triaged
Changed in ubuntuone-client:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Rodney Dawes (dobey)
emarkay (mrk) wrote :

Also confirmed this is still an issue after this morning's updates (which included another .13 kernel for reference.).

dobey (dobey) on 2009-10-13
Changed in ubuntuone-client:
status: Triaged → In Progress
importance: High → Critical
Jerry Casiano (jerrycasiano) wrote :

Seriously? Nobody caught this... wow, lmao!

Oh well, minor annoyance on an otherwise solid system.

Nicklas W Bjurman (lordmetroid) wrote :

Jerry Casiano,
During the alpha releases this bug was not present.

Jerry Casiano (jerrycasiano) wrote :

Yeah... I realize that.

But are you saying that the developers just upload changes without any testing whatsoever?

You can't be serious. If that were the case I doubt my system would even boot...

I assume when they make changes they actually install the result on a test system and have a quick look around before uploading to the repository. I assume they do that even on unreleased systems, especially this close to a release.

But then again, I know what they say about assuming...

Nicolas DERIVE (kalon33) wrote :

JerryCasiano : It might not happen on all systems. I just upgraded to latest ubuntuone-client, but as I've not restarted, I don't see it on this computer (but I saw it on my netbook because I have rebooted). Maybe the test was done using it but not rebooting so the problem was not caught. You're using something which is still a beta, it may have some bugs and some might be introduced before RC freeze, that something we should kept somewhere in our minds though.

Christian Berg (xeniac) wrote :

Since the last Update for Karmic my complete Hardrive is also tagged with "Ubuntu One Syncronised", on both Machines, an 64Bit Ubuntu Desktop and Ubuntu 9.10 Netbook Remix.

dobey (dobey) on 2009-10-13
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2009-10-13
Changed in ubuntuone-client (Ubuntu):
importance: High → Critical
Changed in ubuntuone-client:
milestone: none → 1.0.1
Jerry Casiano (jerrycasiano) wrote :

@Nicolas

Oh, this is a Beta release, really ? I didn't realize that... o_0

and to any other fanboys that I may have inadvertently offended... I'll quote my first message, in case it didn't sink in the first time

"Oh well, minor annoyance on an otherwise solid system."

// And now that this is fixed I have no reason to care anymore, so flame away

ego-sum-deus (shawnwitham) wrote :

I can confirm that the most recent update causes this. There was an update to the human icon theme and after a reboot, the ubuntuone checkmarks appeared. also, it shows up on the other partitions in the HDD (for example, my OSX partition also has all the checkmarks). there are other mess-ups in the icon theme: the CD/DVD Drive icon shows an iPod, along with my OSX partition icon. This sort of makes sense for the OSX filesystem icon, but not with the CD/DVD Drive icon.

@JerryCasiano
As Nicolas DERIVE already mentioned, not all OS configuration is the same, maybe in the test machine bug didn't show up. And yes, using beta means that such errors will happen - this is not a security-targeted time, so nobody will bother to spend a couple of days testing for every possible bug. If You're not happy with that, don't use beta. It's that simple.

Will 1.0.1 update incorporate a fix to the affected icons?

@ego-sum-deus
For me every mounted FS seen on a desktop has an iPod icon... Is there a separate bug report for this?

ego-sum-deus (shawnwitham) wrote :

@Michał Gołębiowski

same here: flash drive, external/internal hard drive, cd/dvd, all have iPod icon. i don't think there is a separate bug for this..nothing came up with a search for "ipod icon", "filesystem icon", or "osx icon". switching to a different icon theme takes care of the ubuntuone checkmark emblem, but it does not solve the iPod icon issue...so i think it is a totally separate bug.

I can confirm this bug as well

@ego-sum-deus
I'd report it but I'm not sure which package it should go against. Definitely not human-icons-theme as when I changed my theme to some accesible one (high contrast, ugly icons etc.) there were very different icons for drives, but they looked like speakers, so it seems they are visible to OS as media-player devices or sth like that.

This bug affects me too...

I have purged all ubuntuone pages.. and reboot...

but the emblem is still there...

i cant remove it!

ego-sum-deus (shawnwitham) wrote :

@Michał Gołębiowski
yes, i am trying to figure out which package is doing this. i will report once i get it pinned down.

@Tom Rauthe
i have purged all ubuntuone packages, did a reboot, and it DID fix the emblems. maybe try another reboot. if that doesn't work, try to change to another icon theme, then back to the Humanity theme...that might do it.

@ego-sum-deus

thanks... i rebootet a second time....
and sitched the ubuntu-themes....

now the tickes are away :)

thank you!

ego-sum-deus (shawnwitham) wrote :

@Michał Gołębiowski

https://bugs.launchpad.net/ubuntu/+source/devicekit-disks/+bug/450540

a bug report has been submitted and a fix is committed for the media player icon on external/internal devices.

dobey (dobey) on 2009-10-13
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.1-0ubuntu1

---------------
ubuntuone-client (1.0.1-0ubuntu1) karmic; urgency=low

  * New upstream release.
    - Only add emblems to files under the Ubuntu One folder (LP: #450112)
    - Support having an -idle icon for other themes (LP: #438641)
    - Fix ValueError when updating completed (LP: #450140)
    - Fix AttributeError crash in syncdaemon (LP: #440908)

 -- Rodney Dawes <email address hidden> Tue, 13 Oct 2009 18:45:00 -0400

Changed in ubuntuone-client (Ubuntu):
status: Triaged → Fix Released
Andros83 (mail-ceandrea) wrote :

With this update the problem is fixed!
Thanks!

mabawsa (mabawsa) wrote :

Fixed here. TY

tsger (tsgermany) wrote :

When will the new package be added to the repos? I only see version 1.0.0-0

tsger (tsgermany) wrote :

Update to previous post: The mirror I was using hasn't updated yet. I switched to the main US repo server, and the updates are there.

On Wed, 2009-10-14 at 15:28 +0000, tsger wrote:
> When will the new package be added to the repos? I only see version
> 1.0.0-0
>

It was uploaded to main archive last night. It might take some time for
your mirror to catch up though.

tim_o (tle) wrote :

I can confirm that the issue is fixed on my install.

Cees de Groot (casedeg) wrote :

same here - fixed since upgrade

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers