AttributeError: 'NoneType' object has no attribute 'path'

Bug #440908 reported by Joey Stanford on 2009-10-02
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Critical
Guillermo Gonzalez
ubuntuone-client (Ubuntu)
Critical
Guillermo Gonzalez
Nominated for Karmic by dobey

Bug Description

Binary package hint: ubuntuone-client

apport picked up an client applet crash. Not really sure what it is. probably a dupe but reporting anyway.

ProblemType: Bug
Architecture: i386
CheckboxSubmission: cbd66e76023689ba0d9f5f41745564b1
CheckboxSystem: b1865df84255b8716d3bcc269ff410d1
Date: Fri Oct 2 14:58:18 2009
DistroRelease: Ubuntu 9.10
Package: ubuntuone-client 0.95.1-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: ubuntuone-client
Tags: ubuntu-unr
Uname: Linux 2.6.31-11-generic i686

Related branches

Joey Stanford (joey) wrote :
Joshua Hoover (joshuahoover) wrote :

Hi Joey, OK, I've seen this at least once before (in a newer bug). I'm going to use your bug as the one we mark any dupes against and I'm assigning this to one of the devs to look into. Thank you, Joshua

Changed in ubuntuone-client (Ubuntu):
status: New → Triaged
importance: Undecided → High
tags: added: ubuntuone-karmic
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → John Lenton (chipaca)
assignee: John Lenton (chipaca) → Guillermo Gonzalez (verterok)
Changed in ubuntuone-client:
status: New → Triaged
assignee: nobody → Guillermo Gonzalez (verterok)
importance: Undecided → High
summary: - [karmic] applet crash on karmic beta unr
+ AttributeError: 'NoneType' object has no attribute 'path'
Guillermo Gonzalez (verterok) wrote :

Hi Joey!

I was able to reproduce the error...but only after nuking some metadata, so looks like the metadata of a share is broken in your install :(

ATM, and in the time frame imposed by karmic, the best solution I can think of is to handle the brokeness by invalidating the share and cleaning up all metadata related to the broken share.
The side effects of this apporach is that the files/folders in the share are (quite probably) going to be marked as conflicts (renamed to <name>.u1conflict)

I'm already have a branch that fix this as described, but I'm doing some tests IRL.

Regards,

Changed in ubuntuone-client:
status: Triaged → In Progress
dobey (dobey) on 2009-10-13
Changed in ubuntuone-client (Ubuntu):
importance: High → Critical
Changed in ubuntuone-client:
importance: High → Critical
dobey (dobey) on 2009-10-13
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2009-10-13
Changed in ubuntuone-client:
milestone: none → 1.0.1
dobey (dobey) on 2009-10-13
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.1-0ubuntu1

---------------
ubuntuone-client (1.0.1-0ubuntu1) karmic; urgency=low

  * New upstream release.
    - Only add emblems to files under the Ubuntu One folder (LP: #450112)
    - Support having an -idle icon for other themes (LP: #438641)
    - Fix ValueError when updating completed (LP: #450140)
    - Fix AttributeError crash in syncdaemon (LP: #440908)

 -- Rodney Dawes <email address hidden> Tue, 13 Oct 2009 18:45:00 -0400

Changed in ubuntuone-client (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers