Ubuntu One hook error, not python3 compatible

Bug #1098128 reported by Dimitri John Ledkov on 2013-01-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Packaging-dailies
Undecided
dobey
Stable-4-0
Undecided
Unassigned
Stable-4-2
Undecided
dobey
Trunk
High
dobey
ubuntuone-client (Ubuntu)
High
Unassigned
Quantal
Medium
Unassigned
Raring
High
Unassigned

Bug Description

apport hook is missing dependencies?
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport/report.py", line 195, in _run_hook
    exec(compile(fd.read(), hook, 'exec'), symb)
  File "/usr/share/apport/package-hooks/source_ubuntuone-client.py", line 36, in <module>
    from dirspec.basedir import xdg_cache_home, xdg_config_home
ImportError: No module named 'dirspec'

noticed in bug 1098127

Related branches

dobey (dobey) wrote :

This is actually a problem of apport running under python3 and loading hooks for apps that are using python2, and not having hooks in a separate directory for python3-using apps, since python3 breaks compatibility.

affects: ubuntuone-client (Ubuntu) → apport (Ubuntu)
Bryce Harrington (bryce) on 2013-01-19
summary: - hook error
+ ubuntuone-client hook error, not python3 compatible

The hook itself comes from the python-ubuntuone-client package, so I've added a bugtask for that. All apport hooks have to be moved to python3 now.

Leaving the apport bugtask open for now, for the request that python2 hooks still be allowed. However, I suspect this will be WONTFIX, since I understand the plan of record is to eventually move away from python2 entirely, so all hooks must be migrated.

Barry Warsaw (barry) wrote :

Just a note that LP: #1077089 is a requirement for ubuntuone-client port to Python 3. Please look at that bug's attached m-p.

no longer affects: apport (Ubuntu)
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
Changed in ubuntuone-client (Ubuntu Raring):
status: Confirmed → Triaged
Changed in ubuntuone-client (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu Raring):
importance: Undecided → High
Changed in ubuntuone-client (Ubuntu Quantal):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in ubuntuone-client (Ubuntu Raring):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in ubuntuone-client:
status: New → Confirmed
assignee: nobody → Dmitrijs Ledkovs (xnox)
Dimitri John Ledkov (xnox) wrote :

The hook does not call any ubuntuone-client api.
I made the hook bi-lingual (both valid under python2 and python3)
This needs a python3-dirspec dependency to run the apport hook.
Please review linked branch merge proposals.

dobey (dobey) wrote :

Why was apport removed from this bug? Was another bug opened, or does one already exist, about apport outright breaking support for all the python2-using applications in the Ubuntu archive?

dobey (dobey) on 2013-01-31
summary: - ubuntuone-client hook error, not python3 compatible
+ Ubuntu One hook error, not python3 compatible
Julien Funk (jaboing) on 2013-01-31
tags: added: u1-by-dev u1-on-production u1-ubuntu
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 4.1.90-0ubuntu2

---------------
ubuntuone-client (4.1.90-0ubuntu2) raring; urgency=low

  * debian/control:
    - Remove gir1.2-indicate dependencies. (LP: #1112544)
    - Add indicator-sync to recommends. (LP: #1053482)
    - Add python3-dirspec to dependencies. (LP: #1098128)
  * debian/patches/00_apport_py3.patch:
    - Cherry pick patch from trunk to allow apport hook to work with
      Python 3 versions of apport. (LP: #1098128)
 -- Rodney Dawes <email address hidden> Fri, 01 Feb 2013 14:27:33 -0500

Changed in ubuntuone-client (Ubuntu Raring):
status: Triaged → Fix Released
Changed in ubuntuone-client (Ubuntu Quantal):
assignee: Dmitrijs Ledkovs (xnox) → nobody
Changed in ubuntuone-client (Ubuntu Raring):
assignee: Dmitrijs Ledkovs (xnox) → nobody
Adolfo Jayme (fitojb) on 2014-05-04
Changed in ubuntuone-client (Ubuntu Quantal):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers