package python-ubuntuone-client 1.2.2-0ubuntu2.2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1009573 reported by Hunter on 2012-06-06
88
This bug affects 11 people
Affects Status Importance Assigned to Milestone
ubuntuone-client (Ubuntu)
High
Marc Deslauriers

Bug Description

This issue is already fixed with a new uploaded version.

Please update package index and upgrade again:
sudo apt-get update
sudo apt-get upgrade
or use the Update Manager.

after update, error message came up, E: python Ubuntu One client subprocess installed post installation script error exit status 1
E: ubuntu one-leaving unconfigured, etc.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: python-ubuntuone-client 1.2.2-0ubuntu2.2
ProcVersionSignature: Ubuntu 2.6.32-41.89-generic 2.6.32.59+drm33.24
Uname: Linux 2.6.32-41-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Jun 6 11:00:53 2012
ErrorMessage: subprocess installed post-installation script returned error exit status 1
PackageArchitecture: all
SourcePackage: ubuntuone-client
Title: package python-ubuntuone-client 1.2.2-0ubuntu2.2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

CVE References

Hunter (sproingulator) wrote :
Alejandro J. Cura (alecu) wrote :

Hi Hunter,

it seems that python2.5 is the version installed in your system, but Lucid came with python2.6, and Ubuntu One is expecting that version.

Can you please confirm if you have manually installed python 2.5, or if this is just a standard installation?

thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Marc Deslauriers (mdeslaur)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.2.2-0ubuntu2.3

---------------
ubuntuone-client (1.2.2-0ubuntu2.3) lucid-security; urgency=low

  * REGRESSION FIX: Python 2.5 compatibility issue (LP: #1009573)
    - debian/patches/CVE-2011-4409.patch: use "Exception, e" instead of
      "Exception as e" for Python 2.5 compatibility.
 -- Marc Deslauriers <email address hidden> Wed, 06 Jun 2012 13:12:48 -0400

Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
Roman Yepishev (rye) on 2012-06-15
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers