Ubuntu

No Nautilus integration

Reported by Shaun P on 2013-09-27
264
This bug affects 55 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Saucy
Low
Unassigned
ubuntuone-client-gnome (Ubuntu)
Low
Unassigned

Bug Description

On 13.10/Saucy using “ubuntuone-client” 13.08-0ubuntu2.

Due to bug #1196684 "Drop ubuntuone-client-gnome from archive" being "fixed", the Nautilus extension is gone and the current Ubuntu One packages don't provide this functionality. This means, for example, you can't get a share link for a file via the context menu in the file manager. I believe (I may be wrong) the only way to manage the sharing of files/folders is via the U1 website now.

Discussion:
http://www.reddit.com/r/Ubuntu/comments/1pdp1z/a_product_in_decline_ubuntu_one_nautilus/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
Matthew Gregg (mcg) wrote :

Is the intention to only provide this functionality on the U1 website or is this going to re-appear in Nautilus? I switched to U1 due to tight integration within Ubuntu, but it appears to be less and less integrated. Disappointing.

Matthew Gregg (mcg) wrote :

Also, it's not just "share link" management that is gon, the status of files(in sync, syncing, etc..) are no longer shown in Nautilus as emblems on files handled by U1.

Shaun P (sigmagammapi) wrote :

With Saucy final due in only 3 days I'm certain this isn't going to be sorted out for 13.10...

I got back the Raring U1 functionality by downloading and installing some packages from Raring:-

ubuntuone-client-gnome
https://launchpad.net/ubuntu/+source/ubuntuone-client-gnome/4.2.0-0ubuntu1

libsyncdaemon
https://launchpad.net/ubuntu/+source/ubuntuone-client/4.2.0-0ubuntu1

I believe those are the only packages I needed.

I'm disappointed that U1 is being whittled down like this, ostensibly so that U1 will be easier to maintain across releases. It does break a lot during the development cycles. Maybe someone will put in some extra work to bring U1 up to spec for 14.04.

TomasHnyk (sup) wrote :

Shaun P: thanks for the hint, it indeed works, the links to the files needed are these (install with sudo dpkg -i):
http://launchpadlibrarian.net/135421143/ubuntuone-client-gnome_4.2.0-0ubuntu1_amd64.deb
http://launchpadlibrarian.net/135422714/libsyncdaemon-1.0-1_4.2.0-0ubuntu1_amd64.deb

I do not understand what is the point of Ubuntu one then? I will revert to dropbox once this stops working as sync from the file manager is much more useful then using the web and dropbox offers that as far as I know.

James Tait (jamestait) wrote :

Note that the sync functionality is provided by ubuntuone-syncdaemon, and is unaffected. You can still drop files in a synchronised folder from your file manager, or the command line, or from any other program, and they will continue to be synchronised as they are now.

You can share a file already in your cloud by clicking the sync indicator and selecting "Share a File" from the drop-down. The Ubuntu One Control Panel will open at the "Share Links" page. Alternatively you can open the Ubuntu One Control panel directly by selecting "Open Ubuntu One" from the sync indicator drop-down, or by selecting Ubuntu One from the Dash or the Launcher; then select the "Share Links" tab. Here you can enter a filename in the search box and select the file to share from the results, whereupon you will be presented with the public link.

Adding a new folder to your cloud storage is done from the "Folders" tab in the Ubuntu One Control Panel. Click the "Add a folder from this computer" button at the bottom of the tab, and select the folder from the file dialogue. Synchronisation should begin immediately.

To share a folder privately with other Ubuntu One users, such that it will be kept synchronised between their connected devices, you will need to click "Go to the web for public and private sharing options".

Matthew Gregg (mcg) wrote :

James P. Yup, I know all about how to do it that way, but not great at all. The fact Dropbox has better integration than U1 is really sad.

Rodney Dawes (dobey) wrote :

The ubuntuone-client-gnome package was intentionally removed, due to it not fitting in with the direction that Ubuntu is headed, having duplicate functionality with the ubuntuone-control-panel-qt application, and being a source of many strange issues, which the resources do not exist to fix and to continue with ongoing maintenance.

The "Share links" tab in the control panel can be used to share files, which can be accessed by going to the control panel directly, or by using the sync indicator to get to the page, as James mentioned already. The web page is certainly not the only means of using this functionality.

Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Won't Fix
Matthew Gregg (mcg) wrote :

Rodney D. In 13.10 how do I know a file I am looking at in Nautilus is currently in sync with U1 or even should be sync'd? You can't. Going through the control panel or web UI for this is sub-optimal.

Fabrizio Narni (shiba89) wrote :

It's not duplicated functionality! Seeing which files are synced form Nautilus (emblem) is not a duplicated functionality. Stop syncing a folder at all is not duplicated functionality.

Ingo Gerth (igerth) wrote :
description: updated
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → High
status: Won't Fix → Opinion
Changed in ubuntuone-client:
status: New → Opinion
summary: - Substandard Nautilus integration in Ubuntu 13.10
+ No Nautilus integration
Changed in hundredpapercuts:
importance: Undecided → High
status: New → Opinion
Rodney Dawes (dobey) on 2013-10-29
no longer affects: ubuntuone-client
Changed in ubuntuone-client (Ubuntu):
status: Opinion → Won't Fix
Ingo Gerth (igerth) wrote :

Rodney, what do you recommend us users to do? Should we stick with U1 with this uncertain future? I would be interested to hear your personal opinion.

Rodney Dawes (dobey) wrote :

@Ingo, yes, of course I think you should use U1. Ubuntu is simply in a very transitional period as it morphs into a converged platform OS. Ubuntu One is part of Ubuntu, and it will be affected in the same way.

affects: ubuntuone-client (Ubuntu) → ubuntuone-client-gnome (Ubuntu)

I just changed my mind: the control panel is not that inconvenient, but practical indeed: I just tested it. Although having a menu also could be a good idea.

On the other hand, I want my comments not to be hidden. If you feel they can prejudice the project image, simply explain briefly why you made these decisions at this time and what kind of small commitments are you taking.

This will do the job because users are not wanting you to agree with them in everything, but simply to know what is your dedication to quality. If they know there's a properly deliberated reason for your behaviour, they will just trust you: is this simple.

Regards.

Since this bug affect a non-essential aspect and limited scope of the application, it has a priority of "low".

Changed in ubuntuone-client-gnome (Ubuntu):
importance: High → Low

Since this bug:

- Has a difference of opinion.
- The project or package maintainers need to move to other work and are considering the issue closed.
- People are free to continue the discussion.

it has a status of "opinion".

Changed in ubuntuone-client-gnome (Ubuntu):
status: Won't Fix → Opinion

Since this bug is non Ubuntu specific, it affects the "ubuntuone-client-gnome" project.

Changed in ubuntuone-client-gnome:
status: New → Opinion

Rodney; you can revert any of this last changes any time at you own will, by explaining why you choose to do so.

Rodney Dawes (dobey) wrote :

Alberto, I would say the same to you. Please stop spamming the bug report. Bug reports are not the right place to argue about whether you think a maintainer should do something or not.

Changed in ubuntuone-client-gnome (Ubuntu):
status: Opinion → Won't Fix
no longer affects: ubuntuone-client-gnome
Rodney Dawes (dobey) wrote :

This has nothing to do with the upstream code in ubuntuone-client-gnome. The code is still there. Anyone is free to grab the source code and attempt to build and install it on their system. The complaint filed in this bug report is only about Ubuntu. The package is not shipped in other distributions.

No update to Ubuntu 13.10 is going to bring the package back in it, either. And the "hundred paper cuts" project is not a fitting place to complain about it. So it shouldn't be filed against that either, but I can't remove that from the affects list.

TomasHnyk (sup) wrote :

Why is not this a dupe of bug 1242450? seb128 is willing to fix this and it seemed that that bug should be used to track this issue.

Rodney Dawes (dobey) wrote :

Tomas, because that bug is a dupe of this one. Seb is aware of the bugs. If he wants to get the necessary packages into archive for 14.04 LTS in universe to make it work, then he will. What bug is a dupe of what, is irrelevant to that.

TomasHnyk (sup) wrote :

Alright, only it would make sense for the bug to be open if he is willing to fix it :-) (which the other one is).

Rodney Dawes (dobey) wrote :

@Tomas, they are the same bug ('this thing that used to be there isn't there").

TomasHnyk (sup) wrote :

Yeah, I know, only that this one is a master bug and is closed, which seems a bit weird if somebody is going to fix it. That you will not upload it back does not mean somebody else will not, hence I do not understand why this is marked as wont fix. If seb is going to fix it anyway, that this is discussion is rather pointless, but maybe it would be easier for people coming to this bug anew.

adutzu89 (verbanady) wrote :

This is a bugg and should be treated as one, since Ubuntu one is integrated in the installer and is no more integrated in Files.

Perhaps we will like us to calm down a bit, to take a deep breath, and make this report something constructive.

A very constructive way of going about it is if someone who's knowledgeable about the issue tell us what is it that's to be mantained and how hard it is to do it. What are the things that need to be done and how often such issues come up. I am a programmer myself but a very inexperienced one, but willing to help. I believe there are many in the same situation here who could adopt this package. But the last time I tried to fix a simple bug I ended up looking at a nightmarish badly documented C++ with all kinds of pointers and such.

So, to sum it up: someone, please, give us an outlook of the Ubuntu One structure, what is essential, what is not and what are the good practices that we can't ignore and what are the bad ones that are in need of change and could use some dev love. After that, tell us what kind of compromise the new mantainers need to make so that this package will come back to Ubuntu.

Rodney Dawes (dobey) wrote :

@Tomas If seb is going to fix the bug, he'll assign it to himself and open it. If he doesn't have time to fix it, then he won't. I don't know what he plans to do exactly though. It's not as simple as simply re-uploading some source packages to the trusty archive.

Rodney Dawes (dobey) wrote :

@Pablo aside from fixing other bugs in ubuntuone-client-gnome or libsyncdaemon (which ubuntuone-client-gnome requires), there isn't really any "programming" work to do. Ideally, the libsyncdaemon code would be rewritten and made asynchronous and have a cache of public files and such, to work with. However, there is not likely enough time for anyone who wants it done, to do it.

The easiest way to get it back in, is probably to copy the libsyncdaemon code into the ubuntuone-client-gnome tree, change it to build as a static library, and have the g-s-d and nautilus plug-ins in ubuntuone-client-gnome link to the internally built library, and ship that as a patch to the ubuntuone-client-gnome package and upload it back to the archive, demoted to universe.

description: updated
Rodney Dawes (dobey) on 2013-11-05
description: updated
Rodney Dawes (dobey) wrote :

Please don't put any WARNING in the description. Bug descriptions are not to warn people to not comment if they don't have anything constructive to say. Common sense and the Bug Etiquette doc on the wiki is for that.

And if anyone is wanting to post a comment, please make sure it is going to be constructive, and not simply a "me too" or to simply complain. There is etiquette in dealing with bugs. Spamming everyone subscribed to the bug with your "me too" isn't helping anyone, and only annoys people.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers